ArduCopter 2.7.1 will become available on Mission Planner and in the downloads area shortly. This release contains a few important bug fixes as well as the first implementation of the MPU6000 sensor-fusion code. 

Detailed changes are in the commit log. Here's a summary:

New:

- Preliminary support for MPU6000 on board sensor-fusion (DMP)

- AP_Limits: Experimental "bounce" mode, for smaller spaces (LIM_RECMODE)

Bugs:

- Bug fix for yaw error buildup on takeoff

- Fix in Auto mode for failsafe handling

- Fixes to 3-axis camera gimbal code

Views: 37240

Reply to This

Replies to This Discussion

I've been away for a few months. Many versions have passed.

I loaded the code through MP, eeprom erased in CLI and told it to reset.

The motors ESC's were individually manually calibrated from the start and still works with this version.

I did find that I lost track, a few versions ago, that the selection of the proper sonar is important.

The radio was calibrated all options checked and the pids approximate for this quad used.

I had to do a update each time on MP because of the mav version being .9 on the pc and it needed 1.0

It flew like a dream. So well I could talke about it with a fellow in the park confidently doing a few fly by's.

I will play around with some gain settings. Very stable right up to my nose watching. Don't try that at home;-)

From this forum  one week ago

 

Chris:
... it's always a good idea to do a CLI: erase/reset after loading new code, then do a full MP config again.

I then asked since so far I had made erase/reset before loading a new version:

Chris, is it really so: erase/reset AFTER loading new code??

Chris:
Yes, that will reset to the new default settings.

Lars:
Chris,
thanks for the clarification! I think many problems shown in this forum are caused by "small" mistakes, shortways made by us pedestrians.

lars






Chris, it looks like quite a few people are running into this issue with 2.7.1  The EEPROM erase procedures have not solved the problem on my end.

f5pql69,

Did you get 2.7.1 working?  

You may be the only one having this problem, and I'm sure everyone is busy, so no more responses.

What do you mean by " I do not understand anything;"?  You loaded code and have been flying.  You understand a lot!

I just looked over the wiki - its been a while for me.  Its really out of date - it must be impossible to keep up with all the changes in the code - both on the APM side and Mission Planner side.  

So to be clear, you can do a ERASE/RESET after loading of each new software release or not.  If you do not, you get the old parameters.  2.7+ had a lot of good changes, so its best to ERASE/RESET.

For me (I have an APM1), I load each new release to the APM board and then do an ERASE, which clears all stored parameters and then do a RESET which re-loads all parameters to APM memory from the defaults buried in the 2.7+ code.  Be sure to type a capital Y when prompted and then remove power to the APM board to reset the board.   Then reconnect power.  Then, when you change a parameter (like RATE P and STAB P), you must write it to memory, overwriting the value that was loaded during the RESET.   

I have to ask, why were you changing RATE P and STAB P? I would FIRST try the defaults.  2.7 has much better PIDS, even for a non-standard frame.  If I were you, I would load the code, do an ERASE/RESET, re-do all the configuration/setup steps (calibrate radio, hardware setup, etc.) but don't change PIDs yet - just go fly, see how it behaves and then tune PIDs.  

Do I have this right?  You load 2.6 and all is well and load 2.7 and motors behave strangely?

I can't image why your motors would behave differently between software versions.  But, I'm no expert.  Just trying to give back a little.  If you give a bit more info, I'll try to help.

I had a great time with this build.

It works even with a bearing vibrating to the APM2 controller.

http://youtu.be/_Zj0cnDryQ4

Hi! Just a short report.

Just finished my new Quad (X Mode):

APM 2 (FW 271)

4x Skywalker 20 A ESC (currently on high timing, voltage protection/Brake/Gov off, Throttlerange set to 1000-2000)

4x Robbe 2827-26 (smooth running, Multimeter tested: no short to the housing)

4x APC SF 10 Inch 4.7

DJI 450 Frame (so cheap, i could not resist // way too heavy)

FRsky TX/RX: DHT-U /  D4FR sumsignal

Lipo 3S 3300mAh 25C

Ready to start weight incl Lipo: 970gr

Hovertime: About 15 Min

Maiden on Stock PIDs: GOOD , rate P lowered to 0.14 : Perfect flight in stabilized mode, Acro steers still a little bit weird for me (used to MWII). Yaw works well with unchanged PIDs. TODO: Thr/Baro/Loiter PIDs.

My front right ESC (connected to "1") gets significantly warmer than the others (not hot). No failure so far. Motortemps seem to be equal on all 4 Motors. Quad looks pretty balanced. Perhaps i should make it tailheavy to look if the front right ESC reduces temp.

I just wanted to report it, because it is 99.99999% a problem of my cheap ESC. But there is also a minimal chance that it could be a software issue with output No 1.

Cheers

Rob

EDIT: Before i search all the WIKI again ( i know i stumbled across it but cant find it now) my question for future FW upgrades: Does the automatic update do a eepromclear on its own? If not, can i just do the eepromclear from Arduino ide 1.0.1 like i am used to on Mwii, or do i have to do some magic in the missionplanner console like i think i stumbled upon in the wiki?

Martin,

your video is of utmost importance and so are all reports about successful flights. This project needs encouragements to balance the flood of cries for help.

Please show your quad in detail.

Thanks, Martin

Lars

 

 

HI.. could you pleae tell me if'  "'Instant PWM" is coded into the current release..I have six Xaircraft ESC and was hoping to try the APM1 on the HexCopter.

Can you enable it via the Mission Planner..?

 

Thanks

 

Richard

  1. There is a history to how such evolved. Should I google it for you? GIFY? Research is important. It is important to show others what needs to be done.

 

I've installed sonar and AH is fine now.

Also loiter is quite good even with jerky corrections.

Saving my € cents for a Ublox

 

Hi Rob.

Regarding the ESC temperature, how are you powering the board ? Via a separate uBEC or are you using the ESC BEC ? If you are using the ESC from motor number 1 to provide power to the board, it's normal that it gets hotter than the others especially if it has a linear BEC, because linear BECs dissipate power by heat. However I would recomend you use a sepparate uBEC and put it as far as you can from the RX to avoid interference from the switching.

Regarding the clear eeprom, you may enter the mission planner and choose the "terminal" tab. You go into CLI mode (command line), type "setup", then "erase" and "reset" (choose Y) and there you go.

 

Thank you very much for your explanation Rui Manuel!

I am such a Idiot! 30 Min after the post i figured out that i power the APM by the BEC of ESC 1 (like you guessed) of course it it heating more up. A sparate BEC is def. the way to go. My Frsky Telemetry tells me that the D4FR is just getting 4,7V - so i fear a black/brown out of the APM2 because it is on the same line. BTW I didn't put in the zener diode, because i am not a "reverse polarity lover". The erase worked after looking at the wiki again - i did it exactly like you advised, except after entering the terminal you have to give it 3 times <Enter> than the APM2 will drop the pants.

So sorry for my stupidity and cheers for you Rui Manuel!

Rob

Reply to Discussion

RSS

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service