Arducopter 2.7.2 is now in the mission planner and in the downloads area Some positive reports on testing can be found in this discusssion by John Hanson.

Note: just as the release was going out an issue was found re support for the all Camera Gimbals on the APM1s (it doesn't work) and with 3 axis gimbals on the APM2 (2-axis works ok but not 3).  If you're one of these people, please wait for 2.7.3 which will be out shortly. 

 

UPDATE: 2.7.3 is now in the Mission Planner

 

Functional Improvements over 2.7.1:

  • Fast waypoints (Jason) - if the turn angle between two waypoint the copter is less than 60 degrees it does not slow down
  • Navigation improvements and logging including switching to filtered location for distance calculations (jason)
  • Flip improvements - more aggressive and flexible flip code based on attitude instead of timing (Jason)
  • Improved camera control - you can now control any axis (roll, tilt, pan) with any rc channel.  it probably makes most sense that you will use 6 but others are possible too.  Unfortunately these changes required we change the set-up procedure so the mission planner gimbal set-up screen needs to be modified again.  Please refer to the AC_Camera wiki page for how to manually set-up the gimbal (Amilcar)
  • Flybar acro mode for TradHeli (Robert)
  • "Fast gains" - allows strong correction of attitude using accelerometers while the quad is stationary on the ground but relies more on gyros while flying (Tridge, Jason)
  • Baro filtering improvements (Tridge)

 

Bug Fixes:

  • DMP timing fix (Randy) - the MPU6000's dmp unit was inadvertantly turned on and caused timing delays in the main loop- xbee bricking issue (Craig / Tridge)
  • Dataflash fixes (Jason)
  • Engine ticking - was a combination of roll/pitch rate D term being too high and the dmp timing fix above (Randy, Emile)
  • Faster heading correction on start-up - resolves issue with simple mode getting incorrect heading if you took off very soon after start-up (Tridge)


Code Cleanup:

  • Increased maximum number parameters (Tridge)
  • Formatting changes to code (Pat)
  • Replaced "int" with "int16_t" everywhere (Randy)


As per usual PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props. If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

There is still some question on whether the default Roll/Pitch Rate P (0.175) is high enough (it was 0.185 in 2.7.1) and also some people feel the Throttle Rate should be higher (currently 0.300 but some say 0.330 or even much higher would be better).

Please feel free to report issues you find in the discussion below and/or add them to the issues list.

Thanks and enjoy!

Views: 52818

Reply to This

Replies to This Discussion

Great news!!! Super excited to test the it out.  Uploaded new 2.7.2 on my APM2. :) Its little windy today ( In LI). Congratulations to all Quad-Hobbyist and Thank you so much to the Dev Team. 

Can't wait to test fly  it. :) 

hello all. I have been flying my quad with 2.7.1 for a few days now and all was well. however i just updated to 2.7.2 and nothing works on my flight data screen. it will arm and disarm and change modes but nothing else is working. i have erased the eprom and reloaded the software and still nothing. i know i'm missing something and any help would be much apprciated. I'm plugged into the usb port running mission planner 1.2.10 mav 1.0  

Steve: what board are you using?

I congratulate them for the good work, design, APM 1.4. 2.5 years and the bug, endures all things.

Of Course with excellent programmers, thank you all for giving me the opportunity to learn.
worth waiting for the 2.5.

sorry apm 2.0

 

Thanks Chris I will keep an eye out for them

Steve, I've tried on all my APM 2.0 boards and can't replicate any problems. Did you use the MP to update the firmware to 2.7.2? 

(I assume you're clicking on the "Connect" button and it's connecting as per usual)

yes i used the MP to update, yes it's connecting as usual, but i no longer have the blue C light on at all except when it's connecting via usb to mp. red light is flashing untill i arm it. then it goes solid.

And the firmware loading went normally, with it passing the verify test? It really sounds like you're got a corrupt download. 

yes it said it was done. when it didn't work as expected i went into terminal and erased the eprom then reset it then reloaded the firmware. same problem.

 

It is possible to try on another PC? 

yes i can take it my friends place and try. it has always worked on mine before though. I've only had it flying for about a week now but i have had the board for about three months now and have been learning and doing updates all along.

I'll let you know how it goes from another computer.

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service