Arducopter 2.7.2 is now in the mission planner and in the downloads area Some positive reports on testing can be found in this discusssion by John Hanson.

Note: just as the release was going out an issue was found re support for the all Camera Gimbals on the APM1s (it doesn't work) and with 3 axis gimbals on the APM2 (2-axis works ok but not 3).  If you're one of these people, please wait for 2.7.3 which will be out shortly. 

 

UPDATE: 2.7.3 is now in the Mission Planner

 

Functional Improvements over 2.7.1:

  • Fast waypoints (Jason) - if the turn angle between two waypoint the copter is less than 60 degrees it does not slow down
  • Navigation improvements and logging including switching to filtered location for distance calculations (jason)
  • Flip improvements - more aggressive and flexible flip code based on attitude instead of timing (Jason)
  • Improved camera control - you can now control any axis (roll, tilt, pan) with any rc channel.  it probably makes most sense that you will use 6 but others are possible too.  Unfortunately these changes required we change the set-up procedure so the mission planner gimbal set-up screen needs to be modified again.  Please refer to the AC_Camera wiki page for how to manually set-up the gimbal (Amilcar)
  • Flybar acro mode for TradHeli (Robert)
  • "Fast gains" - allows strong correction of attitude using accelerometers while the quad is stationary on the ground but relies more on gyros while flying (Tridge, Jason)
  • Baro filtering improvements (Tridge)

 

Bug Fixes:

  • DMP timing fix (Randy) - the MPU6000's dmp unit was inadvertantly turned on and caused timing delays in the main loop- xbee bricking issue (Craig / Tridge)
  • Dataflash fixes (Jason)
  • Engine ticking - was a combination of roll/pitch rate D term being too high and the dmp timing fix above (Randy, Emile)
  • Faster heading correction on start-up - resolves issue with simple mode getting incorrect heading if you took off very soon after start-up (Tridge)


Code Cleanup:

  • Increased maximum number parameters (Tridge)
  • Formatting changes to code (Pat)
  • Replaced "int" with "int16_t" everywhere (Randy)


As per usual PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props. If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

There is still some question on whether the default Roll/Pitch Rate P (0.175) is high enough (it was 0.185 in 2.7.1) and also some people feel the Throttle Rate should be higher (currently 0.300 but some say 0.330 or even much higher would be better).

Please feel free to report issues you find in the discussion below and/or add them to the issues list.

Thanks and enjoy!

Views: 52780

Reply to This

Replies to This Discussion

Can you post logs?

Bill Thanks for the info!

I will be testing this in the near future too, just out of interest, I've found several issues with most of the wp commands. Decided to test them all and put together a pdf on what works and how it works (arducopter only I'm afraid)

This is the only info I have on ROI:
Sets the region of interest (ROI) for a sensor set or the vehicle itself. This can then be used by the vehicles control system to control the vehicle attitude and the attitude of various sensors such as cameras. |Region of interest mode. (see MAV_ROI enum)| MISSION index/ target ID. (see MAV_ROI enum)| ROI index (allows a vehicle to manage multiple ROI's)| Empty| x the location of the fixed ROI (see MAV_FRAME)| y| z ROI |lat| long| alt

Main thing to realise is that some of these commands only function on Arducopter or arduplane, not nesecaerily on both! (Different code!) In the meantime I'm all ears as well, lets hope someone else has been testing.

Of course it might not be fully implemented in MP either! so the options are (a) not implemented in Arducopter code, (b) not implemented in Mission Planner, (c) We are not using it right!

Sorry I can't help more atm...

Sounds to me like you have never had this working previously!

I would be looking for metalwork, electrical fields etc. in close proximity to the magnetometer sensor...

Peter

A document on waypoints would be frantastic.

Maybe somehow I have it set for "sensor" or gimbal, when I need to set it for "vehicle"?

Not sure how I do that. 

DaveC,

    It's there but it doesn't do anything I'm afraid.  Sorry, I'll sort it out..

CrashPilot,

     There is a huge demand for better alt hold control and I would love to hear how you (or multiwii or whomever) have done the integration with the accelerometers.  I've sent you a friend request.

     Theoretically it seems easy (everybody thinks so) but I've seen at least 3 or 4 attempts to get it working and all have failed.  You will see remnants of some of those attempts in the code still.

    One of the first steps is accelerometer calibration.  You can't just use the z accelerometer because you need to adjust for roll and pitch and the scaling and offsets on the different axis can be very different.

    Anyway, please share what you know, and if it works it'll end up in the code!

Bill,

     I also tried ROI the other day and couldn't get it working.  There was a bug to do with the camera mount code but I thought i'd fixed it.  I'll need to look again.

Thanks Randy,

The X8 is actually flying very well with a 1:1, its just under transistioning i get a wobble that I'm sure is prop-wash related, if i could crank up the bottom motors a bit I think it will be gone.

Given that its a top/bottom ratio, would a value of 0.9 mean the top spin at 90% of the bottom (when its fixed that is)

Cheers

 

Randy, Did it used to work?

Peter

Hello,

I went to the flight field this weekend to do some tests. I have the APM 2.5 with a ublocks GPS. I had this discussion before about simple mode not getting initialized, it took me about 12 times of turning the copter on and of before alt hold not stabalize's simple mode started working and then I loaded a flight plan and it did this very successfully until the battery died.

 

So I changed to a newly charged battery, and again simple mode does not want to initialize so I said screw that I am doing the flight plan again, it crashed moments after, it kept stable and was moving to the on point and then it started turning around and it head straight for the ground breaking my frames legs and some blades.

 

I have 2 * APM 2.5's and 1 APM 2 and both APM 2.5's does this where simple mode does not want to get initiualized.

 

Please find attached my log files

Regards

Christiaan

  

Attachments:

You have a message :)

Hopefully it is of some use.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service