In just a short while, ArduCopter 2.7 will become available for download in Mission Planner. As we worked on ArduCopter 2.6.1, we saw that it had several new and compelling features (as well as many bug fixes and improvement) so it was decided to make this a major version release. 

A full list of changes is here, but they include:

 

New and Improved:

  • NEW: 3-axis camera stabilization
  • NEW: AP_Limits library: Altitude limits and geofencing.
  • NEW: Automatic Flip (Roll axis) is now enabled on Channel 
  • NEW: GPS lag estimator
  • NEW: the quad first rise vertically to the "ALT_HOLD_RTL" altitude (if declared) when engage RTL
  • Better altitude control in ALT_HOLD and better altitude transitions
  • Better loiter, rtl and auto missions, especially with the new 3DR uBlox GPS. Check out my video above!
  • Better yaw control
  • Better DCM implementation, resulting in noticeably smoother flight
  • Better velocity control in Auto missions
  • Etc

Bugfixes:

  • Fix to dataflash erasing, which should resolve an issue some users were having
  • Fix some MAVLink commands
  • Fix Circle command
  • Fix some units
  • Etc

Notes:

No more 1280 support (out of program space)
Know issue:
- throttle stick during loiter need better rpm range

Cheers,
Marco

Views: 16349

Reply to This

Replies to This Discussion

STILL FAILS TO ARM


This the apm that I had in my Y6 when it when nut after 2.7.0 upgrade, that I put down to not doing an erase reset before upgrading but I still pulled it from my Y6 and replaced it with my last spare. I reloaded every thing to use it on one of my quad projects. After getting everything set up and configured I can not get it to ARM. I have checked and double checked you can see the radio in the status and the config screen STOCK config the apm has flown before with 2.6 

WHAT AM I MISSING?

Make sure of the following:

1) You're in stabilize mode (it won't arm in other modes)

2) You don't have either throttle or yaw channel reversed (try top or left, rather than the usual bottom right)

3) You've done a radio config in the MP

4) If all that checks out, bring your thottle trim tab all the way down and try again.

Good list I have made all those mistakes before.....LOL

Yes I have checked all those several time and again this morning I started from scratch and went though every thing again. You can see the radio input in both status and cnfg screens

Full STOCK load no changes after an erase and reset

Try going to the parameters menu and writing 0 for LIM_ENABLED. This disables the limits set by GeoFence. I've been bitten before by setting the altitude low limit > 0. If this fixes the problem, you can figure which specific limit is locking you out.

Jim Thanks

I went to the parameter list and LIM_Enable was 0 I did a para refresh and still was 0 I typed in 0 and did a write still no change

Kevin: do the LEDs flash quickly after you do the bottom right deal on the throttle/yaw stick, indicating a IMU calibration as part of the arming process? 

I assume you're flying Mode 2, not in heli mode, right?

Now I feel like a real idiot..........Yep mode 2 was it. When I was setting up the the tgy 9x I started with a fresh slot rather than doing a copy and forgot that the 9x defaults to mode1  

Thanks very much Chris, if the weather holds I will get some flying done on 2.7.1

Thanks again !

Kevin

Just glad we figured it out!

My new Xbee Adapter wont talk to Xbee module. Can someone please help?

http://diydrones.com/forum/topics/xbee-adaptore-wont-talk-to-xbee-m...

is the stream going to move there?

I am setting up the optic sensor and like to know what is the angle width of the lens. I am fixing it to a leg strut at 200mm from the ground. The bottom leg cross been is about 100mm of to the side where the optic sensors center focus point hits the ground. Will this leg strut interfere with the sensor and be in its field of view? Also does the optic sensor work together with the sonar?

a good way to figure this out is by running the test code in Arduino IDE. I don't remember well but if you make some research you will find there is a way to get a serial feed that lets you see what the sensor sees. Remember to use a lot of light.

My optical flow sensor works fine with the sonar. Are you asking because of the shared pin?

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service