ACRO bug (fixed in 2.9.1b): while doing flips in ACRO mode, if you switch to Stabilize while inverted your throttle will go to minimum.  To regain throttle control you need to switch back to ACRO then back to Stabilize again (i.e. switch to stabilize twice).  You never lose control of roll/pitch/yaw.

Loiter/AltHold/Auto/RTL bug: if you switch into these modes with throttle at zero motors will go to minimum until you raise the throttle.

Auto mode altitude bug (fixed in 2.9.1b): setting a waypoint altitude greater than 320m over home altitude may wrap around and instead be interpreted as a low altitude.

ArduCopter 2.9 is now in the mission planner and the downloads area!

The major improvement is we use inertial navigation to improve altitude hold.  This increased reliance on the accelerometers means you must do some additional set-up before flying:

1. Perform the new accelerometer calibration in the mission planner (video).  The auto-trim metho has also changed (video).

2. Add vibration dampening foam between your frame and the APM.  Some suggested materials: DuBrogelhk foam.

 3. If upgrading from 2.8.1, modify the throttle and altitude PID values:

  • Increase your Throttle Rate P, reduce I to zero, increase D
  • Increase Altitude Hold P, reduce I to zero
  • Tune Throttle Accel P and I terms but try to keep P about 1/2 the size of I


Here is the list of major changes (a more detailed list can be found in the release notes):  

  • Alt hold using inertial navigation (Leonard, Randy, Jonathan)
    • AUTO_VELZ_MIN, AUTO_VELZ_MAX parameters control the max climb/descent rate for the autopilot (cm/s)
    • PILOT_VELZ_MAX controls max climb/descent rate for the pilot (in cm/s)
  • Landing improvements (Leonard/Randy).  Copter will descend to 10m or until an object is sensed with the sonar.  Then slows to 50cm/s descent (speed can be adjusted with LAND_SPEED parameter). (video).
  • Surface tracking with sonar (Randy/Leonard).  Copter will attempt to maintain current distance from objects in front of sonar regardless of altitude.  Only used in alt-hold and loiter, not used for missions.  Sonar can be enabled/disabled with CH7 switch. (video)
  • Failsafe improvements (Randy/Craig/John Arne Birkeland) including bug fixes, additional check for PPM encoder failure and implementation of battery failsafe.  Set-up instructions are here.
  • Mediatek gps driver accuracy improvements and use of SBAS [Craig].  Instructions on upgrading your mediatek to firmware 1.9 are here.
  • Traditional Heli improvements (Rob) including (a) bringing heli code back into the fold, (b) enabled rate controller (previously only used angle controllers). (c) fix to rotor speed controllers - now operates by switching off channel 8.  (d) allow wider collective pitch range in acro and alt hold modes vs stabilize mode  (e) bug fix to allow collective pitch to use the entire range of servos
  • Acro trainer (Leonard). Copter will return to be generally upright if you release the sticks in acro mode.
    • ACRO_TRAINER : set to 1 to enable the auto-bring-upright feature
    • ACRO_BAL_ROLL, ACRO_BAL_PITCH : controls rate at which roll returns to level
  • Camera control improvements (Randy/Sandro Benigno):  (a) AP_Relay enabled for APM2  (b) Trigger camera with CH7 or DO_DIGICAM_CONTROL command  (c) Allow pilot override of yaw during missions and fixed CONDITIONAL_YAW command.
  • PPM sum support for transmitters with as few as 5 channels (Randy/Tridge/John Arne Birkeland).
  • Performance and memory useage improvements (Tridge).


As per usual PIDs are optimised for the 3DR/jDrones quad with 850 motors and 10" props. If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

Special thanks to our testing team lead Marco and the dedicated bunch on the 2.8.1 release thread who put their copters at risk while testing the pre-release version.  Some of their videos are here: 1 2 3 4 5 6 7 8

Please feel free to report issues you find in the discussion below and/or add them to the issues list.


Views: 298765

Reply to This

Replies to This Discussion

What I did to get 1.2.32 was uninstall 1.2.30, then install MissionPlanner64-1.2.19.msi ( or I guess x32 if you need) then when you run it hit update, should take you to 1.2.32

Thanks, that explains I.....Don

 but you have to put up with me rambling on!

That's what we want.  Tell us what you're doing and what the quad is doing.

Noted :)

In 2.9 you can override the yaw on RTL or during AUTO missions with the rudder stick or with the DO_YAW_COMMAND and there's also a new parameter called YAW_OVR_BEHAVIOUR that controls when the autopilot will take back control of the nose.


...but I'll add a parameter in 2.9.1 that will allow you to control the behaviour all the time.  actually I'll probably replace YAW_OVR_BEHAVIOUR with just YAW_BEHAVIOUR and it'll have a few options to cover what everyone wants.


     Thanks.  This info allowed Michael O to find and fix (we think!) the issue.  So hopefully in the next release it'll be ok.


     I've added sorting out the RSSI thing to the list for 2.9.1.

Hi Chris,


I upgraded my older Mediatek and it is working much better. I also have the newer unit from 3DR (with battery and larger backplace), but I am unable to determine the firmware version on it as miniGPS won't successfully return from the version query. Went ahead and tried to update just ot see what would happen, but it errors out. Seems to work really well anyway, but thought I'd ask.


    yes, great idea to do the calibration before you put it on the copter.

     By the way, it doesn't actually matter if while during the calibration you get it perfectly flat or anything at each step.  In fact, it doesn't even matter if you totally mess up the order.  The underlying algorithm just wants 6 points to work with.  the best 6 points to give it are all perpendicular.  You don't want to move it while you're doing the calibration though, that's important.


     Yes, all sounds ok for you.

     The instructions to modify the throttle pids is only for people who are upgrading from 2.8.1 so I've updated the notes above to reflect that.  thanks!


I am struggling - help needed.

(APM 2.5+, Telemetry 433, U-GPS)


Running 2.8.1 - upgraded to 2.9 - worked fine ! (btw ALT Hold - amazing..)

Now - Blue light comes on solid, no red light - wont arm - nothing.. Connected to the USB + MisPlanner. Blue light on the whole time - cannot connect via USB - stuck on "Got Param FS_BATT_ENABLE". When USB attached - Blue light goes off and then comes on at the same time it stop on the error mentioned.

I have put back firmware 2.8.1 - same problem. Reapplied 2.9 same problem. I can connect to the CLI - I have "erased" and "Reset" still the same problem. Blue light on solid (noting that GPS is not attached) and the red light is no where to be seen....

Any help would be great - right now not going anywhere...

Cheers James

I've also seen that I can list the logs in the main CLI screen, but when I click "Log Download" up top, the same thing happens to me - blank log screen that stays on "Connecting" - All other functions through wireless CLI work great.. This is the only item that doesn't..

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service