ACRO bug (fixed in 2.9.1b): while doing flips in ACRO mode, if you switch to Stabilize while inverted your throttle will go to minimum.  To regain throttle control you need to switch back to ACRO then back to Stabilize again (i.e. switch to stabilize twice).  You never lose control of roll/pitch/yaw.

Loiter/AltHold/Auto/RTL bug: if you switch into these modes with throttle at zero motors will go to minimum until you raise the throttle.

Auto mode altitude bug (fixed in 2.9.1b): setting a waypoint altitude greater than 320m over home altitude may wrap around and instead be interpreted as a low altitude.

ArduCopter 2.9 is now in the mission planner and the downloads area!

The major improvement is we use inertial navigation to improve altitude hold.  This increased reliance on the accelerometers means you must do some additional set-up before flying:

1. Perform the new accelerometer calibration in the mission planner (video).  The auto-trim metho has also changed (video).

2. Add vibration dampening foam between your frame and the APM.  Some suggested materials: DuBrogelhk foam.

 3. If upgrading from 2.8.1, modify the throttle and altitude PID values:

  • Increase your Throttle Rate P, reduce I to zero, increase D
  • Increase Altitude Hold P, reduce I to zero
  • Tune Throttle Accel P and I terms but try to keep P about 1/2 the size of I

 

Here is the list of major changes (a more detailed list can be found in the release notes):  

  • Alt hold using inertial navigation (Leonard, Randy, Jonathan)
    • AUTO_VELZ_MIN, AUTO_VELZ_MAX parameters control the max climb/descent rate for the autopilot (cm/s)
    • PILOT_VELZ_MAX controls max climb/descent rate for the pilot (in cm/s)
  • Landing improvements (Leonard/Randy).  Copter will descend to 10m or until an object is sensed with the sonar.  Then slows to 50cm/s descent (speed can be adjusted with LAND_SPEED parameter). (video).
  • Surface tracking with sonar (Randy/Leonard).  Copter will attempt to maintain current distance from objects in front of sonar regardless of altitude.  Only used in alt-hold and loiter, not used for missions.  Sonar can be enabled/disabled with CH7 switch. (video)
  • Failsafe improvements (Randy/Craig/John Arne Birkeland) including bug fixes, additional check for PPM encoder failure and implementation of battery failsafe.  Set-up instructions are here.
  • Mediatek gps driver accuracy improvements and use of SBAS [Craig].  Instructions on upgrading your mediatek to firmware 1.9 are here.
  • Traditional Heli improvements (Rob) including (a) bringing heli code back into the fold, (b) enabled rate controller (previously only used angle controllers). (c) fix to rotor speed controllers - now operates by switching off channel 8.  (d) allow wider collective pitch range in acro and alt hold modes vs stabilize mode  (e) bug fix to allow collective pitch to use the entire range of servos
  • Acro trainer (Leonard). Copter will return to be generally upright if you release the sticks in acro mode.
    • ACRO_TRAINER : set to 1 to enable the auto-bring-upright feature
    • ACRO_BAL_ROLL, ACRO_BAL_PITCH : controls rate at which roll returns to level
  • Camera control improvements (Randy/Sandro Benigno):  (a) AP_Relay enabled for APM2  (b) Trigger camera with CH7 or DO_DIGICAM_CONTROL command  (c) Allow pilot override of yaw during missions and fixed CONDITIONAL_YAW command.
  • PPM sum support for transmitters with as few as 5 channels (Randy/Tridge/John Arne Birkeland).
  • Performance and memory useage improvements (Tridge).

 

As per usual PIDs are optimised for the 3DR/jDrones quad with 850 motors and 10" props. If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

Special thanks to our testing team lead Marco and the dedicated bunch on the 2.8.1 release thread who put their copters at risk while testing the pre-release version.  Some of their videos are here: 1 2 3 4 5 6 7 8

Please feel free to report issues you find in the discussion below and/or add them to the issues list.

 

Views: 298759

Reply to This

Replies to This Discussion

Thank you,

I've checked mag offsets in previous flights and they weren't that bad, so I didn't think to look here.  Maybe the large amount of wind caused the motors to have to work harder, thereby creating more EMF. 

I'll work on fixing that.  Just thought the point where the loiter was not doing anything against the wind might have been some other issue.

Thanks for the info, Randy.  Good to know the Accelerometer Calibration has nothing to do with the frame type.  Yes, it is confusing, as the ArduCopter Level page infers that the frame type is somehow tied in with the Accelerometer Calibration.

I think most folks just set it as a Quad X and don't mess with the motor values, so it doesn't behave well.  It took some searching and thought to figure out how to determine the correct motor values, and each Quad V will be different.  May have to extend the motors out to get a better rear separation on the next frame.  I'll report back about as soon as I get the frame up in the air, hope I have it somewhat right. 8-)

Here is the video of second event.

Setpoint of 100m height, and the error occur at approx 65m.

http://www.youtube.com/watch?v=NWDN8srQvK0&feature=youtu.be

 

Logfiles can be found here:

http://diydrones.com/forum/topics/strange-behaviour-in-auto-mode-3d...

 

Ludvig

This should answer your question.

I might have my mysterious GPS problem solved. I did three things at once and need to do further testing to find out which may have solved the problem. I moved the GPS mounting to high above the APM like a NAZA. Secondly, and I think this may be the red X, I removed the Spektrum TM1000 telemetry. I think perhaps this transmitter signal might have interfered with the GPS – they were in close proximity. I also removed my 900 MHz 3DR telemetry. The quad Loiters correctly now but it still takes about one minute after the GPS lock until it becomes solid in Loiter. Within the first minute of flight it still wants to veer off. I can live with this if one or more of the fixes are truly the solution to the problem. Comments are welcome...

I officially giving up on this....apm no3 that i fried.....this time i had no telemetry plug in.....i just finished tuning acro and started working on stab.....and again for no reason i cannot connect to USB, and again the mux chip gets super hot...so i give up. until someone can tell why this is happening im done....2 x Arduflyers bust 1 x 3dr apm bust, so im packing it in any one after some busted boards...!!!!!!!!!!!!!!   

+1 Jim

There are less satellites available  if the GPS device is mounted too close to 3dr Telemtry 900mhz.

It's usually the rule, you should never mount 3DR too close to the baord and GPS, but also not too close to ESCs!

Jim,

    Very good news and gives us some advice to give others.

I think it has to do with the TS5A23157, according to the datasheet, even though the Maximum VCC can be 6.5V, when VCC is 5V signal levels should not exceed 5.5 V, it is an analogue switch that can operate at various supply voltages, in hindsight a digital multiplexer may have been a much better choice. MUX getting hot and frying must be due to high voltage or high voltage spikes [high voltage being around 6V to 6.5V] causing latchup and self destruct of MUX, most likely scenario is ESC BEC failing and passing full lipo voltage to the APM 2.5 supply instead of 5V. It is not caused by having Lipo plus BEC connected at the same time as USB, as that does cause any harm at all. A photo or detailed explanation of how you are supplying power to the board may help others avoid whatever the problem is in your case.

 

Excellent advice and what we all strive to achieve, however, multicopter central hub has limited real estate.

HI Joe

I am Using a Maytec Bec it outputs 5.5v could that be causing it.???

the board still start correctly and i can fly it in acro and stab mode i just cannot connect?

i have ordered some TS5A23157 as i have a SMD rework station at work, could replacing the TS5A23157 solve the connection problem?

it is still seen by MIssion planner i just cannot connect.

the Bec outputs 5.5v constant no fault , i have it on the input rail and JP1 is open.

could it be as simple as the 5.5v ubec causing to high voltage? even with it being in TS5A23157 voltage range?

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service