ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 386750

Reply to This

Replies to This Discussion

Excellent!   Very happy we're on the road to recovery with this copter.  The vibration levels on your copter are very nice and low by the way  I wonder if it's the wooden frame that helps.

I'm not sure about the loiter descending.  It may be barometer drift which is a bit unavoidable.  Here's a graph of the baro alt (red), inertial nav alt estimate (blue) and the desired waypoint altitude and you can see they track pretty well.  ..but the baro drifts so we can't 100% believe the altitude we see in these graphs was it's real altitude.

Goncalo,

     Z looks great but X and Y are out of tolerance so I think you'll need to sort it out.  I don't think it'll act crazy but I think it will drift around a lot.

Para,

     So if you keep yawing it keeps circling but if you stop yawing it settles in a single position?  Or even after you stop yawing it continues to circle?

     I would expect it's position would circle while you're yawing because the nav controller only runs at 10hz (we are cpu limited on the AVR) so the direction it would try to fly in would always be slightly behind where it should be and you'd end up with circling.

I don't get any current data when trying to use the "Compassmot" command. 

I've followed the tutorial both from the video on youtube and in the wiki with usng the Power Module Cable and setting that up within the software, but when up'ing my power to rev my motors I don't see any change in the 0.0 current thus I get the error saying somehting along the lines of not enought throttle or something like that.

Tim,

     So sounds like you've done the 3dr power module setup in the mission planner as shown on this wiki page.  If that's been done can you check that, after attaching a battery, you see a voltage in the "Battery Voltage (calced)" field?  If you don't see a voltage and all the set-up has been done according to that page then I'd have to conclude a hardware issue with the power module.

     If you do see a battery voltage on that page but no current shows up when you do compassmot then I also don't have a good idea as to what the problem could be.  Sounds again like a hardware issue with the current sensing part of the cable.

Randy,

Thanks for the answer. 

1. Yes, I've followed the steps from the video and from the wiki to double check that I didn't miss anything.

2. I do see the voltage measurement as shown in the Battery Monitor panel in MP when I turn on the options for that. 

I guess I'll just have to try and order another PM cable and test that if you don't have any idea what it can be. 

Its not a big problem as I've tested the copter in stab, alt-hold and loiter, and it flies wonderfully. But it would be nice to see if it could have been even better. ^^

Ok .Randy I will try another cable and laptop ..strange though as it connected the first time which is how I did the Reset in the first place ..and the laptop and USB cable is the same ones I have been using for all my Copters and APM boards ?  I will report back 

How old?  The PPM encoder did not set the throttle channel to 900us until the fall of 2012.  At least test the Throttle failsafe behaviour using Mission Planner, but best to update to the new code.

Update:

Very strange Yesterday I spent hours trying to figure out why the APM board would not be seen by the laptop or MP ...After my CLI "Reset" After Hours searching the Internet nothing? I tried all sorts of things ..I thought the unit was "Dead" ... Only to go back out to the workshop after work tonite and open the lid of my laptop (which had been sitting on the workbench still booted up just asleep overnight and while I was at work) open MP and plug in the USB to the bare APM still sitting were I left it ..and as soon as I connected it  I heard the Ding dong sound windows makes when it sees something connect ..and I knew ..it will work now ? So before I got my hopes up .. and Connect MP. I first did firmware install (which went without a hitch) So now I was happy ...My unit is ALIVE!!!  Funny that it played dead for hours on me yesterday ?

Thanks for the response Randy and fellow APM'ers  ;o)

P.s I have been flying my 666 quad to death ..and performing multiple missions and radio off fail-safe landings and GPS Hold etc ..lands within a meter each time, I am very happy with it. I have had no issues at all ..motors stay absolutely cold and I get 20mins fly time on a 4s 8000 battery and on a 4s 5000 I get 16mins...The only thing I may do went it arrives is do the external Compass Mod ..I believe from reading up in the forums its the way to go ..

Just a quick note to the Devs.

I had some issues with a faulty motor on my Y6, but its sorted now, and with the correct parameter file applied, managed to get some good stick time yesterday.

AC3 flies like nothing before it, I have never had such a locked-in feel on a multicopter before.Alt Hold is Rock solid, Loiter is nailed to the sky, RTL works to within a 3 foot radius, the weekend I hope to do a few Auto missions.

Well done Guys! When you read the forum posts one sometimes dont get just how grateful the community are for your hard efforts and long hours.

Let me assure you, we are like this :

Im now just setting up my hex with the APM1 board and loading the 3.0.1 onto it for the first time. Does this have the same vibration issues and  sensitivity as the APM2.X boards with the compass? Do I need to do the same compassmot calibration and check?

@John,

Yes you still need to do all the same setup procedures as with the newer boards, however there might be a performance issue with the APM1 board.

Im still waiting for Randy to give feedback on this and havent been flying my quad for more than a month now... :-(

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service