ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 385569

Reply to This

Replies to This Discussion

Someone know the exact order pin SDA SCL GND VCC on APM 2.5 to connect external mag please?

Attachments:

I updata my apm2.5 from 2.9.1b fin, should I re-adjust all PIDs?

Gary,

     2.5 is pretty old.  I think you'd be better off doing the cli, "reset", "Y" and do the set-up from scratch.

Randy,

Please, please, could you have a look at my previous post and my Quad crashing on descent (worked fine before switching to carbon props)?

I would truly appreciate your input!

Thanks

Alexander P

Randy,

         Is that difficult to reset parameters than v2.9.1b final? My FPV Quad working good when it was V2.9.1b , and I only adjust 3 or 4 times. And now I already adjusted 3 times, it still fly like a bee,On stabilize mode it can't hold YAW correctly , but simple mode don't have any problem. And AltHold(barometric) even worse than manual,If I set a bigger P, Quad will sway.What should I do now Q_Q thanks

1000 Thanks !

We had a GPS glitch while flying today taking aerial video and thought it was perfect example to send in for the experts to take a look at.  We were flying a simple waypoint mission with auto takeoff, transit to 2 waypoints, then unlimited loiter at the last waypoint.  On the way to the last waypoint we had the GPS glitch.  We were able to recover the flight by switching to Alt-Hold, fly to the waypoint manually, then switched to loiter once the GPS had recovered (about 10 seconds later).   We're flying a 3DR quad, with APM 2.5 (v3.0.1), an external magnetometer and the ublox GPS module.  We had a GoPro and a brushless gimbal as our payload.  I've attached the log files and a link to the in-flight video:

http://www.youtube.com/watch?v=P7laGX-tn-Y

Attachments:

Quick correction, on our quad we still use the on-board APM magnetometer.  I got confused with our hex vehicles which we've switched to the 3DR external magnetometer.

Hello Randy,

Thank you for your reply! Follow the ublox GPS by default files that you use to brush the firmware, and then even APM1, electric start, Mission Planner HUD display NO Fix, this indicates that the GPS connection successful. But when I started again APM1, Mission Planner HUD display NO GPS! I see APM1 LED on the Board, when you first start APM1, continuous red LED blinking, this indicates that the GPS connection successful. When the next time you start APM1, the red LED flashes 1 second stops, indicating that NO GPS! This is why?

Garrick,

    Thanks very much for the log.   We talked about this just yesterday on the dev call and I think there's no question that this is the biggest support issue we have (at least for those who have gotten through the vibration and compass set-up issues) so we're going to try to do something for the AC3.1 release.  In your flight it's a very sharp but short glitch.  I think it's a good example of what we should be able to protect against.

Davise,

     Sorry, I really have no idea.  Maybe the first couple of packets from the GPS are understandable but from then on they become unintelligible.  I'm sure if you try a different GPS with the standard 3dr config on it, it will work fine which indicates that it's a GPS issue.  It's not talking a language that the APM understands but i'm not sure what's wrong with it.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service