ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 385883

Reply to This

Replies to This Discussion

Randy,

Yes I've got an old APM1 board. Alt_Hold and Loiter was working perfectly for me in 3.0.0, except for the Loiter wobbles.  I didnt try RC1, only RC2 and that's when the dropping started.  I dont have any vibration dampening stuff as my frame stacks are made from 1mm ABS plastic which is flexable.  Baro is covered with a 1x1" piece of makeup removal pad as per the recommendations.  There's not much space to fly at home so that's why I normally hover at around 2m and do my testing.

I will try the higher P value tonight...

Dustin,

     Ok, i've look at your logs and it's very clear what happened.  The problems started when your copter breached the very small fence and began RTL but the RLT_ALT was set to 100m so up it went.  On it's way up, it received the pilot's roll, pitch, throttle, etc input but ignored them (as it should) 'cuz it was in RTL mode.

     Looks like you left the flight mode switch unchanged for about 30 seconds so it climbed to 80m or so.  At that point you had pulled the throttle to min and then there was about 2.5 seconds where the flight was switched between a few modes (Stabilize, Circle, Auto) before being finally set back to stabilize.  With the throttle zero however it came down very quickly but i guess you caught it in time by gunning the throttle.

What is 'atlasl' parameter in status window (MP1.2.60) ?

(right below 'alt' param.)

What does the "Enable telemetry" button do?

In 2.91, Arducopter will NOT start any stream, unless it receives an explicit command. That is independent of how the stream rates are configured in Mission Planner. MinimOSD-Extra does not request the streams anymore because it is anyways recommended to cut the TX wire from MinimOSD if you use a radio at the same time (which I do).

That means, to start the streams, you always have to connect to the APM via telemetry first and send the command. In consequence, it is impossible to go out FPV-flying with MinimOSD if you don't have any mobile groundstation system.

I have addressed the issue at the dev list some time time ago and the result was that ArduPlane does start the streams automatically but arducopter doesn't. How

Hi,

I had exactly the same problem, but I think there is one more issue. I know I changed modes during RTL but the copter did not respond. I think what happens is that when the copter switches to any other mode from RTL the software switches back to RTL since the copter is still above the fence altitude. Eventually the copter come down, but by that time I was in Stabalize with very low throttle. Just managed to save it 5 feet from the ground.

Thanks

Taking a wild guess here but maybe it stands for ALTitude Above Sea Level...

I made a couple of videos to show a alt hold yaw problem I'm having. I wasn't having it before but I think it's because some settings got  changed in the process or some became more sensitive. My loiters are very good but if I try to yaw, it climbs or descends. Since the octo is a little over powered and not holding it's camera, it's more pronounced. What setting can I change to reduce that?

I've attached a log from the second video.

Here is a 8x speed loiter. Some z movement sometimes but usually it doesn't even do that. I think that was just the location I was flying in. The pressure might have been fluctuating there. I'm on the peak of a mountain.

Second video shows the problem. I'm in Alt Hold and when I give yaw you can see it jump up or sometimes go down. It always recovers but during an fpv flight it can be uncomfortable because your not sure how much or quick you are descending.

Attachments:

X650 with
HP2814-710KV Outrunner,
SK-30A ESC 30A Simonk
external Compass (compassmot = 1%)
4s 4500 mA / h Battery

AltHold and loiter are perfect. I made 20 starts since yesterday with RTL and land successfully. The wobble when in Loiter is now gone.

Here's a short video:
http://www.youtube.com/watch?v=OyYgvcmD4SU

Thanks to all developers for this great version.

regards Peter

Had this with a quad yesterday, turned out to be the sun getting through the apm case and foam and affecting the barometer.  As a quick test try covering the top of apm with black tape.  If that works, paint the inside of the case.

Andy.

No, we thought of that and it's described and demonstrated in the fence video.  It will only switch you back into RTL after you've retaken control if you move an additional 20m from the edge of the fence.  It's much like once you breach the fence, it creates another fence an addition 20m out.

So while climbing for example, if you hit the altitude max you can retake control by switching into another flight mode but if after doing that you move another 20m up it will again switch you to RTL...of course you can retake control again and push it out further.

In Dustin's case as well if you look his logs at line 7004 it's possible to see that he's retaken control at 80m by switching to Stabilize, despite the height being far above the fence the mode is not switched back to RTL mode.

Could you also make sure you motor logging is turned on.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service