ArduCopter 3.0.1 has been released and is now available in the Mission Planner,, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 386579

Reply to This

Replies to This Discussion

Hi Craig, thanks for the reply, Cool, I was hoping that was the case, means there should be a solution!

I am powering the apm and receiver from a 5 v reg, also powering the RFD from it's own 5v reg. also tried using the power from the apm, no change.

I was thinking of trying a shielded cable, but thought I would exhaust other options first.

I did move the modem around a bit away from the speedies. still same story. Might make up a shielded cable and give that a go unless you have any other suggestions?

Are they BECs or your own regulators like LM805s?

Hi Bill, thats correct, you can input power on the second pin on the top row or short it to the third pin over which pulls power from the cable. 

The RFD900 can pull around 800ma I think, So i have always used a seperate 5v supply.

So i guess if it is not a processing issue then I might need to test the supply with a oscilloscope and see if there is noise there,....  Kinda scary with 8 x 15" props!

sbecs,.... also used these with the same results...

About to do another test with a separate battery for the modem,... let you know the results in a few minutes....

Hi Bill, Craig, dev team...

Ok, so I have just done some more testing / fault finding. 

SO I have tried all the 5 v regs that I have, powered apm seperate from speedies and still lost telemetry when armed and advance the throttle above idle.

So I disconnected all speedies from the apm. 

Power up the apm and armed, then advance the throttle and still loose telemetry.... So i don't think this is a noise generated issue.

I will test with another apm that I have and see if I can replicate this issue.

currently I am using 3.1-dev (also had same issues since 2.9.1b) 

Telemetry rate seems reduced on my hex as well but just slow,..

The octo and quad-octo both drop out completely when above idle....

Dev team ?? any thoughts?

RFD900 Modem set to air rate 64, tried up to 128 with no change (57400)

Any other info that would be useful?



Do you have 'super simple' enabled, by any chance?

Surely you can just save your current parameters - reset the quad, save the new params (which are the defaults) and then reload your settings?

Your idea that it's CPU related is possible although a bit unlikely.  There are some calculations that we don't do when the throttle is zero.  One way to check this theory is to disconnect the ESC & motors and repeat the test.  If the radio still stops working it's possible it's CPU, if it continues working then it could be some kind of interference problem.

You should also reduce any logging you're doing to just the default and disable any camera gimbal that you have running through the mission planner's optional hardware screens.

Hi Randy, last test was with esc's disconnected, no gimbal, no logging at all, was able to duplicate same senario on a new 2.5 on the bench. It is loaded with 3.0.1 no speedies, no logging etc . I have turned off everything i can think of, still stops telemetry when i arm and advance throttle.

I will reconfigure apm as hexa and see if i get the same result.
I might add all the same hardware was flying and talking well in a fixed wing aircraft over 30km's so pretty sure it's not hardware related.
Oscilliscope show's 5v is fairly clean. Don't think motors or speedies are feeding because the same thing happens with them out of the loop. Ie not connected in any way.
I have a OSD module that listens to the mavlink output. Is it worth hooking that up with a camera and see if i get similar results?

So the quads been flying pretty good.  The rtl speed still needs to be faster. (How do I speed it up?)  The other day I was up around 700' and I went to put it into loiter so I could get some nice video.  When I put it in loiter it started to dive.  Why did it do that?  Here is the Video  And I think I got the right log attached.  Oh and also how can I tell what the compassmot % is from the logs?


Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service