ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 385526

Reply to This

Replies to This Discussion

Forgot to say:

Loiter Pid P is 0.6

Dick Gerritsen

I too wanted to come in and say that I'm totally thrilled with this software release, on an APM 2.6 and Y6.

Really stable flight, excellent missions, very predictable behavior.

I continue to have these two bugs to report:

  • [test] [motors] Does not work on Y6.
  • [setup] [compassmot] refuses to run, insisting radio is not calibrated.

Also, I made the mistake of using cyclic radio trim (+14 on the Futaba scale).  On the next flight, the copter immediately spun onto its side when armed on the ground.  I don't know if there should be a failsafe for checking center-stick on arm?

My vibe numbers look incredibly good, maybe too good?  Is this even possible?

You didn't say what version of the flight code you are running, but I just tested a Y6 running 3.01 and [test] [motors] worked fine.

[setup] [compassmot]  worked fine as well.  Have you calibrated your radio?

I have calibrated the radio (at least a dozen times).  I'm running Y6 w/ 3.01 (the one uploaded by MissionPlanner firmware update).

The only think I can think of is that I originally had this APM 2.6 programmed as an Octo, and later changed to the Y6 configuration.  I did try a setup/reset and restore parameters, but 'test motors' still did not work. I'm really puzzled by this, since the rest of the system works great.  I've flown dozens of successful flights, including GPS missions.

What does the software use to determine if the radio is calibrated or not?  (I suspect this is also why I have to disable the pre-arm checks.)

I see that the trim values are correctly stored in parameters, the radio ranges are correct, hover throttle, everything works fine.. it's just not convinced that the radio is calibrated.  I even tried the CLI radio calibration sequence.

hello Randy and others.

I really appreciate your hard  work and everything you do for the fpv community.

Like many others, on my qav500 i've got perfect settings, perfect flight conditions on 3,01 and the latest beta, BUT i can't get my alt hold not pulsing. It make me crazy. The vibes are perfectly low, on the clean plate of the wav. i've tried with or without the sonar, at different altitudes with no sucess...

here is a link of my paramters if anyone can help and see something big that i missed...

I don't understand why the pids seems almost perfect in stabilized mode and high freq pulsing in alt hold/loiter.... 

all the best guys.

jerome

Attachments:
I'm no expert but have you tried tuning down Thr_Alt_P? I vaguely remember someone else posting about that and they fixed it with turning Alt_P.

No one? I appreciate any help.

Hello!

Which bootloader to upload, after re-soldering new 32u2? Everything else is ok.

I got the same problems with the altitude hold, moved my apm up, further away from esc and power distribution and perfect althold.

I think that the baro is also influenced by magnetic interference

Darrell,

     Glad it's working well.  I don't think you'll see too many differences between -rc1 and -rc2.  I think the changes are mostly for the pixhawks and a small bug fix for the MOT_SPIN_ARMED parameter.

     I suspect that smoothness you're seeing in the take-off is down to some changes Leonard and I did specifically for the big copters.  Marco had mentioned he wanted it smoother and I also found with the big crop sprayer copter I've been working on that it was a bit rough on the take-off.  Happy to see it's working on other copters too.

Hi Randy,

What is the Default you mean for Throttle rate P

After loading 2.01 it is at 0.0

In the Tuning guide is mentionned  .35   (0.35?)

And in the full Parameter list of MP ist listet under the Options: 1.000 ... 8.000

 

The pulsing could be eliminated by Setting Throttle Accel P=0.4 and I=0.8

Kind regards, Otto

Otto,

     I guess you mean "after loading 3.0.1"?  There's a screen shot of the default parameters in the main part of this discussion above.  Throttle Rate P should be 6.0.  Alt Hold won't be good with it set to 0 if that's what you've got.  The tuning guide might be out of date.  The range of 1 ~ 8 seems reasonable.  Excellent that your copter isn't pulsing.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service