ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 386033

Reply to This

Replies to This Discussion

I'll try them later. Thanks Randy and Devteam!

Hi mate,

the reason your altitude is increasing is because your throttle is at around 63%. So it is going up because you are telling it to go up. If you find your copter is increasing in altitude, just reduce the stick until it doesn't.

To have a look yourself look at the CTUN message and compare BarAlt (measure altitude) and WPAlt (desired altitude). And to look at your throttle look at the ThrIn.

You can clearly see in the logs that the first three attempts result in a constant WPAlt and a variation in your baro of approximately 0.5 to 1m. All the flights after that you had your throttle too high and the WPAlt was moving up. 

I've been doing a lot of with 3.0.1 without any problems except one annoying thing that has started to come up more and more recently. I'm including a log of my last flight with the problem. The problem starts when I take off which is always in stablize mode. It does these quick random burst which take it up a meter or more. Just half a second and it never looses control. At first I thought it was a main power connection problem to the ESCs but I don't find any problem there. I'm using the APM PM. I'm using APM2.5 and 3.0.1 on a medium sized quad. If I switch to altitude hold the problem seems to go away or maybe it's masking it. I've looked at the log in regards to current and see some jumps but am not sure what I'm looking for. I doubt this can be a problem in the code but can someone give me a clue as to what to look for to see where the problem is coming from.

I think the problem shows up around 18% and 22% in the tlog.

And one other thing that I would like to fix is when I get an auto switch to RTL because of fail-safe, it points to home before ascending. This usually results in a dramatic jerk and then usually the signal comes back and it goes back into prior mode which is usually alt-hold. I know there is a setting to not have it turn home but I do need it to turn home since I'm using for FPV but can it turn AFTER it ascends? An ascend would be a much calmer way to indicate an RTL.

Can the yaw to home at least be slowed down or would that effect other auto modes?

Thanks everyone and especially the developers. I almost never to post here because of your excellent work because it mostly just works without any problems! 3.0.1 is very stable for me.

Attachments:

agree still no rc5 in MP. i've just check.

To do an Autotune :

1. set the CH7_OPT or CH8_OPT to Autotune or 17 to allow turning on/off the auto tuning with ch7 or ch8

2. ensure the ch7 or ch8 switch is in the LOW position

3. wait for a calm day and go to a large open area

4. take off and put the copter into AltHold mode at a comfortable altitude

5. put the ch7/ch8 switch into the HIGH position to engage auto tuning:

- you will see it twitch about 20 degrees left and right for a few minutes, then it will repeat forward and back

- use the roll and pitch stick at any time to reposition the copter if it drifts away (it will use the original PID gains during repositioning and between tests)

- move the ch7/ch8 switch into the LOW position at any time to abandon the autotuning and return to the origin PIDs

6. when the tune completes the copter will change back to the original PID gains

7. put the ch7/ch8 switch into the LOW position then back to the HIGH position to test the tuned PID gains

8. put the ch7/ch8 switch into the LOW position to fly using the original PID gains

9. If you are happy with the autotuned PID gains:

Leave the ch7/ch8 switch in the HIGH position, Land disarm to save the PIDs permanently.

If you DO NOT like the new PIDS switch ch7/ch8 LOW to return to the original PIDs. The gains will not be saved when you disarm


Note:
The initial Autotune used a three position switch, the new version only uses a 2 position switch.
So far the only tuning issue has been with frames with very soft dampening on the APM or very flexible arms.
For best results the copter shouldn't be allowed to build up too much speed. This can be prevented by applying a quick correction between tests (twitches).

Thanks all and I look forward to your feedback.

Leonard

Hi,

Can someone post me the link of 'Releases' on github for Arducopter?

I don't want to take it the master branch directly as I am told this can be a bit risky as its still in development. I saw the build version of RC5 just a couple of days ago on github, but unable to see it now.

@Leonard: +1, 

Perfect explanation, exactly what I was missing! I will test this very soon and get back with my feedback.

PS: I like your posts as you explain them very well, keep it going :)

Leonard, one question about the autotune:

My understanding from your above list is that the copter completes the autotune with the ch7/ch8 switch is at HIGH position but the new PIDs are NOT in effect till I cycle the ch7/ch8 switch and leave it at HIGH position.

With this, I can go back and forth between the original and new PIDs without permanently writing the autotune PIDS.

If I want to write the new PIDs into APM then I also have to land and disarm while the switch is at HIGH position.

Did I get it right?

Hi L!
Thanks for the feedback..
I set the mid throttle according to ctun th out..
This value is around 620 to 650 ..
My original attempt had thr mid set at 580 but I was still seeing some rise...
On the other attempts I set thr mid to 500 (still got rise) and then all the way upto 650
(Still rise) how should I set thr mid?

Hi Steve, I would like to help but I need a flash log.

Perfect Alex,

Randy and I didn't like the way the previous system just went the tuned pid gains as soon as the autotune finished. This means the pilot must choose to test the new pid gains and therefore is ready for a different control reaction.

Dear Devs!

I downloaded the 3.1rc5 hex file and made an autotune test with my long endurance hexa (link 1link 2). Stab P is now at 9.0 and it is pretty responsive. Before It was at 4.5. Wind was quite heavy so I will try again the next days. WIll this have an effect on endurance? I'll make some tests.

This is an important feature! Thanks for all your efforts!

There are two minor things I have to double check. First, the hexa is relatively "twitchy" in loiter. This was "introduced" when switching from rc2 to rc3. Not problematic but a little strange. Second, battery voltage fail save is not working (no RTL at 14V). Any ideas?

Thanks,

Thorsten

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service