ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 385537

Reply to This

Replies to This Discussion

Just set ACRO_TRAINER to 0 or 1.

0 is nothing but ACRO

1 is ACRO with a little auto level

2 is ACRO with auto level and angle limiting.

Good luck and be careful. Make sure you have your finger ready to flick back to stabilize with full throttle to bail out if you get in trouble!

Acro is there to help pilots crash copters, not fly them :)

Hi @Leonard/Randy,

I just compiled and updated RC5 to APM2.5. I was flying well until yesterday with 3.0.1 (main release).

With absolutely no change in setting, when I armed the motors after upload, it started turning fast.

This became quite scary and I unplugged the battery connections before hurting myself.

Any reason why that may happen? Do I need any recalibration or something? Nothing changed apart from the upload of new fw..

@Darell,

Thank you for that. You are right in your understanding that motors start as soon as I arm. I am going through the post to find the solution. Could you tell me if I must disable/enable any #define flag in source or do I disable this feature via MP?

Thanks for the quick reply.

Here is 3.1 rc4 autotuned in all its glory :)

Only thing new I am going to do from this is add the external compass.

http://www.youtube.com/watch?v=DAF8CsQZYtQ&feature=youtu.be

Hi Randy,

Can you please help me understand what is happening with INS_GYROFFS_X, INS_GYROFFS_Y and INS_GYROFFS_Z on each boot and duringa accel. calibration?

Seems like these values change randomly each time i fly and they are affecting my artificial horizon as well as flight. I don't usually boot the copter on level ground (grassy area, never level) and these values seem to change every time and (I believe) affect my "level flight".

If so, what is the purpose od accel. calibration and how to make them stop from changing, or at least have them be accuratly calculated every time.

 

Thank you,

Misa

*clap* *clap* *clap*

Wow this is great Leonard!! Can't wait to try it. I've been away from this thread for a few weeks. Great to see the development is still moving at a nice pace! Now I will upgrade to the beta unless you think I should stay with 3.0.1 to solve the surging problem?

Leonard,

Back in days when I was flying 2.9.1, I had to reduce the Acro_Ball-Pitch, and Acro-Ball/Roll values to almost 0 level to get the true acro mode (no self leveling).

Without reducing these values, copter would always self level.

Do we NOT need to change these settings now once we set the ACRO_TRAINER to 0?

Miodrag,

     Those are the gyro offsets which are captured when the red and blue lights flash on the APM (or Pixhawk) soon after the battery is plugged in.  During this time you shouldn't move the copter.     It's not necessary to boot the copter on level ground, the accelerometers are only calibrated during that accel calibration set-up step done through the mission planner.

     Can you give more details (maybe a video?) of the problem you're seeing when trying to fly?

Thanks Randy! Maybe also a ramp up speed like you are doing on entering and exiting waypoints would be a nice addition to smooth the auto yaw.

You can set the MOT_SPIN_ARMED parameter to zero and it'll go back to the AC3.0.1 way.  The change is on line 56 of the release notes.  How can you miss that?!  :-).  You're not the first person to be surprised actually..not even the first today.  I'll be sure to mention that when it comes to the big release.

Maybe it will be best to have the MOT_SPIN_ARMED feature set to 0 as a default in the official release and then users can change it to what they want if needed...

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service