ArduCopter 3.0.1 has been released and is now available in the Mission Planner,, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 387201

Reply to This

Replies to This Discussion

First of all I am amazed with all of this and thankful to boot!  The Developers are fantastic.

Randy, et al,

I have a slight issue with RC5 that wasn’t present in prior versions. I have an APM 2.5 with External Compass(raised 10cm) mounted on a X560 quad, 3DR 850kv, simoneK ESCS.  It flies well on current release except for TB in loiter and occasional left roll “twitching”.  With RC5 I get roll and pitch spikes when the APM is stationary and disarmed.  What is really strange is the craziness that happens when I plug in the fight battery to the power module.  The HUD starts spinning around and the pitch and roll data points(mainly roll) are all over the place.  As soon as I remove the battery, she levels out and the occasional pitch/roll spikes return.

I attempted to do accel calibration with and without the battery installed.  With battery the cal fails, without, it’s successful.  However, the craziness returns every time I plug in the battery.  I’m afraid to go any further with RC5 at the moment. I’ll revert back to the release version. Oh, this craziness occurs when MP is connected by 3DR radio or USB.

I have included an tlog if anyone would be so kind to take a look.

Battery plugged in at 13%
Calibration attempt w/batt 19.7% (Failed)
Removed battery at 20.4%
Calibration attempt WO /batt at 22.5% (Successful)
Battery plugged in at 24.9%

Thanks all!



Thanks Leonard, I see that default setting of ACRO_TRAINER 1 was holding me back.   Felt almost like STAB mode.   I am on 3.0.1 still,  3.1 since RC1 incorporated some changes to ACRO.  

What would be recommended ANGLE_MAX setting to allow rolls and flips with aileron and pitch stick with ACRO_TRAINER 0.

Randy, thank you for your reply.

Symptoms are that after switching between multicopters (3, 2 x hexa and 1 x octo) artificial horizon seems to point "wherever" (as if the copter is "nose in the ground"). I don't know if gyro, imu or ahrs offsets get changed but i then reload saved parameters (from file) and start again (losing the level trim data). This happens with no changes to the hardware, just flying.

Being a software developer myself I know the importance of reproducing the issue but no luck so far.

I am however religiously logging every flight, refreshing params and comparing them to ones in the file and so far only gyro seems to change (which is from what i learned now an expected behevior).

I have all the logs, but sifting through so much data (without pointing to specific one) is not very effective use of time at this point.

So, I'll keep looking and send log files and as soon as I catch this occurrence again I will post. By now it seems most likely that when switching between multicopters some parameters get overwritten (by MP maybe?), but again, no actual proof yet.

I vote that it not spin by default. I had an issue with motors were missed wired and my copter kept flipping until I figured out the wiring issue. But when it flipped, the props kept spinning until I disarmed.

I agree. I mean, I have had crashes with other FC's that have motor spin on arm, and it may have resulted in a few more scratches on my props before it disarmed, but the difference in overall safety is worth it. If it's spinning ppl will back off period. Also, the idea of an esc restarting during a flip recovery sounds down right frightening to me. There is no reason an esc should ever go to "0" throttle in flight, and disabling "motor spin on arm" allows that possibility.

Acro is there to help pilots crash copters, not fly them :)

Bullpuckies! ;)

Hello Bruce,

I can confirm this behavior exactly as you describe it. I have 2 chinese APM 2.5.2  boards. The one that currently sits in my quadcopter does the twitching the other one does not. And its reproducible FW 3.0.1 works, both 3.1 RC4 (the first I tried) and now RC5 have that twitching. Each time I revert back to 3.0.1 it works without problems. Also a complete CLI clear and reset with fresh setup did not change any of this twitching on this one board. In my case it seemed like the twitching roll and pitch slowed a little when the copter gets armed but its not flyable as it starts to radically shake as soon as you try to lift off.

I also use an external compass with the board that has the problem while my spare working board has still the internal compass enabled.



Interesting, that sounds like it may be a better approach for "larger missions" until spline comes out. So is that a specific value for "yaw behavior" we need to change, or a code/compile thing?

Y'know, I have to agree that going "no spin" for default would be best. As long as it is parameterized it's easy enough to change for copters that have grown longer in tooth. No reason to put fresh new projects at undue risk.

Regarding the LED mode of v3.1, I recall it was said that the low battery warning buzzer (if retro-fitted) would now oscillate rather than sound continuously, I'm using the number 11 (8+2+1) which gives - low battery flash fast, beeper on, GPS on, Motor LEDs on.

V3.1's LED bitmask however, seems different to the original thread (, how does one make the buzzer oscillate rather than sound continuously? '29' or '30' (17+9+3) doesn't do it.


Dear Devs,

I am not sure if this is related to rc5 or Mission Planner. Have a look at the values for D and IMAX.

They do not match. I did several write and refresh actions. First, in the Copter PIDs, IMAX was on 185. In the Standard Params the value was 500. I changed it in the Full Parameter List to 180 and back to 185. Now I cannot change it in the Copter PIDs section back to 185 - it shows 180? Is this just a rounding effect (I assume this for RATE_PIT/RLL_D) and thus ok? Or might this cause any trouble?



PS: I had some problems like this before - using a "," as decimal separator (some values which should have been in range were marked in orange and showed very high or low values).  I changed this but this is the result.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service