ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 385526

Reply to This

Replies to This Discussion

Craig, I am getting this error with rc5.  Does it matter (is it a problem with the upload or a problem with the verification)?  Will the APM operate correctly?

Here are the details:

  • Stock standard download of 3.1rc5 from git
  • make configure
  • Change config.mk to reflect APM1
  • make
  • make install

Here is the trace.  

Gerrie-mac:ArduCopter gerrie$ make upload

/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -c wiring -p atmega2560 -P /dev/tty.usbserial-A600eGoh -b115200 -C /Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -U flash:w:/var/folders/1b/sybtdbtn69scqmqh6g2bs7cr0000gr/T/ArduCopter.build/ArduCopter.hex:i

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.05s

avrdude: Device signature = 0x1e9801

avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed

         To disable this feature, specify the -D option.

avrdude: erasing chip

avrdude: reading input file "/var/folders/1b/sybtdbtn69scqmqh6g2bs7cr0000gr/T/ArduCopter.build/ArduCopter.hex"

avrdude: writing flash (261648 bytes):

Writing | ################################################## | 100% 48.07s

avrdude: 261648 bytes of flash written

avrdude: verifying flash memory against /var/folders/1b/sybtdbtn69scqmqh6g2bs7cr0000gr/T/ArduCopter.build/ArduCopter.hex:

avrdude: load data flash data from input file /var/folders/1b/sybtdbtn69scqmqh6g2bs7cr0000gr/T/ArduCopter.build/ArduCopter.hex:

avrdude: input file /var/folders/1b/sybtdbtn69scqmqh6g2bs7cr0000gr/T/ArduCopter.build/ArduCopter.hex contains 261648 bytes

avrdude: reading on-chip flash data:

Reading | ################################################## | 100% 40.25s

avrdude: verifying ...

avrdude: verification error, first mismatch at byte 0x3c000

         0xb5 != 0x00

avrdude: verification error; content mismatch

avrdude: safemode: Fuses OK

avrdude done.  Thank you.

make: *** [upload] Error 1

Gerrie-mac:ArduCopter gerrie$ 

Randy, I was reading this 6 month old post

https://github.com/diydrones/ardupilot/issues/249

You said it was fixed, but just wondering doing a mission with waypoints is it safe to go 10m/s, by setting WPNAV_SPEED to 1000, I see it can even go to 2000, Id like to try, but do not want to fly to the ground :)

Leonardthall Sorry, I did not understand, would you give advice to modify parameters?
I have much to learn, so your suggestions are welcome.
thanks


regards Fabio

I just did my first auto tune with my smaller quad and it went great. Need to do it again in less winds but wanted to check it out. When I landed I don't know if I did something wrong but the values were the same. It did it's dance and then I landed and disarmed. Then came to my MP and clicked Refresh but nothing changed. Is this perhaps because I have ch6 tuning set to Stab Roll/Pitch kP? Also is there any info on what parameters it tunes? Just stabP or Rates also? What about Throttle Accel?

Hi,

still have Yaw drift problem. Tried many places. Now magneto is mounted 100mm over quad and still same.

Drift dont exist when i'm in ACRO.

Made live calibration, but drift still exists.

and heres my h-quad:

Attached LOG. Maybe some can give me clue what im doing wrong or what is wrong with my H-quad.

Attachments:

Leonardo, I'm following these steps but something is causing my new PIDs to not be saved. When I switch channel 7 hi/low after the dance is done, it doesn't seem to be much different than my values but maybe I feel some difference. I keep ch7 hi land and disarm. Come to my MP and refresh on CopterPIDs but nothing changes. Is there something I'm doing wrong or something that prohibits an auto tune? I do have a little breeze outside. Would that cause it to abort it?

After completing an hexacopter  and testing , it has a random defect, it twitches always in the same direction very short duration.

I suspects of   some kind of power issue, probably power module is not able to keep voltage steady ,

 

I appreaciate if somebody with more experience could take a look at the readings and help my understand what may be wrong.

 

Thanks

Attachments:

Finally had a chance to test these.  The HUD acted up immediately with all three upon connecting to APM.  Here are the logs.

Thanks Randy.

Attachments:

Yeah, that's definitely been fixed.  However, the fix does not guarantee you won't crash if you set that speed higher than your aircraft can attain.

Just tried it at 10m/sec and it did work well but auto landing was hard, my path was just under 2 miles (3km) over a park and at the end the battery was warm(not hot) but the autoland was stable but noticably faster than it ever has before, hard but controlled.

I did not change the WPNAV_SPEED_DN so I assume it should not land and faster than it did before, please let me know if am I correct on this one that it should not have landed harder than it did before, I assume that it was the warm battery and long flight so maybe I should back off to maybe 8m/sec

I also want to mention that the landing was a RTL set to land at RTL so maybe it was considered a waypoint and it actually used that parmater WPNAV_SPEED?

Ill have to try on a short flight

Steve,

similar issue.  I Ran autotune on my H-frame quad.  it seemed to finish doing the roll tests... never began the pitch tests... so I landed, cycled Ch7 to low and back to high, then disarmed... the PIDs were not changed.

 

thoughts on where I'm losing the plot?

 

 

 

 

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service