ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 385450

Reply to This

Replies to This Discussion

It is bad Detlef.  I'm flying with 3.1 rc3 for now. Today i'll be loading each iteration from rc3 - rc4 to see where it first pops up. 

I will probably get the PixHawk when it comes out....

Randy,

I was just wondering, if the RC output speed is only 490Hz for updating ESC values why would you need to read the sensors with 8MHz? I am not an Arduino programmer but 500kHz input gives already 1000 input values for 1 output to the ESCs. Do you need more for internal accuracy or am I thinking wrong?

regards,
Detlef

Here is a TLOG of a failed auto tune. I've tried it many times but it always fails after about 30-40 roll iterations. Does it show in the log why it failed? I have the onboard log as well if it's needed. APM2.6 standard gps. rc5. 10" props.

Attachments:

Well I found the HEX file where my issue first pops up.  It's 2013-10-13-03:10.

Here is the git-version.txtt file contents:

commit 0e740bd4e1bb018aac3c1ddef09f811de7706b2b 
Author: Randy Mackay <rmackay9@yahoo.com> Date:   Sun Oct 13 11:57:50 2013 +0900      Copter: enable AUTOTUNE for mission planner build  
APMVERSION: ArduCopter V3.1-rc3

Hope this can help track down my issues...

Thanks
- Bruce

Randy,

We already have a nice failsafe builtin.

When the copter is armed, it will disarm automatically after (20 sec default).
The danger of leaving it armed is removed.

And for those first 20 secs of it being armed.
Everyone is already aware the copter is ready to take off.
The pilot will be sure to let everyone know.

Anyway...leaving the autospin off by default is the best option.
Or at the very least, during wizard setup, give the user the option to have it on or off.
Maybe even an indicater in the HUD, showing the motors will spin at startup.
Or an LED flash sequence on the copter for either mode.


nice...the slow mo...lol

Awesome!

 

spent the day testing RC5 and found that the Minim OSD no longer displays the flight mode. (I think its missing from the MAV)  No other hardware or software changes were made to the Hex other than loading 3.1 RC5.  didn't notice any other problems (REALLY liked auto tune)

 

Firmware replaced was 3.0.1 ( I have not loaded or tested any other RC's, so I don't know if its a new bug or has been here a while)

 

 Steve

 

Steve

I respect your point Nick. And I understand that it feels weird or not necessary to have the props spin on arm. And I also believe this is mostly because we all used to have the props NOT spin on arm for a very long time that it because just a habit and now with spinning props it just feels unsafe and awkward.

However, I still believe the prop spin on arm is a much better option as default.

Why?

There is NO danger with this option at all as some of us think. If one thinks that this is a danger because props spin unexpectedly, it must be because the copter has been armed way too early or at an inappropriate location. There is no reason to arm the copter before it is at its take off location or while people are around.

With this feature on, there is no guesswork if the copter is armed or not, one doesn't need to follow and interpret the blinking LED status or give a quick throttle to see if the copter is armed or not. It is so simple and direct: You look at the copter, if the props are spinning, then it is armed, if not, then it is not armed... Period.

Of course, users have all the right to disable this feature and go back to previous state by just changing the parameter. 

But I believe the default should be left at "prop spin on arm" state to let users get used to it. I think developers left it at default for this purpose. Believe me, when I first used this feature, I didn't like it and found unnecessary. But now, it is my default parameter.

I am not a developer but I truly believe that this is the right habit we all need to get used to.

I hope you didn't think that I disrespect your point of view. I understand and respect your comment. I just stated my reasoning why the default should be left the way it is:)

No Power to the Red LED.

I used a multi-meter to check the voltage across the LEDs. The blue shows a voltage ~2+ but, nothing on the RED. So, the LED likely isn't burnt out it is the circuit.

What activates the RED LED? The APM flashes, connects to the MP, HUD works, takes config changes, the copter will arm & disarm, flies, collects logs. I haven't really gotten to do a full flight but, it will fly low and easy around a small area with out any changes. GPS locks too.

Thanks Randy,

I reflashed by the instructions, and  and now work fine,  have tested on my backyard on short fly , before the problem appeared immediately , so I m confident it will work. Logs are normal now.

Even when I have tested many vibration dampening alternatives, logs look always the same , could you tell me what the frequency of this signals, so I can test a more "scientific" approach ?,

Just for the record . Flip does not work correctly under w8, it connects, reads, but doesn't write.

 

Thanks for your help

Regards

Update to no RED LED.

Using Scott Berfield's excellent explanation, here, on how to configure external LEDs and Buzzer I've now what I'd intended to do eventually. This proved that the RED LED APM circuit is still working because the external LED indicates Arm/Disarmed. I just do not have power to the LED.

Software:

I noted that the GPS Blue external LED will not blink coinciding with the Internal LED blinking. This will cause times with no external Blue light. Not a big deal but, a small inconsistency between internal and external indicators. Since my on pcb RED is not working I can not tell if it blinks matching the external for indication or not.

Is there Firmware settings for the on pcb RED LED which some how could have gotten turned off? Like - fuses which somehow may have gotten corrupted or ???  ---- I did erase EEPROM and reflash to firmware 3.0.1 which I had been using successfully.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service