ArduCopter 3.0.1 has been released and is now available in the Mission Planner,, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 387126

Reply to This

Replies to This Discussion

Thanks Randy,

I was really hoping to be able to fly my quad again this weekend but looks like it's going to be a wet and windy one again.

Luckily 19% is still low enough so there shouldn't be any problems...

This could just be where your throttle was during the tests or the wiring could have changed slightly.

Acro is there to help pilots crash copters, not fly them :)

Dude, Leonard, say it isn't so! :)

some people couldnt see the original due to the audio.

Here is a new link that should work in this case.

Hi all,

Can on off de devs (or randy) please have a quick look into the attached hex log. (RC5)

We only have this log no gcs station en problem was in stabilize suddenly drops out of the sky

Can only find in the log that throttle in and out to zero but not on the sender.....

Hex with only apm and gps, no powerbrick and telemetrie.



Thanks for your parameters.  I am really confused because with the same parameters my quad acts totally differently.  

Here are my logs with very similar parameters.  This was with the rc3 but I have tried rc5 and it acts in the same way.  

My :

  • baro readings are nice and clean
  • my acceleromers are very clean
  • (even my sonar which I have now switched off is really clean)

I would really appreciate it if you could have a quick eye-ball of the logs attached.  These are run without any sonar.

I am really at my wits end!!!

The 23-36 2 file is more interesting.  The one thing I notice is that the Z-accel readings seem to bear little reference to the baro profile.  

(Oh, this an APM1)



My 2 cents is as follows

  • I got a huge fright the first time
  • I love it for its safety - my kids fly and there is no chance of someone approaching the quad and picking it up without disarming

Please keep as default!

@Andre & Randy,

For the new FW (3.1RC5), does it work with the AMP1 board ?

Thank you.

If you do a survey or something Randy, I'd suggest one of the options being "I already know its there through early-adopter testing, so I really don't care what the default is anymore :)"

...I'll choose that one.  The smiley is key, though.. 

If you get an oscillating buzzer, I would think that means the buzzer is plugged into the wrong output, because I never set up the buzzer for oscillation.  

What I don't understand is you're saying that your buzzer will go on and off (beeping) when you enable oscillate.  But then you are saying that you want it to go beep-beep-beep.... These two statements contradict eachother?

Steve, I don't think anybody else has reported this.  It's totally new.  It's possible there's something peculiar about your hardware (ie: weird processor problem?), or it's possible that something about your setup, your specific parameters, which is triggering a bug.  But Randy and Leonard cannot find any bug.  So that would point back to it being a hardware problem.  But that in itself is so strange of a possibility, that it's hard to come to that conclusion, so they are still looking.

I'm having compass issues again with v3.1rc5.

The resolution is described here in this issue.

Randy, would it be possible to please get it included in rc5 beta and/or the final release?

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service