ArduCopter 3.0.1 has been released and is now available in the Mission Planner,, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 385510

Reply to This

Replies to This Discussion

Bruce, Detlef,

     I've created a discussion re the SPI bus issue here.  There's a new binary I'd like it if you could try.

Hi Springfield,

I just removed the old one and raised it to the top of my frame dome (not seen in the pic below as it is an old one)  I kept the orientation the same and I had to replace the metal bolts with nylon ones as they were giving me terrible offsets.

When I first built my quad I had the carrier board parts cut from 1mm ABS plastic.  Luckily for me when the whole thing about vibration dampning started I got good results because the plastic is flexible to a certain degree...

eCalc is subjective in that respect... It says my qav500 will hover for 3mins and I get ~10-12mins hover.  Maybe saying "eCalc is relative" is a better way to say that..

I've seen the F450 run with 8's just fine with 4s and 800's, but 3S likely would make you feel like time is slowing down.  To be fair, my friend that flies the F450 did upgade to either 900's or 980's with 8" props, I don't remember which.  He also tried 1250's for fun, but then went back to one of the 900 models.  Worth a try if you're bored, but if you're having fun with it? :)

Hi David,

It looks to me like you have got a very good tune. Looking at your second log it looks like you have good requested vs measured roll and pitch angle. The biggest pitch errors spike to 5 degrees and most of the flight is less than 2 degrees. The errors coincide to be closely related to command inputs and are expected.

So am I missing something?

Have you tried SPORT mode? The reason I ask is that it would let you set the pitch angle and then take your fingers off the sticks. This would keep the desired pitch angle constant while "driving" with yaw. If it is being caused by the controllers this will clearly show it up.

My theory is that all this is being commanded rather than being oscillations in the control system. By reducing the Rate P and increasing the Rate I you have slowed the rate controllers down and have masked the problems. We could test this by using Sport mode or you could add some code to slew the angle request.

Has anyone been flying this new firmware on a Pixhawk unit? C'mon release them already!


I've noticed mine doing this (at least with the internal compass as I have the combo external uBlox now and haven't paid attention to it lately). It doesn't seem to affect flight as mine does great in Auto, Loiter, RTL etc. I don't have anything short of a rock solid loiter even in 10 to 12 mph gusting winds. I am interested if the Devs have any input on this.

Please provide the option to include the content of the message on the email notification, for the new forum.

See link below for the same request for ArduPlane.

Otherwise, email subscribing is not useful.

Andrew T. said he will try to provide this, see link below.

the desire to have the content included in the notification

Hmm.  I get the poster's content when I'm notified of new posts via email. I use gmail.

About the link to the new forum.

Does this mean that the current forum at is going to be closed or something? Anyone?


No, the DIY Drones Forum will continue to function as it always has, however issues related to 3D Robotics hardware and the accompanying Open Source Firmware will be migrated to the new Forum. This migration will provide more room on the DIY Drones website to present the expanding international world of UAS platforms, issues, and development.



With latest MP 1.2.85    1.1.5409.36165

Three (2) Issues/Problems -

1) Mission Planner Map Error message on start.   Update MP 1.2.85   build 1.1.5049.36165

Description (Repeating):
Start up error message is: "Map change failed. try zomming out first." The error instructs to: "try zomming out first." --- I zoomed out. This did not self correct the problem and this error repeats on each MP initiation. Also, the map will not zoom to last zoom level as previously but now zooms out - to N.A. in my case.

This upgrade has already crashed once with error - Windows 8.

2) No Heatbeat detected. After MP upgrade the APM USB connection fails. (Repeatable but will connect once in a great while Sporadic).

Mission Planner 1.2.85 1.1.5049.36165 did have one successful connection after the initial automated upgrade but, on subsequent connection attempts the MP fails out indicting no heart beat detected. Note: While writing this report after several minutes of APM connection to USB and no connection to MP I tried again and the connection worked. I had tried several times prior and rebooting the MP with no success. After connection and HUD functioned I disconnected the USB and tried to re-initiate connection between the APM and MP with no success again.

The MP initiates connections by reseting the APM and then times out with the error message that it can not get a heartbeat. Upon which the MP stops connecting to the APM. The APM restarts and comes to a normal stable LED condition of GPS lock, Blue LED solid, and the Arm/Disarm (external in my case) Red LED blinking. The Tx is bound to the Rx on the APM and connects. I am able to Arm and Disarm the APM from the Tx. Note: I can not flight test - My copter is apart.

****   Question: How do I downgrade to MP 1.2.84?


And yes, a few more issues spotted in log download and it consistently happens with 1.2.85 Mission Planner.

This reminds me to ask one question:

Why isn't Mission Planner fully tested before giving the option to update?? This has happened not once but many times. I am not complaining here, but request to check in trouble free updates as far as possible and choice to downgrade to previous version, shouldn't be that hard.



Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service