ArduCopter 3.0.1 has been released and is now available in the Mission Planner,, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 385887

Reply to This

Replies to This Discussion

Exactly my problem as well.  Fix or downgrade option please.

Lack of reliability/repeat-ability seems to be a hall mark of this whole enterprise.  Huge waste of time just to stay in one spot.

Cheers . . . . 

Her you can find previous Missionplanner

Thanks Goran!  


I don';t quite agree with you. This platform involved a lot of work over time and "hall mark of this whole enterprise" is not a true statement. Arducopter has stabler releases so we can't complain about 'enterprise' as a whole.

The issue is with Mission Planner, and I have raised a bug report on github/missionplanner/issues. Also, in light of the fact that Mission Planner is handled by only a handful individuals.

@Someone: Does anyone know if github/missionplanner/issues are ever addressed? It doesn't see to move and has been looking stagnant for quite some time now.



Voice Battery Voltage announcement when connected to USB.

Is it possible to have MP planner automatigically toggle between disabling Battery Voltage announcements when on USB working when no USB connection but, a battery is connected for flight?

Thanks Randy - and there it was all along in APM_Config.h - just as you said.

Is there a guide to update the complier anywhere?


+1 on bugs #1 and #2, I haven't experimented with #3. The solution to #1 is simply select a map type in planner the restart. With #2 my symptoms are identical... maybe the reset operation is buggered?

HI Developers of MP --- Where would I place feature issues?

*** Sorry about a missing problem 3 above. I posted then deleted because it sort of worked and I thought I'd not address it at this time.

Here is a screen capture which shows crowded HUD text on the MP 1.2.85 and a new field with no indication of use?

Below also see a long standing issue I had posted with no resolution regarding the updating and viewing of Telemetry.

Thanks for your diligent work!



What I decided to do is to tune the compass declination so that it points in the right direction when I have the battery connected as this is how the quad would be when flying...


How do you 'tune' the compass declination alone? Can you explain that to me?


Hi Shyam,

I use the method as described here:

Set ch6 tuning option to "Declination" and enter a min value of 0 and a max value of 2.  Save the changes and go back to the "Flight Data" screen.  Now turn your ch6 knob until the heading (red line) of the APM matches the actual heading that your copter is facing.  Best way is to point your copter parallel with a street and then tuning it until the red line also points parallel to it on the map.

Just remember to tune it a little bit and then leave it for a few seconds for the reading to stabilize before you tune it again as there is a little delay...


Hi Leonard,

I tried it with Sport mode and it does seem to be a lot less jittery, although still quite jittery at higher speeds or angles. Log attached.

If this jitter is indeed coming from commanded input, where would the source of this input jitter most likely be?


Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service