ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 386577

Reply to This

Replies to This Discussion

A log would be good to help figure out the cause but some possible causes are:

    1. the throttle stick is accidentally being pulled down a bit as you move the sticks around (sounds silly i know but it happens!)

    2. the baro pressure is changing because wind is hitting the baro as it leans over (unlikely if you're using an original 3DR APM which comes in a case with foam inside).

    3. the accelerometer calibration hasn't been done correctly so it thinks it's rising or falling when it leans over.  You could actually check this on the ground by connecting with the mission planner and leaning the copter to the left or right and see if the altitude in the MP changes.  If this is a problem then try re-doing the accelerometer calibration.

John,

     Yes, the "APM with External Compass" is meant for use with the 3DR GPS+Compass module.  What that does is set the orientation drop-down at the bottom.  That's the critical thing to get right.  Coincidentally though I think you want ROLL_180 which is actually the same orientation as pushing the "APM with external compass" will set it to.

     So I think with that external compass mounted the same way as it was on an APM1, it's "components down pins forward" right?  I'm pretty sure that's ROLL_180.

I will check those items. Also I fly mode 2 so my pitch and roll are on the right and throttle and yaw are on the other so it's unlikely.
Yes it is a 3dr apm 2.6. I will check the accel today and let you know. I will also flight test it and attack a log.

Thanks
Joe

It's a lesson well-learned for me as I spent the better part of a day discovering this on one of my quads! :)

Hi,

I just had a huge crash this morning, hoping somebody can help with my logs.

Setup:

Arducopter V3.1 rc5

APM2.5, modified with External compass

TBS disco,

Tiger MT2216-11 (900KV)

F30A ESC

Graupner 9x5

What broke:

4 props

1 arm

GPS antenna

Antenna stand

external piezo buzzer

Dragonlink receiver SMA coupling

1.3G CP video antenna

GoPro lense protector

Top Frame plate

I was in my backyard making use of the low winds setting some trims. A bit of a slight wind came through, which I tried to correct for by giving it a little bit of reverse pitch, then it just pulled itself full backwards and nearly straight into myself, and narrowly missing my kitchen window. It smashed straight into the wall at full reverse throttle. It stayed that way until I was able to disconnect the lipo. No property damage, just my quad.

I had just finished installing a new antenna mast which holds my GPS and compass, so was making sure it was still trimmed OK. not sure if the new antenna had anything to do with the crash.

Attachments:

Nicholas,

     A few things from the logs:

  • the copter switch to RTL because it thought that it was outside the fence (see map below of where it thought it went).
  • GPS Hdop value climbed to 9 a bit before the crash.  This was probably the main cause of it thinking it breached the fence.
  • GPS failsafe was disabled.  Maybe this was done because of the bug in -rc5 related to it switching to LAND mode?  Generally there's no reason to disable it and -rc7 is out now so if the -rc5 bug was the reason, I'd recommend upgrading.
  • GPS is only running at 2.5hz instead of 5hz.  This can be seen by checking the Time field in the GPS messages.  They're 400ms apart when they should be 200ms.  This is a bit unusual because the APM requests 5hz from the compass when it starts.  Maybe the GPS cable is broken so messages aren't getting through to the GPS.  I've made a video here which shows how to manually set the ublox's configuration to the 3dr default which will probably resolve the problem.
  • Compass orientation is set to "4" which is possibly correct if using an non-3DR external compass but probably worth checking because it's not an orientation that we normally see.
  • Pretty much every message type is turned on in the logs.  The AVR CPU is pretty overloaded so we don't recommend doing this.

Best of luck.

Thanks Randy

That's the first time I've had it think it's outside the fence. I hope it's only related to and RC5 issue.

What would cause the HDOP to climb to 9?

What are the main recommended logs I should turn on?

Things for me to do:

put her back together again.

upgrade to RC7

Ensure GPS failsafe is enabled

Fix GPS refresh rate

fix my logs

yep I have it with pins  to the front and components down same as when its fitted to APM1. I'm not sure what it means by "ROLL_180"  Does this make the firmware read it as if its flipped over to suit? eg, If I flipped the mag over with components facing up would be the same except then left right would be in reverse?

Nicholas,

     Setting the Log_Bitmask (now found in the Standard Parameter list) is default is generally the best unless you're specifically testing for something.

     It's hard to say what caused the bad GPS hdop.  There's some discussion about multipathing here that might be the cause or maybe there's some FPV or other radio gear near the GPS that's causing interference.

     I don't think this crash is caused by a bug in -rc5.  I believe the cause is a very bad GPS position and possibly a slow GPS update rate.  The steps you're going to take look good to me though.

Thomas,

     1. we've had this reported by Rob on the dev team as well.  I think when using the on-board compass there are some power lines which pass too close to the compass and upset the offsets.  There's some discussion of doing some additional tests to find out if these offsets are dynamic or static.  For example if more power is pulled through the system (for example by attaching servos) do the offsets change?  If they change then it's not good, if they don't then we can just increase the pre-arm check limits for the PX4.

     2. I've heard SBUS works but we've also got a fix in the issues list that one person says makes it better

     3. Rob has also reported twitches but this hasn't been investigated.

     #1. this might be ok so I wouldn't worry too much.

     #2 definitely sounds like local interference.  You might want to rotate your copter around and make sure the mag field doesn't change in length too much.  If it does change a lot (like over 30) then it might be best to re-do the compass calibration in a location with less interference.

     #3. We haven't had any other reports of this so I suspect it's something specific to your set-up or config.  Could you try going back to AC3.0.1 and see if it still doesn't work?  If it still doesn't work then it's probably unrelated to the upgrade.

-Randy

John,

     Yes, that orientation parameter is the orientation of the compass vs it's regular orientation on the APM2 board.  So if you flip it over so it's components up, pins forward then you could use the orientation "None" I think.

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service