ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 386065

Reply to This

Replies to This Discussion

Light is affecting baro. Use a flashlight and you will see.

For that reason I mentioned cover with "black" foam.

Thor,

     It's very hard to tell if that's a good throttle level based on the log posted.  The instructions on how to figure out a good value are on the wiki here.  My guess is that the copter hovers at about 65% so 650 would be a better number but really from the log provided it's very hard to tell because it's not in a stable hover I think.

Ok thanks Randy, i will try 650 tomorrow and capture a log.

I am curious, when the Quad THR_MID is set to 450, with all Failsafes disabled, why it shuts down motors. The firmware seems a bit more temperamental in RC7 then 3.0.1. i did read that article, thats why i thought i was under powered and went with 450. 

Also if there is a good explanation of how the values in TX Calibration related to throttle percentages, i would love to read over that

as always thanks for your help, its why i bought your products and continue to recommend them to others.

Thor,

     Many of the throttle parameters are in percent * 10.  So for example 450 means 45%.  It would probably be better if these params were all just percent but that choice was made for performance reasons at the beginning of the project because integer math is faster than floating point.

     I'm not sure where in the logs you're seeing the motors shut-down but I also noticed that you may have set the THR_MIN to 50 (it's default is 130).  That number controls how low the altitude controller will lower the throttle and 50 (i.e. 5%) is so low that it may be below the ESC's built-in deadzone.  I'd recommend returning that parameter to it's default of 130.

I tried "drift" today... worked very well... fun to play with but videos captured with a gimbal don't look as interesting... off with the gimbal for "drifting"!

Thanks to the developers!  Great stuff!

the log you are seeing is from flight outside, not the inside where you would see the shut downs, i can post  those logs if you like? i will adjust the min. i never edited that, i assumed when i upgraded firm ware it changed

This is the flight from the log incase you wanted to see it https://www.youtube.com/watch?v=jlG_nkQ81Eo

I believe this is the log that shows loss of throttle when indoors, props off, testing changes in the throttle when switching from stabilize to ALT HOLD or Loiter. i have made the THR_MIN change  to 130 this morning but it didnt make any difference, throttle still cuts out when switching flight modes. i dont know this is a legit problem or not, but just incase its some hidden bug or just particular to these walkera parts. 

Attachments:

Hi Randy,

My new X8 was doing something similar. Hover was at about 60%, which to me seemed like a lot. THR_MID was at 350 I think, so I changed it to 550.

Worked great to fix the AltHold, but now I am hovering at about 45%..

It worked, but not as I expected.

I thought my hover throttle would stay at  55% but that the autopilot would not require less to maintain alt in ALT_HOLD

my craft generally hovers about 6 feet at 45%. in firm ware 3.0.1 it wouldnt increase altitude in alt hold, it would hold the altitude very nicely. in this version it seems there is a, in my case, maybe yours, a disconnect on the  throttle needs of Alt Hold/Loiter from Stabilize. thanks for adding your note, it is appreciated

Suggest that you get it outside and above 6 feet.
Need to take the ground effect out if the equation, and put it into a real-life situation. I'd get it at about 30 feet, minimum.

When I set mine, I hold altitude in Stab for a while, noting the throttle gimbal marker position. I can verify the position in the Throttle Calibrate screen and with the flight log showing the flat altitude.

David and Thor,

THR_MID is an output value to the motors, so if you hover with 60% stick and wish to hover with 50%, then increase THR_MID from 350 to 450 (450-350=100=10%). You increased output by 200 that means 20% more power to motors, so you only need stick at 40%.

There is a misunderstanding because nobody mentioned that THR_MID is output percentage and not equals stick position! If you dont want to calculate you can follow the instructions on the wiki.

Thor,

Did you try decreasing THR_ACCEL_P to 0.75 and THR_ACCEL_I to 1.5?

1.0 and 2.0 seems a bit high and could influence Alt_hold.

Did you set up your power module or why do you have a current of ~170Amperes????

Did you calibrate your ESCs and TX already?

Regards Christian

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service