ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 386033

Reply to This

Replies to This Discussion

only thing that changed was the firmware...

Ryan, we have some great documentation right here http://copter.ardupilot.com/.

There are instructions and videos at the start of this thread.  Go become a responsible pilot and be prepared to operate your craft in a knowledgeable and skilled way.

Ryan, you are spending an awful lot of time grumbling and complaining about something that thousands of people are now successfully flying.  When you changed from 2.9 to 3 did you read and follow the upgrade instructions?

A lot of people have spent a lot of time developing this release and spent a lot of time explaining it to people that want to learn.  All of you are too polite to to him to "go fly a kite".  I appreciate what you have done and a have no emotional ownership in it. So<  have no problem telling " Mr. Ryan" to piss off!  Experts, do not waste a single keyboard stroke on this person. 

There are people that are really involved and want to learn and fly with the features that this system has, this guy is not one of them. 

keep the faith....

Last night I figured out how to put older firm ware on! (I am such a Noob, thanks for your understanding and time.) Loaded up a 2.6 or something made sure I had a control link, REINSTALLED the 3.0 did all the calibrations got a control link!

 Fired her up and went for a lil woo, All systems check, ALT HOLD ok, Loiter is way better, still starts to circle but less. It can be corrected manually but will start to wander again.Think it might be vibration now.  I also put the GPS on a 3inch standoff. Started to peck rain had to land. But way happier than I was yesterday!! Thanks to Craig and Richard. Cheers n Beers

My previous objection was made before seeing your solution of leaving the parameter but defaulting it to zero m - that seems just fine to me.  (When O when will we ever see a discussion system that doesn't have dozens of topics spread across 149 pages under a single heading...?)

The amazing thing is we have at least 2 more releases of very significant features for Arducopter in the works and a couple that are just cool and useful

Sweet. Care to spill a few of those beans?  :D

Agreed, kind of tired of the drama hitting my inbox.  If you're unhappy, cool, move on.  If you have an interest in going through the upgrade process per the instructions and then giving feedback on where you're stuck, also cool.

First i enable GeoFence. I set 30 meters radius and 30 altitude. I set GeoFence to ch7 button. I take off nead itself and change switch position to ON. Then i fly forward, left, right... for test. Copter fly about 30 meters and do RTL. All ok. Then i change switch position to OFF and fly >50 meters. GeoFence is not working - it OK.

Then i power off copter (change battery) and fly >50 meters, but how length about 30 meters i again see RTL more times (i see GeoFence works with switch position OFF). Then i change switch position to ON and OFF. After it GeoFence not working - all OK. If i power off, then this behaviour again.

Use a bigger radius.  30m is VERY small compared to the GPS position error

Look what's inside the Walkera X350 over the Baro! Over that is a black foam. The opne area is pointing forward

Just a guess... it sounds like the default is GeoFence on after bootup (when enabled), and the ch7 switching routine is responding to changes in ch7 state, not periodically checking ch7? A simple fix: add "GeoFence switch off" to the prearm checklist.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service