ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 386576

Reply to This

Replies to This Discussion

For the flight we posted the non-APM related electrical devices were a 2 axis brushless gimbal that is mounted under the center of the quad (not near the APM or GPS) and a GoPro camera on the mount.  I've included a picture of that vehicle:

 

Hi there,

Does anyone know when you are plugged into MP and you have a gps fix should the quad icon on the flight plan view stay still ie is this representative of the actual position the quad would be trying to achieve if in loiter. My icon seems to wander around with 9 sats and a hdop of 1.5 and my loiter is not great. Cheers Alex

I see your large reflector and I wonder with this in mind: 

"GROUND PLANE SIZE
The larger the ground-plane, the higher the antenna gain in general. Also
the centre frequency of the antenna will change in proportion to the size of
the ground-plane."

The whole text found here.

Biggest mistake you can do is order motors, esc's from that place. Buy from a reputable dealer. Thats just my 2 cents. How about putting on some american made esc's? You get what you pay for. 

There is a envelope on that ground plane to gain though. 

Hi,

I have had something happen recently while flying that has not happened in the past, I thought it was only on one copter but I had it happen on my second quad today. I am running the "latest" FW  I just loaded the latest FW on the second quad to see if it would happen nd it did.

Flying in simple mode switched on via ch8 option I will be flying fine and it will go 90 degrees out of wack, forward reverse becomes right left and right left becomes forward back.

I tried looking at the log and the compass seems ok (I should always be pointing North  in the log I will attach) so I dont know what it going on.  It will stay 90 degrees out even if I switch ch8 on and off. it stays 90 degrees out until I land, unarm then arm and take off again.

In the log it happens once, I switch off simple mode, land and take off again.  not sure if this is a bug or what, I am using external compass's and have done compassmot  with pretty low mag field 7% on one and 8% on the other if I remember correctly.

thanks,

John

Attachments:

HI Randy,

Re-tuning from the beginning solved the issue. However, I'm not happy with how she behaves now: not a very 'tight' feeling. Very sluggish, so I have more work to do. 

Trying to locate default parameters to try with those. 

Thanks

AlexP

Does anyone know the default parameters for this release (Quad). Seen them before, but somehow I cannot find them....

is there truly such a thing as an American made ESC? I know a lot of stuff that has made in USA on it is not necessarily made in America. I know that for a fact becasue I have seen it in factories Ive been to in China and the stuff they are making for  American companies had printed on it "Made in USA"  One of those companies in particulate is Oakley.

Hi Randy, and everyone else!

I am flying a large coaxial machine and have noticed that my telemetry disappears as soon as I raise the throttle above idle. I am using RFD900 modems and no matter what settings I use as soon as I go above idle it drops the telemetry rate. 

I am using apm2.5, with external compass. The modems are fine ( I have a few pairs, and all test out ok on the fixed wing) 

My guess is that the apm 2.5 is just overworked and can't keep up with the processing of 8 motors and the telemetry.

as soon as I drop the throttle to idle i instantly get the telemetry feed back. I need it to work for position and AP work, nxt option i guess would be to go to the PX4

Any thoughts or things to try?

Anyone else running a octo or quad-octo with telemetry?

Cheers

Steve

It is almost the same time required to process 8 motors as it is 4. And it is the same amount of time to process them at low throttle as it is at high throttle.  Overworking the 2.5 is not the problem.

It sounds like either a power supply problem or noise. 

Are you powering the RFD900 off of a separate supply from the APM?  The APM can supply enough current to operate the RFD900.

It sounds like a power problem. The RFD900 needs more power that the standard 3DR Radio. aPM 2.6 works as the fuse was increased to 1A that limits the power on the APM (500mA) on APM2.5

You can power the RFD900 from an external BEC or from the OUTPUTS side of your APM, i believe there's a jumper on the RFD900 to disonnect the power coming from the telem port.

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service