ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 386579

Reply to This

Replies to This Discussion

Thanks.  But I think this menu option is only available in Arduino 1.0.3.  I guess I'll have to downgrade.

http://ardupilot.com/downloads/?category=6

Also this version is only available on Windows and Mac.  I'm using Ubuntu Linux OS.

Guys,

I need your help. APM2.6/3.1rc2/SimonK. The quad is flying great in Stabilzie, also Loiter is holding pos and altitude without toilet bowl. What I noticed in my videos though is that the motors seem to be very aggressive in Loiter mode, especially in windy conditions. Please have a look at the video and point me in the right direction of which parameters to tune. Loiter PID's, throttle rate or throttle accel?

Thanks,

Michael

Attachments:

hello Randy & Devteam,

Is there a way for the system to detect if it's downward velocity decreases rapidly?

Randy,

On the Fence, I read the Wiki here

http://copter.ardupilot.com/wiki/ac2_simple_geofence/

and watched the Youtube

http://www.youtube.com/watch?v=HDnGdo54o-4

But I did not 'see' where its mentioned if the fence is ignored in Auto or not, i.e. can I fly in Auto and it will ignore Fence.   Also if so and I am in Auto and I was past the second fence(+20 meters outside first fence) and I changed to Stabilized would it land or better yet try to come back home first?

I also don't see RTL Altitude mentioned so not sure what that does.

Thanks guys, this is cool.

Edgar,

     If enabled the fence isn't ignored.  So even in Auto mode if it hits it, it'll switch to RTL and attempt to come back.  It will come back at the RTL altitude even if that's been set to be higher than the fence's maximum altitude.

     As you can see with the fence it can be a bit like the left hand not knowing what the right hand is doing but that's 'cuz it's a fairly simple implementation at this point.

     One note of warning on the Fence, don't set it to be too small!  I.e. keep it at least 50m radius.

Perfect, I just set the max Radius to 500m, I know it sounds far but I've always worried about changing to Auto and I have the wrong plan loaded and it tries to go 10 miles away, this would take care of it.

Maybe we can get an ignore if in Auto in the future, but its still a great new feature with or without it.

I had a sudden uncommanded yaw for a couple rotations in Alt Hold Mode on my Tricopter today which gave me quite a scare, especially since it was a demo with spectators watching. The rest of the flight continued normally. Can anyone provide any clues as to what might have caused this?

Thank you.

Attachments:

Hi iskess,

Nothing new. I had a lot of such surprises see below.

Command to descend produced a turn right.

 

Peaks with no command and jumps back.

Try to disable the Dataflash Logs. After this I had no more such "implemented" surprise. I assume the Processer is at its Limits and it is a Timing Problem. You can read a lot of such Troubles in the Forum.

Wow, maybe I should go back to 2.9x where I never had a problem. I just upgraded.

I don't really want to turn off all the data logs, since I often fly without telemetry. I have the default ones enabled. Can I slow down the smaple rate instead of turning them off? Maybe there are some I could do without.

Hi Randy,

Can you have a look at the attached log file please. My hex does not appear to respond to any of the stick movements apart throttle which works as expected. The hex hovers for a few yards and then flips. I appear to have no control of in pitch, roll or yaw?

Set up as follows:

DJR 550 frame

V3.0.01

Hex +

6 x 1000 kV motors

10 x 4.5 props

4S 2600 LiPo

I have attached log files - being new to this I am not sure which you need?

Hope you can help.

 

Regards

Barry Cooper

 

 

Attachments:

Hello!

I have this mag: http://www.goodluckbuy.com/gy-282-hmc5983-high-precision-triaxial-c...

but I don't know how to install it :( I have conected trought i2c port but now I don't know to continue with the installation.

I tried to calibrate with live calibrate but I obtain the message: "log does not contain enough data" and if i try to do the compassmot: "compass not healthy"

Please can you help me?

Sorry for my english.

Best Regards.

@Diego,

What instructions did you use to connect the APM I2C port to the compass?

The instructions in the Wiki are for connecting a 3DR stand alone compass to the APM I2C port: http://copter.ardupilot.com/wiki/common-external-magnetometer-for-i...

How did you determine what I2C connector wires went to the right pads on the new compass?

From the symptoms that you have described, it sounds like you did not get your new compass wired up correctly to the I2C cable.

Regards,

TCIII ArduRover2 Developer

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service