ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 387208

Reply to This

Replies to This Discussion

Michael, is your original question around max angle or around the rate at which the copter will reach max angle?

I think you're asking about the angle, which has nothing at all to do with your PIDs.  Well, it does, in the case of overshoot, but let's table that..

Loiter in its default config will only let the copter go so fast, which ultimately requires much less lean angle.  Stabilize is going to have a max_angle limiter of 45º because it is set up to allow people to fly around a little more freely.  I believe the parameter you can change here is actually called "MAX_ANGLE" and is set to 45º by default.  You can roll this back to 10º if you really want, but I would tread down this path with caution, because if you get yourself into trouble as you get more comfortable with flying, a 10º lean angle limiter may not be able to generate enough force to point your copter in the direction you want.  Maybe knock it down to 30º and test that way?  You can also consider the use of dual-rates on your transmitter if it is so equipped, and reduce the end-points to a level that suits your flying style.  You could then switch to this dual rate mode when you just want to essentially loiter around in Stabilize.

Hope this helps.  If I've missed the mark here, apologies.  If someone else knows of the correct parameter and it isn't MAX_ANGLE then please do post the correction.  

Edit: Yes it is normal for Stabilize to have a steeper angle than Loiter and potentially althold.

thanks josh that is a great explanation!

Maybe i just got to use to loiter default pids. I feel much more comfortable flying like that with slow reactions. Because if a roll all the way to the left with full stick movement in loiter it moves slowly and has a small tilt angle different to stabilze/althold if i roll all the way to the left with full stick movement it tilts with a big angle and moves very fast but flies fine just i don't like it that fast and prefer the slow loiter default movements. 

maybe i asked the wrong question. What i would like it stabilze an althold to go as slow as loiter which would result in a much less lean angle. Any ideas?

I will try and drop MAX_ANGLE to 30º if nobody can give me anymore input thanks again Josh for the great info!

Thanks :)

I think you've asked the right question, just were looking in the wrong area to address your request.  Have a look at the MAX_ANGLE. 

Funny, for me I want to move that to 80º on my sport flyer :)

some more info please if you can help.

Got firmware 3.1rc4 installed and tried autotune today. It didn't work.

These are the steps i used:

- full param page changed ch7 opt to 17

-apm copt pids page made sure ch7 opt is set to autotune

-radio calibration page make sure radio 7 goes above 1800 pwm when i flick the switch (it goes from 1070 to 1918)

-fly my quad with ch7 at 1070(low) change to althold hover for a bit then flick switch to 1918(high).

nothing happens i get no twitching from my quad i wait a bit then land it with ch7 at 1918(high) and disarm it. Go to mission planner to see if any values have changed but nothing.

Did i miss anything? From what i read version 3.1rc4 came with autotune and you didn't have to change and compile the code.

-rc4 does not have Autotune enabled.  There are gobs of posts buried in this thread but basically it is not enabled, you're likely best to wait for -rc5 due out in the next few days.  

Your PWM values are fine, don't stress there either.

edit: It was originally thought to have it enabled, but that was a miscommunication.

ok thanks alot. Will try ANGLE_MAX 30º tomorrow and come back with results.

Have a good one!

Michael,

So, I don't know where I was looking before, but MAX_ANGLE doesn't actually exist.  I'll keep looking through my parameter file, but perhaps I saw this in something Randy was going to introduce down the road that isn't readily available yet.  

Sincerest apologies for the confusion here, but hopefully I find something in the next little bit, or someone else has an idea on limiting the angle/speed of your copter in Stabilize.  Alternatively, you can chase down the dual-rate idea from above, too..

Josh there is no MAX_ANGLE but ANGLE_MAX exists and i already changed it from 4500 to 3000 :)  

Strange, for mine it doesn't matter and in the code, the hdop <2 test is only done for mode that need GPS

Ah ha!  Good find, thanks.  Sorry about the unintentional dyslexic moment there

Sorry if this has been asked and answered, but I'm unable to find...

I've got a copter that in Stabilize requires one throttle setting to hover, but in Acro requires just a tiny bit more.  Is there a setting I can tweak to be able to maintain the same PWM-output to "Throttle" between the two modes, or is this a deeper tuning issue between Stab and Acro?

My THR_MID is set to 444 and my TRIM_THROTTLE is 531.  I thought about getting these two values closer together but I know my copter hovers just under half (which is why I set THR_MID to 444, per watching the Tuning window in MP) and I thought we weren't supposed to alter TRIM_THROTTLE as this is calculated live.  Maybe I just suck it up and adjust THR_MID to match?  

Anyways, appreciate any input!  Throttle params in the attached jpg..

Question for anyone with regards to ACRO...  Are ACRO_BAL_PITCH and ACRO_BAL_ROLL ignored when ACRO_TRAINER is set to 0?  Or if you want true rate-control do youneed to set both of those to 0 as well?  

The wiki is not current on these parameters as it still references AXIS_ENABLE which I believe has been deprecated..

Reply to Discussion

RSS

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service