ArduCopter 3.0.1 has been released and is now available in the Mission Planner,, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 385547

Reply to This

Replies to This Discussion

Hi Shyam,

In order to check why isn't arming, try to connect your APM on MP then try to arm it. You should be able to see what's happening. (reminder: don't plug your lipo batter yet.)

good luck.

Glen and others who posted on this, thanks.   I loaded 2.4 r682 and all is well.



Ok, well, if the surging returns remember we have this binary we'd like to run on your board to zoom in on the cause.

The easiest way to get the six channel transmitter to work on channel 7 is to take the sixth channel from the receiver and plug it into the seventh channel on the amp. To set autotune you have to go to the advanced parameters and go to channel 7 and set it to 17 and then it will be set for autotune.

Thanks, I saw some guys reporting they tested this it in flight?! And failed for some reason ...

Here is a close up of part of my board.  I've circled two areas of concern. One appears to be a damaged component on the left and what looks like a short across one of the legs of the package on the right.  I think its the OB compass - it's been disabled.

The I2C's plastic socket came of the board after using the 3DR cable recommended for adding a 3DR compass.  Connection is still good though when plugged in





     Normally the yellow led should only come on during autotune or esc calibration.  Is it always on?

     We sent the failsafe status a little different in AC3.1 than in AC3.0.1.  We use a bitmap now instead of sending long strings.  Maybe there's something going wrong there...I'll have a look.

Is the new MP release buggy for anyone else?

I just opened up MP, it asked me if I wanted to update, I clicked yes, it updated (1.2.85), then problems started. It says "Map change failed. try zomming out first." every time I startup now. Connecing to my APM fails now. Most of the time when I hit connect, the LEDs on my APM go out, connection fails, and after I close the timeout dialog the LEDs turn back on. I can still get it to connect by letting connection fail first, then hitting connect again as soon as my APM lights start to flash again. It consistently connects to the terminal (CLI) still, but the GPS test seems to crash.

Looks like the Short is intentional on the compass as it is present on the external unit i got from 3DR also...

Interesting about the pitch and roll PIDs being so different after autotune. I also got similar results, with pitch P at 1.4, and roll P only 0.09. This didn't work out for me at all, it made SplineNav fly a nasty wobbly curve instead of being nice and smooth. So I averaged the autotune pitch and roll PIDs and set them to be the same numbers, i.e. 1.15 for pitch and roll P. Similarly for I and D. After this SplineNav flew a super smooth, precise curve, no more wobbly back and forth.

I wonder if the non-symmetric pitch and roll PIDs would affect the precision of other auto modes as well, since they all use the same loiter controller. But maybe not, since the other auto modes only fly in straight lines anyway. Well, except circle mode, might be interesting to test the non-symmetric PIDs on that too.

Select a map source in the flight planner screen again and restart.

The "Map change failed. try zomming out first." was resolved when I uninstalled the complete thing, deleted the folder in Program Files and reinstalled fresh. The connection problem stays, I get lucky if I hit a couple times the reset button while MP is trying to get a connection but something is not working right. Besides, CLI and firmware uploads always work.

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service