ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 386834

Reply to This

Replies to This Discussion

Thanks for the report! I've created an issue here for it so we should fix it for 3.1

I saw the new firmware come up on my software suite. Now I am running a RTF 3D hexa thats (apm 2.5) less that 2 weeks old should I really be upgrading this seems like lots of improvements.  My major question is do I need to go through the whole setup process or just reduce the pids suggested? Everything is stock setup from 3D.  Is there a backup function to what I have now just in case I have issues and just want to go back with all my settings. I assume I can just screen shot everything.  Thanks guys you are doing some really amazing work.

Oops... that upgrade didn't work for me.  Almost had my hexcopter slam into the ground from a very high altitude.  Could someone please look at the attached logs for any issues you see?  Any help would be greatly appreciated

 

Things that worked well:

1) Compass "Learning".  I had some compass issues in 2.9.1b.  I didn't have those issues in 3.0.1

2) Upgrade process was well documented including the PPM upgrade.

 

Some problems I noticed after I upgraded:

1) Mission Planner no longer created rlog and tlog files.

2) Generated KMZ files had two issues: (1) Altitudes no longer seem to be referenced to ground.... the flight paths start and finish way up in the sky (viewing Google earth).   (2) Clicking on the KMZ file did not bring me immediately to the flight area, I had to click on the one of the flight paths.

3) Lost complete control of hexcopter.  It would not respond to any input from me.  It just kept going higher and higher and 'wandering' in the sky.  I think it may have gone into RTL or Auto mode and wouldn't come out. (not sure why) If it was in auto mode (I did have some preprogrammed waypoints in there, but they were set to be low to the ground), then it was waaaayyyy to high.  I did everything I could think of to get control of the hexcopter again (toggling switching, moving the throttle,.... no response).... then, suddenly, down...down...down... flipping and falling....  (I suspect it was stuck in auto and finally came out during the time I had cut the throttle to try to keep it from going to high.  I threw the throttle into high as it fell and it recovered about 2-3 feet off the ground [now... despite the tension I felt..., seeing it recover at 2-3 feet off the ground was downright cool!..... especially because it was falling at a very high speed and likely would have been completely destroyed).

4) Due to the fact that it was flying on its own at a very high altitude, and when I went into RTL mode it would just start gaining altitude, and the KMZ flighpaths are all way up in the sky....  Any ideas what might cause this?  I suspect a setting issue.  However, if I have a setting wrong that would affect RTL and Auto, I don't know why it would throw the KMZ files off for Stabilized flight.

5) I've never had trouble getting out of RTL & Auto mode before.  What would cause this?:  The only thing that changed was upgrading to 3.0

 

Below is a picture of one of my KMZ file screenshots.  The mountains in the background are nearly a mile higher than my takeoff area, but the KMZ file shows my flightpath way up there.

Any help would be greatly appreciated.  In the meantime, I have some rebuilding to do. 

 

Regarding a general suggestion regarding creating KMZ files... it would be nice to have a checkbox to eliminate 'transition modes'.  By that, I'm referring to the modes that the APM cycles through as it's getting to the selected mode.  ie.... if modes 1,2,3,4,5,6 are in order and you go from 1 to 4, the APM sometimes briefly hits modes 2 and 3.  This clutters the KMZ file.

 

Thank you for your help!

Dustin

Attachments:

In "APM 2.5", the 2.5 is referring to the hardware version.  What you see in mission planner is the ArduCopter version.  Previously, it was 2.9.1b.  Now, it is 3.0.1.  There's probably an easier way to do this, but if you connect to the mission planner and go into terminal mode, you can see what Arducopter version you have currently installed.  My personal thought would be to wait on the upgrade if you are flying okay.  Others may disagree with that and many are not having any problems.  I had major issues after the upgrade (see message below).

Alex O asked how to enable the motors in the dataflash.  Below is a screen shot of where in the mission planner you can do this.

Dustin,

     I can't help with #1 and #2, those are mission planner issues so we will need to get MichaelO to have a look at them.  I've ping'd him.

     The dataflash attached is only 18 seconds long and it doesn't look like the copter gets off the ground.  Did you create the kmz from another dataflash file?

     I suspect that it was a FENCE breach.  It looks like the Fence radius has been set to only 10meters and the altitude to 30m.  This is a tiny fence and so an RTL would be triggered very soon after you take-off.  Did you purposely set the fence to be so small?

     Once the fence was breached it would attempt to RTL and this is where you hit another problem.  The RTL_ALT is set to 100m.  I suspect this is because of a bug in the mission planner from a few weeks ago (now fixed) which would default this to 100m.  Which version of the mission planner are you using?

Normally you should be able to re-take control from the fence by changing the flight mode and I've demonstrated this in this video so if you can find the correct dataflash logs I'll have another look.

There's one thing we can fix in the code though which is to ensure that the RTL alt is never above the fence max alt.  I've added an issue here and we will sort it out for 3.0.2 or 3.1.0.

John,

     It's up to you as to whether you want to upgrade or not.  If you want to downgrade back to 2.9.1b later then before you upgrade you should first save your parameters using the mission planner's Adv Parameter List.  Only a few Loiter and Alt Hold parameters have really changed though (see image at the top)

To get 2.9.1b loaded back onto your APM you can go to the mission planner's Hardware, Install Firmware screen and then click on the "Pick previous firmware" link.  You should be able to pick any of the top few bizarro looking strings (those are GitHub hash tags in case you're wondering) and you'll see the version change back to ArduCopter V2.9.1b.

..and if you're wondering, "why do the top 5 hashtags all make AC-2.9.1b available?" the answer is that it has to do with us releasing ArduRover and ArduPlane independently.  As you flip down through the tags you should see that at least one frame's version changes.

Hi Randy, 

  Thank you for your reply.  Sorry, I attached the wrong logs.  I think that log was a check afterwards to see if everything worked and the hexcopter just flipped over and tried flying into the ground.  Attached are all the logs I got for the session.  I think it is log #2; however, I can't find the 200ft or so freefall, but that may be because all the altitudes are showing up wrong.

One strange thing I noticed is the altitude.  I don't know if its an issue with the KMZ file or if the issue was with a GPS reading, but Google Earth seems to think I was flying at 12000+ feet.  This should be about 6200 ft.

I had tried making a smaller fence hoping to keep the copter close to the ground while testing... ha... that plan didn't work out so well.  Incidentally, two nice features for fencing would be (1) a low altitude limit, and (2) the ability to 'bounce off the wall'.... that is, for multicopters, rather than always sending the copter back to the middle when a boundry is hit, just don't allow it to keep going... and if it's out of the boundry, let it loiter back to the last 'in boundry' location. 

What you said about fencing makes sense and it may have tried doing an RTL... however, while it was going up, it was going further away from home rather than straight up.  When an RTL goes up before going home, does it do this using a GPS loiter or is the at the mercy of any wind?

My biggest concern is that whether it was RTL or Auto or Fence related, I couldn't regain control.  This could be a real danger and worried me the most.

Thanks again for your assistance.  It is greatly appreciated.

Dustin

 

 

Attachments:

Randy,

Here are my alt_hold test logs; one with and one without the sonar but the results are the same.  The copter will drop when alt_hold is engaged. Sometimes it will stop on the way down and bounce back up and then sometimes it will go right down to the ground...

Attachments:

Thank you Randy. I am still using MP 1.2.53. My screen is not like that but I know how to find "Log_Bitmask" parameter. So I should be fine...

Alex,

    Great.  If you can't find it, you may need to do a Ctrl-F from the Flight Data screen and then push the "paramgen" button and finally restart the mission planner.

Andre,

     You were using an APM1 which has a worse barometer than an APM2.5 or PX4.

     Did you ever use 2.9.1b and get Alt Hold working or is this the first time you're using alt hold?  Sorry, I've seen a bunch of your posts, just forget where you're coming from.

     Your copter's vibration levels are very low which is normally a good thing but what kind of vibration dampening are you using?  Also how is your barometer set-up?  You of course have the little bit of foam on the baro right?

     Could you try increasing your AltHold P to 2.0?

     I see your flights are all at quite low altitudes.  If you're confident flying higher in stabilize mode could you go up a bit higher? 

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service