ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 385511

Reply to This

Replies to This Discussion

Hi Fressinet, you sent the wrong log. This tune still doesn't look like it is working as well as it should. How much does your "clean" section move?

Could you send me the correct log?

I am off to bed now but I will get back to you again tomorrow afternoon.

Hi all, I have updated the firmware to 3.1-rc5. But I am having issues with activating autotune in althold. Any advice would be greatly appreciated!

http://www.diydrones.com/forum/topics/unable-to-activate-autotune

I wanted to try autotune today but didnt get that far as my alt_hold would work.  As soon as switched into alt_hold my copter would rise about 1.5m and then float down again, then go up again and come down again.  I tried to lower throttle accel P but it made no difference.  I even went down as low as 0.2500 on the P.  I tried to lower Altitude Hold P as well but couldnt get it to work before my laptop died on me.

My question now is what would be the best way to tune alt_hold with ch6?  Should I start with "Altitude Hold kP", "Throttle Accel kP" or "Throttle Accel kI" first?  Is it safe to tune anyone of the accel values in flight and then landing to update the other value to reflect the I=2P formula?

Log files are attached...

Thanks,

Attachments:

Hi Andre,

What is your SONAR_GAIN. I was talking to Randy about a similar problem, try to lower it down to default 0.2, if it already is not. I will be testing this tomorrow anyhow!

Hi Shyam,

I see now that mine is 2.  I also noticed now that in the advanced parameters list the options for SONAR_GAIN is 0.01 and 0.5, so I wonder why the default is set to 2 then.  I will try it with your suggestion of 0.2... Thanks

Hi Leonard

Sorry I messed up with my log files here is the last one which is a new try in auto tune but did not work it does few twitches on the roll then stop.I try several times to enter auto tune but it either does few twitches then stop or do not start at all.

The clean section does not move that much ,if I take reference with the dirty section we are talking of few mm (2 to 4mm)even applying reasonable force, if necessary for the auto tuning procedure I could block the clean section ,just tell me if I should do that.

Attachments:
So I thought I had solved my wobble issue by replacing one motor.. I had three successful flights after that. After the third flight (bat wasn't even changed) the wobble suddenly came back.. It's random and sometimes appears in mid flight or at the start.. When testing without props it doesn't show up however today I decided to idle the motors and managed to take a video of the motors pulsing on the right side and it gets worse as the video goes on (see from 10secs onwards) .. It seems to be on the right side only.. I am not manipulating throttle.. And quad is in stablise mode..
Any suggestions?
http://www.youtube.com/watch?v=BWhIgwH7w7Y

@Andre:

I think RC5 defaulted sonar gain to 2 instead of default 0.2.

The forum post I raised has all details here:

http://diydrones.com/forum/topics/copter-jumping-up-down-constantly...

Could you confirm if this is a similar problem you too face? Probably, could give an extra hand in problem getting reproduced by others as well.

--

Thanks,

Shyam

Hi Shyam,

I will gladly test it for you.  I will try to tune my SONAR_GAIN with ch6 and see what results I get...

@ Andre,

Not regarding this problem, but curious, where did you read the I = 2P formula. What is the RATE_IMAX that you have set for yourself. Could you post me a link to that or something?

Hi Shyam,

Leonard has mentioned it on a few occasions:

http://diydrones.com/forum/topics/apm-copter-2-9-1-b-has-been-relea...

http://diydrones.com/forum/topics/arducopter-tuning-guide?commentId...

http://diydrones.com/forum/topics/arducopter-2-9-released?commentId...

I havent changed any of the default settings so my THR_RATE_IMAX is 300 according to my log file...

Thanks for the links, I am going through it. Much appreciated!

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service