ArduCopter 3.0 is ready for widespread use.  To make the transition easier, this time we are asking people to voluntarily upgrade from 2.9.1b for the next month or so before we make 3.0 the default firmware downloaded by the mission planner.  The new version can be found in the Mission Planner's Beta firmware's link,, GitHub and the new Downloads Area.

Warning #1: A bug was found in the FENCE in which if you lost GPS it could lean at extreme angles as it tried to maintain an invalid position.  This is fixed in AC3.0.1-rc1.

Warning #2: This release has not been fully tested on Traditional Helicopters

Warning #3: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the WPNAV_ACCEL to 100 and Loiter PID to 0.2 (from 1.0) to reduce aggressiveness.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer.

2. Click on the MissionPlanner's Firmware screen and click the "Beta Firmwares" link on the bottom right.  The version numbers should update to "ArduCopter-3.0.1rc2", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3dr frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. If you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware.

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Special Thanks to MarcoDaveC and the rest of the beta testers for putting their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.  

Added by Craig:

Please watch Randy's videos on setting up and flying APM-Copter 3.0 before you go flying.  They are excellent!

3DR Quad Set-Up Suggestions
AC 3.0 "Live" Compass Calibration
AC 3.0 CompassMot Setup      
AC 3.0 Pre-Arm Checks            
AC 3.0 Fence                               
AC 3.0 Maiden Flight Checks   

Views: 134217

Reply to This

Replies to This Discussion

Sean, are you using large propellers (14-15") ? If yes, Did you ever try a normal ESC firmware with version 3.0 ?


Hi Randy,

I started the mission planner today. I wanted to do some test hovering and vibration test. Mission planner warned me about an upgrade. I had just upgraded to 1.2.53 the other day. I clicked yes and it upgraded to 1.2.56

I got to see the upgraded graphics. But I cannot download any log in the Terminal Window now.

When I click on "Log download", I see strange characters on the screen and I get frequent error messages.

Is this a new issues? I didn't change anything recently...

Do I need to roll back to 1.2.53? I don't even know if there is an easy way to do it though...


Portion of the error message I get:

Error reading data System. Overflow Exception: Aritmetic operation resulted in an overflow at System. OI.Ports.SerialPort.ReadExisting(). 

etc. ect. it goes on and on

Hi Randy,

It's a brand new (never been used before) APM2.5 with the cover and pink foam in place. Any suggestions as to what could cause this, and how to fix it?


Hi all,

have the same issues in loiter, i'm running 40A rctimer opto Esc's with SimonK software

HP4108 580kv with 13 x 4 cfk props @ 5S

if there is any need for some testing i'm ready !

Palo, here is the picture. You'll need a SPI programmer.


Negative, the current frame is rather compact for a tri, with 240mm/9.5" booms-- I am using 9x4.7's on 980kv motors.  And no, I've never tried a stock ESC firmware on AC3.0. 

Hi Oliver,

thanks for answer. I bought SPI programmer, therefore i was little bit angry taht i can't find pictures on wiki guide. Do you have all pictures that have been on this wiki site? Because as i count correctly there were at least 2 pictures - one you have posted.

Does anybody know how to uninstall 1.2.56? Well actually how to go back to previous version 1.2.53?

I made a mistake by upgrading my mission planner to 1.2.56 

Now I am stuck... I cannot do anything. I can't even find a connect button. It is not there anymore. Terminal window is not functioning; full of strange looking characters. I did a system restore on my computer's operating system to yesterday hoping that it would take care of it but it didn't:(

Is there an easy way to go back to 1.2.53 from 1.2.56 without doing an uninstall and reinstall?

I don't want to do a complete uninstall then install a fresh Mission Planner because then I will lose all my PID tuning I guess...

Sorry i do not have the other ones my local copy is not up to date. Perhaps we have an archive somewhere. Perhaps you could ask to 3DR support or someone else here will come up with them.


PIDs are stored in flight controller not PC.  Connect button is top right, next to com port info.  Try rebooting your PC first. Or do a standalone install from -- this usually fixes any 'auto update' problems i had with MissionPlanner. 

Thanks Sean. Yeah it makes sense that PIDs are in the controller not on the PC.

Man, there is no connect button on the top right with this 1.2.56 I tried everything. There is no configuration tab. I fiddled with it for almost an hour and gave up.

I don't know why on earth I upgraded to something I didn't know. I just did and learned my lesson the hard way. It seems the only option for me is to do a complete uninstall and get rid of this 1.2.56 and then do a complete reinstall. The link you provided has 1.2.55. I thought I was at 1.2.53 but I might be wrong. I will go back to 1.2.55 and if it works, I will never bother with 1.2.56 ever again...

And yes I did reboot my pc 2 times. I just couldn't get rid of the strange behaviors. So annoying... 

I have an APM2 (NOT 2.5) and have wondered the same thing.  The GPS and Magnetometer are located on a small daughter board that is soldered to the main APM board.  It also has the SDcard on board.  The overview of the board is linked below.

The Barometer chip is below this board, and it's exposed to the wind, etc.  The only way to protect it is to put it in some kind of cover or case.

I've wondered if taking the board off would allow my to protect the Barometer chip better, move the GPS away from a lot of other signals, place a ground plane below it and now, with the heightened awareness of compass interference, to move the compass away from the rest of the systems too.

Mine appears to be soldered in 4 places (I suspect it should be 6, but two of the standoff pins are not soldered), and should be reasonably easy to remove.  I'd have to fab a cable to connect the two boards, but that should be reasonably simple, I'd think?

Assuming I have the skill to remove the board safely and create a cable to interconnect, would this represent a viable solution to moving the compass away from all the power wires?

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service