ArduCopter 3.0 is ready for widespread use.  To make the transition easier, this time we are asking people to voluntarily upgrade from 2.9.1b for the next month or so before we make 3.0 the default firmware downloaded by the mission planner.  The new version can be found in the Mission Planner's Beta firmware's link,, GitHub and the new Downloads Area.

Warning #1: A bug was found in the FENCE in which if you lost GPS it could lean at extreme angles as it tried to maintain an invalid position.  This is fixed in AC3.0.1-rc1.

Warning #2: This release has not been fully tested on Traditional Helicopters

Warning #3: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the WPNAV_ACCEL to 100 and Loiter PID to 0.2 (from 1.0) to reduce aggressiveness.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer.

2. Click on the MissionPlanner's Firmware screen and click the "Beta Firmwares" link on the bottom right.  The version numbers should update to "ArduCopter-3.0.1rc2", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3dr frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. If you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware.

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Special Thanks to MarcoDaveC and the rest of the beta testers for putting their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.  

Added by Craig:

Please watch Randy's videos on setting up and flying APM-Copter 3.0 before you go flying.  They are excellent!

3DR Quad Set-Up Suggestions
AC 3.0 "Live" Compass Calibration
AC 3.0 CompassMot Setup      
AC 3.0 Pre-Arm Checks            
AC 3.0 Fence                               
AC 3.0 Maiden Flight Checks   

Views: 134258

Reply to This

Replies to This Discussion

i'm using mp 1.2.59 and it's still impossible to connect via terminal to do the compassmot. I connect mains to APM and then connect via xbee to MP and then within 20 seconds I go to Terminal and press Connect APM. Then all i get is a string of garbage characters and i don't see the APM rebooting. I've tried many times. Is there any other way to connect to Terminal or do compassmot?

1.2.59 connects without issue to AC 2.9.1b or 3.0.1rc1

The characters you are seeing are heartbeat packets from the APM.

Try connecting over USB

Yes you are correct.

I prefer to use terminal via xbee to do the compassmot. I couple of versions back I could do it. I would go to Terminal and as long as it was within 20 seconds of APM boot then it automatically went to the client menu. I know the new way is to click the Connect APM button but that doesn't bring up the menu either. I just get the stream of random characters.

I set my JR921rx to RTL and trim down the throttle to 990. Then I set up MP failsafe to RTL. Hasn't failed me yet!

Hi Pablo,

We have discovered a yaw bug in the code. There will be a new release out very soon.

This bug is always associated with a mechanical problem but the code would normally hide it from you.

Sorry, this bug was my fault.

Got it.  I just reproduced that situation.  I understand what is going on.  We'll have to do some work to sort that out.  Thanks

Hey Steve, are you saying you set the Tx failsafe to RTL plus you have loss of telemetry failsafe set to RTL as well? 

Did I get it right?

Hi Randy, I'm pretty sure there are more FrSky receivers out there than Futaba. FrSky is well known to be an extremely reliable system. See all the RC Model Reviews videos praising FrSky, for example. I'm sure there are many other receiver brands in use that do not allow setting just the throttle channel on failsafe as well. You can't expect everyone to be using Futaba. Thus it would probably be a good idea to either fix this APM bug, or change the Wiki to make it very clear that users need to set a failsafe ch5 PWM corresponding to an auto mode, not STABILZE or ACRO. The current wording of the Wiki, saying "All other channels should remain at their last value or move to the middle" is not adequate, because the middle for ch5 could correspond to a STABILZE or ACRO mode.

Yes on the Tx failsafe to RTL and no I don't use "loss of telemetry" RTL. 

Then what do you mean by "Then I set up MP failsafe to RTL"?

What is MP failsafe?

Well Craig, I just read the entire wiki page Randy posted about the failsafe and I have a pretty good understanding of how the system functions. Now, I can say that I was partially correct when saying "Tx failsafe MUST be disabled"

Why? Because the failsafe initiation is still done through the Tx/Rx. When the signal is lost, Rx is made to output low PWM on the throttle which signals the APM to get into Failsafe state. But from here on, the decision is left to APM instead of sending the APM RTL flight mode signal.

Now, the way I set my failsafe through the radio is that I let the Rx to tell the APM to initiate RTL. In this state, APM doesn't actually know if the signal is lost. It might just think that the pilot entered into RTL flight mode. APM does not have any decision making power here. It just flies back to the launch site.

With the recommended throttle failsafe setting shown at the wiki page, the failsafe(due to signal loss) is still initiated by the Tx/Rx by setting the throttle PWM below the normal range. This is the signal for APM stating that something went wrong take over. Then APM does what is required.

I am pretty sure I got what I said above right.

If the Tx failsafe is disabled completely, the APM will not have any way of knowing the signal loss occurred. What actually surprizes me here is that WHY is APM not able to detect a radio failure on its own? Why does it have to told this with some failsafe settings?

I was thinking that if the signal is lost (Tx turned, copter is out of range etc.), then PPM encoder should output some flat values (considering no failsafe setting done through the radio) that should make APM aware of the loss of radio link. Why is it not possible?

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service