ArduCopter 3.0 is ready for widespread use.  To make the transition easier, this time we are asking people to voluntarily upgrade from 2.9.1b for the next month or so before we make 3.0 the default firmware downloaded by the mission planner.  The new version can be found in the Mission Planner's Beta firmware's link,, GitHub and the new Downloads Area.

Warning #1: A bug was found in the FENCE in which if you lost GPS it could lean at extreme angles as it tried to maintain an invalid position.  This is fixed in AC3.0.1-rc1.

Warning #2: This release has not been fully tested on Traditional Helicopters

Warning #3: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the WPNAV_ACCEL to 100 and Loiter PID to 0.2 (from 1.0) to reduce aggressiveness.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer.

2. Click on the MissionPlanner's Firmware screen and click the "Beta Firmwares" link on the bottom right.  The version numbers should update to "ArduCopter-3.0.1rc2", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3dr frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. If you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware.

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Special Thanks to MarcoDaveC and the rest of the beta testers for putting their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.  

Added by Craig:

Please watch Randy's videos on setting up and flying APM-Copter 3.0 before you go flying.  They are excellent!

3DR Quad Set-Up Suggestions
AC 3.0 "Live" Compass Calibration
AC 3.0 CompassMot Setup      
AC 3.0 Pre-Arm Checks            
AC 3.0 Fence                               
AC 3.0 Maiden Flight Checks   

Views: 134288

Reply to This

Replies to This Discussion

I'm confused by your post Jim (Cooper). 

Why the rubber grommets on the GPS?  I'm fairly certan that the GPS is not affected by vibration unless it's bad enough to physically damage it, which is more than we'd ever see on these copters.

Certainly isolating the APM from vibration is required, but the GPS module is another story.

Also, what would super simple mode have to do with the GPS locking?What am I missing here?


    Super simple mode is like simple mode except that it works even when the copter is behind you.  So for example if you hold the roll stick left the copter would fly a circle around you in a counter-clockwise direction (as long as it's at least 10m away from you).  This require a GPS to work though.

     I've never actually used super-simple mode myself but this is what I think it should do.

that's correct Randy. Ive tried it a few times. Just imagine its attitude always faces outwards from its take of point like lines radiating outwards from the take off point.  Where ever it is around you , front, left, right or behind you, if you pull the pitch leaver down it will fly in to the center back to its take of point

Hi Bill,

I ended up mounting the GPS on rubber grommets primarily to get it off the plate (I didn't have any standoffs handy) and figured the vibration absorption wouldn't hurt.  The super simple mode....I didn't know if maybe it hadn't been tested and may have been causing some weird control issues.  Not too many people use simple or super simple (I don't think) so eliminating some of the variables just seemed to make sense.  Hope I have addressed your confusion..  Thanks for the feedback.  Jim

Got it.  Thanks Jim.

I was certainly aware that GPS lock was needed for simple and super simple modes, but I couldn't see how switching to those modes would unlock the GPS.  I guess if there was a bug, it could cause issues with the GPS code in the APM as you mentioned.  Doesn't sound like this is an issue though.


I am quite sure it is not an issue - more likely either I did a bad compass calibration and/or vibration.  Seems to work ok now.  

I just updated to 3.0.1 and after update, I am not able to connect anymore to the APM and see my params.


I however can connect with terminal and see that 3.0.1 is loaded. I reverted back to 2.9.1b and seems to work...


Any clue what's happening here?

This is the old thread, next time could you post over here?  Basically though I think you should go to the terminal window, then type "setup", "reset", "Y" and then redo your config (sorry!) and it'll be ok.

I have one question:


If I've FS_GPS enabled, when I arm the copter (indoor, with no GPS fix) at the beginning the motors run and 0,1 sec later its stop. If I've FS_GPS disabled this doesn't occur.


This could be a bug? How can I fix this?


Thank you so much!


I have three AP;  one 2.0, another one 2.5 both are from 3DR  for my aeroplane and copters and one 2.5 from chine that I used to run some tests

Two month ago I burn the 3,3 regulator of the chine one I read the topic with the procedure to change it.

When I was in the investigation process to find a solution I think that somebody had written that if you installed de 3.0 release in a chine AP board you could burn the 3.3 regulator.

I have my test chine board again alive and I have installed 2.9.1 release and is working with no problem in a small test quad. , but I would like to installed the 3.0 or 3.1 firmware.

I would like to know if somebody else has read what I think I read please let me know if I am right or wrong

Can  I  update this board with 3.0 firmware?

I am looking forward to hearing from you guys any comments.


Thank in advance, Leopoldo

Did you end up with the s800?

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service