ArduCopter 3.0 is ready for widespread use.  To make the transition easier, this time we are asking people to voluntarily upgrade from 2.9.1b for the next month or so before we make 3.0 the default firmware downloaded by the mission planner.  The new version can be found in the Mission Planner's Beta firmware's link,, GitHub and the new Downloads Area.

Warning #1: A bug was found in the FENCE in which if you lost GPS it could lean at extreme angles as it tried to maintain an invalid position.  This is fixed in AC3.0.1-rc1.

Warning #2: This release has not been fully tested on Traditional Helicopters

Warning #3: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the WPNAV_ACCEL to 100 and Loiter PID to 0.2 (from 1.0) to reduce aggressiveness.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer.

2. Click on the MissionPlanner's Firmware screen and click the "Beta Firmwares" link on the bottom right.  The version numbers should update to "ArduCopter-3.0.1rc2", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3dr frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. If you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware.

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Special Thanks to MarcoDaveC and the rest of the beta testers for putting their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.  

Added by Craig:

Please watch Randy's videos on setting up and flying APM-Copter 3.0 before you go flying.  They are excellent!

3DR Quad Set-Up Suggestions
AC 3.0 "Live" Compass Calibration
AC 3.0 CompassMot Setup      
AC 3.0 Pre-Arm Checks            
AC 3.0 Fence                               
AC 3.0 Maiden Flight Checks   

Views: 134270

Reply to This

Replies to This Discussion

I am so impressed with 3.0.1 rc1  It just works!

Stable mode, loiter, RTL, auto all work perfectly!

I did struggle a bit getting it to arm the first time until I learned about the mandatory pre-flight calibrations, which is a good idea in hindsight.

I have one nagging issue that isn't 3.0 related.  I had this issue with 2.9.1 as well.  When in loiter, my altitude jumps around quite a bit.  Is this typically a vibration issue, or something with the barometric pressure sensor not being shielded well enough from prop wash?  What should I be looking at in my to help me determine the cause and what to be looking at?

Horizontal position holds unbelievably well.  I was just out flying 15-20 mph wind and in loiter mode, it stayed in about a 4' circle horizontally.  Almost unbelievable!  :-)

Thanks in advance and to the team for really AWESOME software!


-So is 1.2.59 perfectly fine? Does the terminal connect automatically as it was done in 1.2.55 and previous versions?

-Are characters readable on terminal window? At 1.2.56, I was unable to read the messages.

-Is the 1.2.59 screen layout low-resolution friendly? Meaning, will I be able to see the "Connect" button on top right corner? 1.2.56 didn't display it due to my low (1200x600) netbook resolution...


>>>-So is 1.2.59 perfectly fine?


>>>Does the terminal connect automatically as it was done in 1.2.55 and previous versions?

No, you have to select Connect APM.  The Connect button you are referring to is greyed out in Terminal and there are 2 new Buttons Connect APM and Connect PX4, plus a new disconnect button as well.

>>>-Is the 1.2.59 screen layout low-resolution friendly?


I'm using the cli right now using plane and 1.2.59 right now on APM 2.5

Try it.  You'll like it.  :)

Hi all,

For those having loiter wobble problems I would like to get feedback on what your rate pids are set to. If you have the time I would like you to try reducing your Rate Pid's and especially your Rate D terms.

If you could post the PID values for Roll and Pitch that you were seeding the wobble on and then what values you tired and what you saw.


Hi Leonard,

I had the loiter wobble problem with stock PIDs.  Olivier suggested to lower the STAB_P value.  I went down as far as 3.0 which made the wobbles less aggresive but still visible.  I then tuned RATE_P up to 2.5 which appears to have soften it a little bit more but the wobble is still visible.  I will lower RATE_D to 0.003 to see if it makes a difference...

Could you also try lowering your Rate P?

If I was doing this I would keep everything at my initial tuned values or default if that is what you had. Then I would reduce Rate P and I by as much as 50% (carefully), and then reduce Rate_D down to 0% (you would need to make sure the copter is stable with Rate_D set to zero). I would do this on the CH6 slider with the maximum set to my default value so I could push it back to default if things got hairy. Because I would use the Ch6 slider I would be in stationary loiter the whole time. But if you are changing the values using the mission planner you would need to do the, change value, take off, switch to loiter, not response, stabilize, land, change value.......... Or what ever you are comfortable with.

I am looking to see if we can make this problem completely disappear using rate tuning.

The other information that would be helpful is:

How far is the APM above the CG of the copter?

I really appreciate your help! I really would like to get to the bottom of this problem!!!

Would you like me to rather set all the PIDs back to their defaults values and only lower the RATE_D then or not?

The center point of where my arms cross to the center point of my APM is about 4cm...

I was fliying FPV (went pretty far and high) and i noticed that APM seemed to loose it's 'level'. I was in stable mode and when i let go of the sticks it leveled itself ~15 degrees to right side (from OSD i saw that in it's mind it was leveled then). As i flew this 'leveling' point seemed to drift, but when i decended and was ready to land it was OK. What kind of logs should i enable to trace the problem?

Could it be some sort of firmware bug where acc errors accumulate or similar?

I've had this sort of leveling problem once before when i plugged my battery in and stated to fly, but for some reason 'level' point was completly off. Then i had to trim it to place again.

APM 2.5 with ext compass and V3 RC6 soft.


terimakasih banyak

If you were getting good results in stabilize with the default settings it would be great if you could start from there.

I assume you are using simon K

As always be careful not to cause a crash as you change those parameters. Dropping Rate D while Rate P is high can easily cause oscillation so you probably need to drop Rate P first.

Thanks again Andre!!!!

Hi Leonard,

Whilst waiting for your response I went ahead and did two tests; one with my current PIDs and lowered RATE_D to 0.003 and one with the stock PIDs and lowered RATE_D.

The flight with the stock PIDs felts very loose however it still wobbled.  The flight with my tuned PIDs and lowered RATE_D was a bit better but also had the wobble.

PS: No I am not using SimonK ESCs...

Let me know if you need me to upload a short video of the wobble perhaps...



Thanks mate,

It would be great if you could do another test with IMU turned on. The logs I am looking at are




The video would also be great. I am sorry to inconvenience you but this is the only way I can approach this problem in the short term.


Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service