After months of testing AC3.1 is finally available in the Mission Planner and GitHub.

Warning #1: If the vehicle is left landed (but armed) while in AltHold or Loiter mode for more than a few seconds, the vehicle may suddenly jump into the air the moment the pilot raises the throttle above zero.  The reason is the baro altitude may fall while the vehicle is sitting on the ground.  In AC3.2 this bug is fixed because we reset the target before take-off.

Warning #2: Motors will spin (slowly) by default as soon as the copter is armed!  You can switch this feature off by setting the MOT_SPIN_ARMED parameter to zero.

Warning #3: if you see "Bad Gyro" on the HUD then you may have a blown 3.3V regulator.  See this thread for details.

Warning #4: if you use a sonar set the SONAR_GAIN parameter to 0.8 or lower

Warning #5: Trad Heli users should now connect their main rotor ESC to APM's RC8 output

Warning #6: Trad Heli BUG causes loss of collective control in ACRO mode if swash type set to flybarred (i.e. not flybarless).  Will be fixed in AC3.2.

 

The major improvements over AC3.0.1 are (full list here):

1. Pixhawk support (Tridge & PX4 development team)

2. Autotune of Roll and Pitch gains (Leonard/Randy)

3. Drift mode (Jason)

4. Improved Acro (Rob/Leonard) and new Sport mode (Leonard)

5. Arming, Take-off, Land in Loiter or AltHold

6. TradHeli improvements (Rob) including:

a) support for direct drive tail rotors

b) smoother ramp-up of main rotor

c) reduced collective for better control in stabilize mode (STAB_COL_MIN, STAB_COL_MAX params)

7. Support for SingleCopter (Bill King)

8. Performance improvements resolve AltHold troubles for Hexa & Octacopters

9. Safety Improvements:

a) GPS Glitch detection (Randy)

b) Motors spin when armed (Jonathan Challinger)

c) crash detector shuts off motors if copter flipped for 2secs

d) batt failsafe option to RTL instead of LAND, gps failsafe option to trigger AltHold instead of Land

e) more pre-arm checks of inertial nav speed,

10. Bug fixes:

a) optical flow working again (although performance is still not great because not integrated with inertial navigation)

b) ROI working (use DO_SET_ROI command)

 

How to upgrade:
Click on the MissionPlanner's Initial Setup >> Install Firmware screen.  The version numbers should appear as "ArduCopter-3.1", then click the appropriate frame icon and it should upgrade as per usual.

Special thanks to Marco and the many beta testers on the AC3.0.1 thread who put their copters at risk during the testing of this new version and uncovered many problems so that you don't have to!  Here are some of their videos: loiter in wind, patio sonar, autotune, autotune2, roi, beach, acro, vrbrain, tricopter, train spotting, radio failsafe, the tree, double loiter

 

If you haven't seen it recently, please check out the ArduCopter wiki.

 

Feel free to post comments below and we're going to use the new APM Forum for support issues so please post your support requests there.

Views: 151340

Reply to This

Replies to This Discussion

Thanks Randy - I'm going to try it, I just wanted to make sure it's safe to use and wont cause any erratic behavior.

Answered (sort-of) on the APM Forum.

Thank you guys. 3.1 is a real treat to fly :-) Did my first flight in drift mode and it was great fun! Always though that althold was my favourite but this just takes the cake. Excellent stuff!

Do I understand ROI correctly?

1. Must be set after at least one normal waypoint is entered.

2. Persists only until the next waypoint is reached and then is reset.

3. The ROI command in the WP type drop list in Mission Planner should NOT be used...use the Set ROI feature of the map....

Henry,

     Yes, that all looks correct.  using the set ROI feature on the map seems to add a DO_SET_ROI command to the mission which is what we want.

     I see your point about more documentation on the mission commands.  Perhaps like the flight modes we need a page for each command.  Some pages may be short but a more in-depth explanation for each is probably warranted.

I was using v1.8.1 but I downgraded back to v1.7.

If I load v3.1 final I get an unreliable connection or none at all, if I load v3.1rc8 everything works fine.

Sorry that i ask at this place But i registered at the apm forum a  few days ago but cant login already. how can i contact a board admin without login.

@Marco, in your Tx switch config, you have six flight modes configured on two position switches, but then you said you also configured "simple flight mode" on a third switch? How do you configure this 3rd switch to trigger simple mode? (And thus override the currently selected mode?)

Easy, because in this way i can select to enable or disable "Simple/SuperSimple" with all the six flight mode.

I have a question:

What exactly does Load IRIS Defaults  do at AC3.1 ? Only changes RC Setting (Flight Modes) or does it change sth else ?

Is it recommended to use the defaults at older PIXHAWK hardware revisions (<2.4 ) as well ?

Loiter works great,btw.

http://www.youtube.com/watch?v=5swR527ODhs&feature=youtu.be

Guys please ask questions in the new forums. They work well and will make information easier to find for folks.

This thread really is to serve as an announcement of 3.1 only.

Once again this is the link http://ardupilot.com/forum/viewforum.php?f=25

Take a look in CH7 & CH8 options, there you can configure simple & super simple ;-)

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service