After months of testing AC3.1 is finally available in the Mission Planner and GitHub.

Warning #1: If the vehicle is left landed (but armed) while in AltHold or Loiter mode for more than a few seconds, the vehicle may suddenly jump into the air the moment the pilot raises the throttle above zero.  The reason is the baro altitude may fall while the vehicle is sitting on the ground.  In AC3.2 this bug is fixed because we reset the target before take-off.

Warning #2: Motors will spin (slowly) by default as soon as the copter is armed!  You can switch this feature off by setting the MOT_SPIN_ARMED parameter to zero.

Warning #3: if you see "Bad Gyro" on the HUD then you may have a blown 3.3V regulator.  See this thread for details.

Warning #4: if you use a sonar set the SONAR_GAIN parameter to 0.8 or lower

Warning #5: Trad Heli users should now connect their main rotor ESC to APM's RC8 output

Warning #6: Trad Heli BUG causes loss of collective control in ACRO mode if swash type set to flybarred (i.e. not flybarless).  Will be fixed in AC3.2.

 

The major improvements over AC3.0.1 are (full list here):

1. Pixhawk support (Tridge & PX4 development team)

2. Autotune of Roll and Pitch gains (Leonard/Randy)

3. Drift mode (Jason)

4. Improved Acro (Rob/Leonard) and new Sport mode (Leonard)

5. Arming, Take-off, Land in Loiter or AltHold

6. TradHeli improvements (Rob) including:

a) support for direct drive tail rotors

b) smoother ramp-up of main rotor

c) reduced collective for better control in stabilize mode (STAB_COL_MIN, STAB_COL_MAX params)

7. Support for SingleCopter (Bill King)

8. Performance improvements resolve AltHold troubles for Hexa & Octacopters

9. Safety Improvements:

a) GPS Glitch detection (Randy)

b) Motors spin when armed (Jonathan Challinger)

c) crash detector shuts off motors if copter flipped for 2secs

d) batt failsafe option to RTL instead of LAND, gps failsafe option to trigger AltHold instead of Land

e) more pre-arm checks of inertial nav speed,

10. Bug fixes:

a) optical flow working again (although performance is still not great because not integrated with inertial navigation)

b) ROI working (use DO_SET_ROI command)

 

How to upgrade:
Click on the MissionPlanner's Initial Setup >> Install Firmware screen.  The version numbers should appear as "ArduCopter-3.1", then click the appropriate frame icon and it should upgrade as per usual.

Special thanks to Marco and the many beta testers on the AC3.0.1 thread who put their copters at risk during the testing of this new version and uncovered many problems so that you don't have to!  Here are some of their videos: loiter in wind, patio sonar, autotune, autotune2, roi, beach, acro, vrbrain, tricopter, train spotting, radio failsafe, the tree, double loiter

 

If you haven't seen it recently, please check out the ArduCopter wiki.

 

Feel free to post comments below and we're going to use the new APM Forum for support issues so please post your support requests there.

Views: 151240

Reply to This

Replies to This Discussion

I had a very bad crash this weekend and this is just after I uploaded the latest firmware onto my APM 2.5. I lost my Hex and my go pro and my brushless gimball because of some fault. If someone one can tell me what happened I, it would be much appreciated. Find attached my log file. You will see that the last image I attached the log signal disappears where the hex starts falling out of the air, this happened twice. The first time it was quick and the second time it was for too long. You will see on the first time I cam home to land and I could not see anything wrong but the second time it was too long I could not recover.

Attachments:

HI Guys

When the copter is being controlled by the autopilot ( loiter and auto) and flying in windy conditions,I am seeing large slow oscillations in the axis facing in the the wind (IN the direction of effective forward flight)

This behaviour is not present when the copter is manually controlled.

This points me in the direction loiter overshoot and Loiter PID controls.

Maybe NAV acceleation is too much?

OR loiter D term needs to be increased to slow the whole process down?

Flying asymmetrical quad with 15" props and big battery and pixhawk

Any Ideas?

Thanks

Hi there .. it appears as you power supply is the issue .. its very "dirty" and it drops below recommended values .....how are you powering your APM?

I powering my apm with a new power module and new capacitor 16v 3300 µF (before I used

BEC)

I see what looks to be like your RX failing (brown out) as you have an RTL right at the start of your flight and another failure near the end .. I suspect your issues are from the supply voltage being too low. it should be above 5 volts but you are well below ..or at least a bad connection . I see Gps failed but this was perhaps when you were upside down after the crash ..are you powering anything else besides the APM?

Yes the gps failure was after crash (broken the connection) and I powering just apm and RX nothing else

Hi Graham,

I had the same problem with wind and I resolved it after an Autotune sesion. . Most PIDs were increased.

Please, find here-attached two images of my config before and after Autotune.

BEFORE:

AFTER:

Now it works much better facing to wind in Auto modes.

Hope this helps

This is the log of the flight before crash, same low voltage....

Attachments:

Again I see an RTL did you envoke that one ? I also see a Battery low failsafe between 5mins and 6mins .. It still seems as you have power supply issues .. ..

Yes sometime i try RTL and other mode, normaly i fly in stabilize.
I have another power module and it's 5V This one have a problem...

Thanks

I use a 3DR power module. This is the first time this happened.

Thanks very much, Ill give it a go :)

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service