After months of testing AC3.1 is finally available in the Mission Planner and GitHub.

Warning #1: If the vehicle is left landed (but armed) while in AltHold or Loiter mode for more than a few seconds, the vehicle may suddenly jump into the air the moment the pilot raises the throttle above zero.  The reason is the baro altitude may fall while the vehicle is sitting on the ground.  In AC3.2 this bug is fixed because we reset the target before take-off.

Warning #2: Motors will spin (slowly) by default as soon as the copter is armed!  You can switch this feature off by setting the MOT_SPIN_ARMED parameter to zero.

Warning #3: if you see "Bad Gyro" on the HUD then you may have a blown 3.3V regulator.  See this thread for details.

Warning #4: if you use a sonar set the SONAR_GAIN parameter to 0.8 or lower

Warning #5: Trad Heli users should now connect their main rotor ESC to APM's RC8 output

Warning #6: Trad Heli BUG causes loss of collective control in ACRO mode if swash type set to flybarred (i.e. not flybarless).  Will be fixed in AC3.2.

 

The major improvements over AC3.0.1 are (full list here):

1. Pixhawk support (Tridge & PX4 development team)

2. Autotune of Roll and Pitch gains (Leonard/Randy)

3. Drift mode (Jason)

4. Improved Acro (Rob/Leonard) and new Sport mode (Leonard)

5. Arming, Take-off, Land in Loiter or AltHold

6. TradHeli improvements (Rob) including:

a) support for direct drive tail rotors

b) smoother ramp-up of main rotor

c) reduced collective for better control in stabilize mode (STAB_COL_MIN, STAB_COL_MAX params)

7. Support for SingleCopter (Bill King)

8. Performance improvements resolve AltHold troubles for Hexa & Octacopters

9. Safety Improvements:

a) GPS Glitch detection (Randy)

b) Motors spin when armed (Jonathan Challinger)

c) crash detector shuts off motors if copter flipped for 2secs

d) batt failsafe option to RTL instead of LAND, gps failsafe option to trigger AltHold instead of Land

e) more pre-arm checks of inertial nav speed,

10. Bug fixes:

a) optical flow working again (although performance is still not great because not integrated with inertial navigation)

b) ROI working (use DO_SET_ROI command)

 

How to upgrade:
Click on the MissionPlanner's Initial Setup >> Install Firmware screen.  The version numbers should appear as "ArduCopter-3.1", then click the appropriate frame icon and it should upgrade as per usual.

Special thanks to Marco and the many beta testers on the AC3.0.1 thread who put their copters at risk during the testing of this new version and uncovered many problems so that you don't have to!  Here are some of their videos: loiter in wind, patio sonar, autotune, autotune2, roi, beach, acro, vrbrain, tricopter, train spotting, radio failsafe, the tree, double loiter

 

If you haven't seen it recently, please check out the ArduCopter wiki.

 

Feel free to post comments below and we're going to use the new APM Forum for support issues so please post your support requests there.

Views: 151286

Reply to This

Replies to This Discussion

Yes i have the ground connected to ESC signal wire of afro slim ESC. did not try motorsync, is it a new feature in mission planner?

Ok, but without a log file there's no reason to jump to the conclusion that it's the firmware.  Better to provide a log and find the real cause and the go after that.

The change log is linked above.  See ReleaseNotes.txt.

Ravi,

     If you move to AC3.2 you'll find there's a MotorTest option available in the mission planner's Config/Tuning > OptionalHardware section.  It's new so it doesn't have much documentation but you'll see a number of buttons corresponding to each motor (in clockwise order around the frame) and a field with a single number in it (i think it's "5" or "13").  That number controls the throttle percentage output.  So set it to 50 and push a motor button and that motor will spin at 50% for about 3 seconds.  Becareful!

Hi Randy,

Had a weird crash after upgrading to 3.1.4.. maybe someone can give some insight.

Been flying this quad for a few months without issue, recently upgraded to 3.1.4 and today had a crash. A couple broken plastic legs but otherwise no issues. hopefully one of you guys can point me in the right direction. It looks like possibly a mechanical failure, but i've tested the components and they work well on the bench... could it be a sync issue?


Specs:
-Pixhawk running arducopter 3.1.4. 
-GPS with external mag
-3DR 850kv motors, 10" props
-20amp AfroESC's (simonk etc) with ground from ESC's going to pixhawk.
-Frame= "Xugong"

Issues began when I switched to loiter. It's hard to tell in the video (gimbal), but it's clear in the logs; after I switch to loiter there are some erratic maneuvers, then it seems to be ok... I start to yaw while in loiter and it falls to the ground.

Flew 5 batteries earlier in the day without problem (and at least 25-30 before upgrading to 3.1.4), using loiter without issue. Only difference when the crash occurred is the wind was blowing a bit harder.

Attached logs and here's a vid:


Any help would be greatly appreciated - thank you in advanced!

log attached

Attachments:

Raph,

sorry about your crash, I had a look at your logfile. It seems like motor 2 lost sync.

RC inputs Ok, Vibrations OK, Baro OK, Compass OK though you still have Autodec enabled..

Bat Volt OK, Vcc OK, Bat Current got high due to wind or is indicator for lost sync.

(I had situation in past where a motor out of sync was burnig down the ESC with high current)

Hope Randy can check/confirm.

Regards Christian

Christian, Thank you for taking the time and looking at this for me.

Today I tried first replacing the ESC for motor #2; when I armed the copter, #2 motor twiched for a sec then went on. I tried to hover but the copter leaned back hard, so I countered slightly and tried to land.. it started to drift, so I countered more then the copter flipped to the ground.

Now i replace #2 motor. Tried another flight and same exact behavior; copter wants to drift backwards, I counter.. any hard movement causes the quad to flip.

I calibrated the accel both times; on level ground the HUD shows level. Also tried AC 3.2rc2 and same behavior. I'm really stumped :(. attached logs. I can say that motor #2 felt warmer than the rest (both the old & brand new motor). what could be going on here?

Attachments:

Raph,

After updating to 3.1.5 I noticed a similar behaviour. The copter tilts to one direction and I hardly had to push the sticks against that. So after checking full parameter list, I found that during update the AHRS_trim went to 0.1745 and -0.1745(max. values). I set it back to my saved values and it was fine. Your params are still ok.

Reasons for mot#2 could be:

center of gravity not in middle,

propeller bad thrust or things below in airflow,

(bad connection to motor(to high impedance in connector),)

you use BEC 5V from this ESC and push the 7805 to limit(warms up hole ESC and get temp. drift),

ESC general failure or out of sync with motor,

ground not connected in signal wire #2 to ESC?,

in case of sync problem use other ESCs/Motor combination or for testing that you can set

RC_SPEED to 100.

btw pls change COMPASS_AUTODEC to 0(off)

Hi Randy,

pls excuse me for posting here a little offtopic, but since the thread of the blown 3.3V regulator is closed, I want to ask here:

Is it recommended to solder in the capacitor like in the video from proficnc that you referred to?

In addition, should one go for a new regulator with more amps?

I havn't had an issue up to now but want to reduce possible problems when I am going to add a gimbal to the copter (board drives two more servos then).

Regards

John

Capacitor won't hurt. The main thing they proved is that hot plugging/unpluging external devices is the main cause.

As long as you do not have the hot plugging habit and have that capacitor (just in case) you should be fine.

A lot of people were against using higher amp regulators. 

Also if your board is original 3DR, you have better chances than that of clone board owners (based on statistics).

Hi all.

After hours of smooth flying with my APM 2.5 I started trusting in it when suddenly I observed this strange behavior of my tricopter. It was flying in circle mode, then did two loops and lost approx. 20m height while doing that. Here is the video:

loop drop (the copter loops at 10".)

That's no acro, it was in an assisted mode (circle) where loops were not possible. Also I did not flick a switch or touched a stick.

Luckily the copter was high enough for that stunt ;-))

I've attached the shortened log file. The drop occured between 13:23:41 and 13:23:47 (GPS time) and the log is from 13:23 to 13:24, with the parameters at the beginning of the file.

FW was 3.1.2 at that date. The loops were the cause for me to upgrade to 3.1.5. Will that help?

Can anybody help me please to regain the trust in my APM? Would want to do aerial photography with it again...

Attachments:

As you can read 3.1.2 has an critical bug (#1) which costs me many hours of analysis and hundreds of euros. But I am no expert. The motor out is missing in your logs.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service