After months of testing AC3.1 is finally available in the Mission Planner and GitHub.

Warning #1: If the vehicle is left landed (but armed) while in AltHold or Loiter mode for more than a few seconds, the vehicle may suddenly jump into the air the moment the pilot raises the throttle above zero.  The reason is the baro altitude may fall while the vehicle is sitting on the ground.  In AC3.2 this bug is fixed because we reset the target before take-off.

Warning #2: Motors will spin (slowly) by default as soon as the copter is armed!  You can switch this feature off by setting the MOT_SPIN_ARMED parameter to zero.

Warning #3: if you see "Bad Gyro" on the HUD then you may have a blown 3.3V regulator.  See this thread for details.

Warning #4: if you use a sonar set the SONAR_GAIN parameter to 0.8 or lower

Warning #5: Trad Heli users should now connect their main rotor ESC to APM's RC8 output

Warning #6: Trad Heli BUG causes loss of collective control in ACRO mode if swash type set to flybarred (i.e. not flybarless).  Will be fixed in AC3.2.

 

The major improvements over AC3.0.1 are (full list here):

1. Pixhawk support (Tridge & PX4 development team)

2. Autotune of Roll and Pitch gains (Leonard/Randy)

3. Drift mode (Jason)

4. Improved Acro (Rob/Leonard) and new Sport mode (Leonard)

5. Arming, Take-off, Land in Loiter or AltHold

6. TradHeli improvements (Rob) including:

a) support for direct drive tail rotors

b) smoother ramp-up of main rotor

c) reduced collective for better control in stabilize mode (STAB_COL_MIN, STAB_COL_MAX params)

7. Support for SingleCopter (Bill King)

8. Performance improvements resolve AltHold troubles for Hexa & Octacopters

9. Safety Improvements:

a) GPS Glitch detection (Randy)

b) Motors spin when armed (Jonathan Challinger)

c) crash detector shuts off motors if copter flipped for 2secs

d) batt failsafe option to RTL instead of LAND, gps failsafe option to trigger AltHold instead of Land

e) more pre-arm checks of inertial nav speed,

10. Bug fixes:

a) optical flow working again (although performance is still not great because not integrated with inertial navigation)

b) ROI working (use DO_SET_ROI command)

 

How to upgrade:
Click on the MissionPlanner's Initial Setup >> Install Firmware screen.  The version numbers should appear as "ArduCopter-3.1", then click the appropriate frame icon and it should upgrade as per usual.

Special thanks to Marco and the many beta testers on the AC3.0.1 thread who put their copters at risk during the testing of this new version and uncovered many problems so that you don't have to!  Here are some of their videos: loiter in wind, patio sonar, autotune, autotune2, roi, beach, acro, vrbrain, tricopter, train spotting, radio failsafe, the tree, double loiter

 

If you haven't seen it recently, please check out the ArduCopter wiki.

 

Feel free to post comments below and we're going to use the new APM Forum for support issues so please post your support requests there.

Views: 151357

Reply to This

Replies to This Discussion

As we're grasping at straws, have you tried flying without the angry bird on the front? Could it be diverting air from the barometer in such a way that it "thinks" it's holding altitude even though it's sinking.

Would explain the logs showing a good flight when it's not and why it works going backwards not forwards.

@MarkM thats a good theory which i will try but it doesnt explain the X650 which have full Covers over them. we'll give it a go tho! thanks

Hi all,

I have an unexpected problem with my new quadrocopter with the pixhawk and AC 3.1.5.

If I switch to the ALThold mode during the flight the copter became a rocket. It climbes on the full trottle until I switch it back to stabilaze mode. I cant find the problem in logs or settings. Could anyone help?? The same setup with an APM worked great before.

In the logs you could see that the DAlt after switch to ALThold mode seems OK, but motor out is 100% and baro altitude rise correctly:

What could couse the problem? 

Regards,

Petr

Attached logs:

Attachments:

Well this is certainly not good news for DRONE fliers, http://gizmodo.com/drones-are-now-banned-in-every-national-park-in-... Drones Are Now Banned in Every National Park In America

This is a similar story on ABC News which states they may be over reaching their authority sice now laws are in place to prevent Drones flying in parks http://abcnews.go.com/Politics/wireStory/govt-moves-ban-drones-400-...

Can anyone shed any light on why with version 3.1.5 loiter won't hold an altitude without me moving the throttle to eventually find a sweet spot?

I was out flying our octaquad yesterday on a job, stabilize is nice and smooth, RTL is great, but loiter is another story, very active and can't hold an altitude.

These are the PID settings...

I have also attached three logs, one full log (all parameters including yesterday's mission) and one just for yesterday's mission with no parameters and the Tlog, the octaquad gets airborne at about 41% in this file.

Attachments:

You never commanded a constant altitude... did you leave your stick in the middle? Try calibrating the radio again


Menno

Yes I did leave the stick centred when selecting loiter, but the octaquad just kept climbing, so I naturally lowered the throttle to try and stop it. Radio was calibrated that morning before the flight.

Any clues as to why it is so fidgety? I have tried changing the loiter P settings, but haven't had much luck at stabilizing it.

That 'sweet spot' you've mentioned... did you find a stick position that corresponded to holding altitude? 
If so, how much deflection was it from centered position?

Btw do not change the gains, they cannot solve the problem because the problem is already existing at your input... and altitude followed the reference very well I think.

The throttle had to be just below centre to stop it climbing and then it would very slowly descend. The throttle setting for stabilized hover seems to be determined as 440 when looking at the parameters. However the Trim Throttle is set at 530, despite me originally setting it at 440.

The fidgeting I am referring to is the excessive roll and pitch that it seems to command when in loiter. In stabilized mode or RTL it is very smooth, but rolls and pitches significantly when in loiter, as if it is too sensitive.

I don't have experience with Loiter and it's associated gains, sorry.

Trim Throttle will be changed by the controller during the code, that's why it has changed. Leave it at 590 ;-).


You can set thr_mid to 590 as well to ensure a smooth transition between stabilize and AltHold, i.e. your hovering position in stabilize will be approx centered stick position and you will not have to change the stick position when you switch to AltHold

Thanks for the help Menno, much appreciated :)

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service