After months of testing AC3.1 is finally available in the Mission Planner and GitHub.

Warning #1: If the vehicle is left landed (but armed) while in AltHold or Loiter mode for more than a few seconds, the vehicle may suddenly jump into the air the moment the pilot raises the throttle above zero.  The reason is the baro altitude may fall while the vehicle is sitting on the ground.  In AC3.2 this bug is fixed because we reset the target before take-off.

Warning #2: Motors will spin (slowly) by default as soon as the copter is armed!  You can switch this feature off by setting the MOT_SPIN_ARMED parameter to zero.

Warning #3: if you see "Bad Gyro" on the HUD then you may have a blown 3.3V regulator.  See this thread for details.

Warning #4: if you use a sonar set the SONAR_GAIN parameter to 0.8 or lower

Warning #5: Trad Heli users should now connect their main rotor ESC to APM's RC8 output

Warning #6: Trad Heli BUG causes loss of collective control in ACRO mode if swash type set to flybarred (i.e. not flybarless).  Will be fixed in AC3.2.

 

The major improvements over AC3.0.1 are (full list here):

1. Pixhawk support (Tridge & PX4 development team)

2. Autotune of Roll and Pitch gains (Leonard/Randy)

3. Drift mode (Jason)

4. Improved Acro (Rob/Leonard) and new Sport mode (Leonard)

5. Arming, Take-off, Land in Loiter or AltHold

6. TradHeli improvements (Rob) including:

a) support for direct drive tail rotors

b) smoother ramp-up of main rotor

c) reduced collective for better control in stabilize mode (STAB_COL_MIN, STAB_COL_MAX params)

7. Support for SingleCopter (Bill King)

8. Performance improvements resolve AltHold troubles for Hexa & Octacopters

9. Safety Improvements:

a) GPS Glitch detection (Randy)

b) Motors spin when armed (Jonathan Challinger)

c) crash detector shuts off motors if copter flipped for 2secs

d) batt failsafe option to RTL instead of LAND, gps failsafe option to trigger AltHold instead of Land

e) more pre-arm checks of inertial nav speed,

10. Bug fixes:

a) optical flow working again (although performance is still not great because not integrated with inertial navigation)

b) ROI working (use DO_SET_ROI command)

 

How to upgrade:
Click on the MissionPlanner's Initial Setup >> Install Firmware screen.  The version numbers should appear as "ArduCopter-3.1", then click the appropriate frame icon and it should upgrade as per usual.

Special thanks to Marco and the many beta testers on the AC3.0.1 thread who put their copters at risk during the testing of this new version and uncovered many problems so that you don't have to!  Here are some of their videos: loiter in wind, patio sonar, autotune, autotune2, roi, beach, acro, vrbrain, tricopter, train spotting, radio failsafe, the tree, double loiter

 

If you haven't seen it recently, please check out the ArduCopter wiki.

 

Feel free to post comments below and we're going to use the new APM Forum for support issues so please post your support requests there.

Views: 151348

Reply to This

Replies to This Discussion

Hi Randy 

Just an Update .. My pixhawk still does not calibrate the internal compass..

here are some photos of my Spraying copter with interchangeable spray booms and solenoid to switch between different jets..

Reuben

Try Loiter P=0.2 and you will have a lock-in loiter. Enjoy

I'll try it thanks Willy.

Which loiter P value Willy, the red one or the yellow one? See attached picture.

Attachments:

The one with yellow circle. It should give you a nice solid Loiter. P=1 is just too aggressive although that's the default value.

Thanks Willy

This video will demonstrate exactly whats going on while flying my F450 as far as ALT HOLD problems. you could watch the first minute to see it all. in the lower left corner is the BARALT, WPALT and the RELALT. I thought chaning the Props from 11" to 10" might solve teh problem but to no avail. the ONLY ting all three of my quads have i common, other than APM 2.6, is that they all have the same Radios, Turnigy 9XR with Open TX. i am beginningn to wonder if that is the problem, that some dead band issue is occurring? maybe thats a stretch. in the VIDEO, the Quad flew straight and narrow in Stabilize mode with out descending, IN ALT_HOLD, the drop is HUGE.

attached is my log, here  is the video: https://www.youtube.com/watch?v=mvJpCdirxBU 

remember when looking at the LOG i did change my Props from 11" to 10 inch and didnt adjust my THR_MID, i just forgot to do that.

Attachments:

Thor,

     This looks like the classic, aerodynamic issue in which the vehicle drops 1m after flattening out after flying forward at high speed.  The best way that we know of to deal with this issue is to reduce the airflow over the flight controller.  Perhaps put it in an enclosure.

Randy i sincerely appreciate your time. i will look into a hood on this vehicle.! funny it doesnt drop during Stabilize flight but i guess there is more involved with ALT HOLD than STABILIZE. the video pretty much follows the Value Graph in said video.

That's because the drop is not due to aerodynamic forces pushing the quad's body. But due to a 'disfigured' barometer reading. Since you don't use your barometer in stabilize mode (attitude is not controlled in stabilize mode) it will not be a problem there. 
Or didn't I understand, Randy?

hi,

thats venturi effect. air passes through the case of your FC and sucks on your baro sensor.

--> less pressure --> FC thinks copter is lifting up in height --> reducing altitude to compensate--> altitude drop

that only happens in baro assisted fligth modes

Thanks for eveyones Help, i have had SUCCESS!! By increasing the Throttle P/I on my X650, the craft flies great in ALT_HOLD. the F450 needs a Cover or canopy or something but by boosting Throttle during Forward Flight slightly and it pulls up nicely.

thanks again for all your help! 

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service