Developer

ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • FYI.... WAAAAAAyyyyyy back in this thread somewhere I posted a problem about and issue were after going to 3.3 from 3.2 my teesny and lue script for my taranis telemetry was broken. It worked fine until I fired up a GCS station the instant I did that and connected the Taranis telem acted weird... useless. I FINALLY figure out it was because I needed to snip the red wire [ and I didn't blow up yea!!] which was the TX from the teensy RX on the tellem 2 on the pixhawk. Now it seems to work fine. If anybody knows why that is I would sure like to know! 

  • Can someone please tell me how to skip just the gyro calibration pre-arm check? If I set pre arm check to '0' that disables all of them [ compass etc ] but all I want to do is skip just the gyro. I need to do this to arm on a moving boat until 'boat mode' gets the green light in 3.4. I hope...  

    • https://github.com/diydrones/ardupilot/blob/ArduCopter-3.2.1/ArduCo...

       ARMING_CHECK_INS = 0x10

      Although note this skips all the INS checks including accelerometers.

      Also note that in 3.3 these checks were specifically strengthened to fail pre-arm checks if the FC is moving over a certain threshold when arming such as on a choppy boat, as if this is allowed then as I understand it the FC can't then keep attitude control.  In other words, bypassing this is a Very Bad Idea :)

      • Thanks. Yea I agree probably not a good idea. Guess I'll wait for a better solution in 3.4

  • Having issue getting MP to georeferenced my images using the post processing tool  (Ctrl-F).

     

    If i tell it to use the CAM messages it errors out and just says aborting.  I had MP take the pics are preset distance intervals during the mission.  Pictures are fine.

    If I tell it to use a time offset and the do the estimate Offset command then it runs fine and tells me the offset is 1179.592  

    I then add this value to the Seconds offset. I hit the Pre-Process and below shows me the pic are found and at what ms away value.  I then click on Location KML and in Google earth it appears all photos are right over the Home/start position?

    I then click on GeoTag and it sits and processes as it should. When I look at the Geo data inside each picture they are all the same.  Looks like it has assigned the location or either Home or the ground station for each picture time.

    What am I missing?  Again I had MP trigger the camera during the mission.

     

    Bill Neuhauser

     

     

     

    • I'm still encountering a similar issue with the Geo Reg Images utility in MP-1.3.32. Pre-process appears to only work for me when 'Use AMSL Alt' is unselected. If this is selected, the utility prints the error "Log file problem. Aborting". I'm still using AC3.2_RC10, and wondering whether there's been a change in the position (log offset) of the AMSL value in the logs?

  • @Glen M, Thanks for that. I have worked out how to use U-Centre. I can change the baud rate and then reconnect. The comms link is flashing green and I can read the data in the text window. . I can see the sat data, etc after re-connecting. Once I disconnect and lose power. The baud rate goes back to 57.6k.

  • Can I briefly take the discussion back to the M8N? I have bought one from FoxtechFPV and have found it much less sensitive the 3DR ublox indoors, but able to obtain more satellites outside.  Previous discussions have talked about the configuration file for U-Centre. I have connected to U Centre and can talk to the GPS. Everytime I change the baud rate to 38400 and save the configuration and disconnect it, it reverts to 57600. I'm not sure if I am doing something wrong or it has no battery for flash.

    Is there a command string that APM and Pixhawk write to the compass to configure it?  As well, what is the setting to turn on all of the satellite networks for the M8N?

    Thanks,

    Joe

    • Developer

      By the way, the GPS driver is suppose to work at baud rates higher than 38400 although I have never tested that this works reliably.

    • The reason your config isn't saving on the m8n is because you are unable to write to the rom after changing the baud rate, since u-center will still be connected to the gps at the original baud rate.

      The way I do it, is make all of the config changes except baud rate, write the config to rom, then change the baud rate to 38400 in the gps config, then in u-center change the baud rate you're connected to the gps at to match. You will then be able to write the changes to the rom. You can see when you're connected in u-center when there's a green dot down the bottom somewhere that flashes when you bring up a new page in the config or try to write anything. When it's not connected, or has a baud rate mismatch, changing pages in the config doesn't make the dot flash.

      Hope that makes sense!

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars It's just something that's easy to track with chroma keying. I ended up using different colors on th…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
DIY Drones via Twitter
First impressions of the Intel OpenBot https://ift.tt/36qkVV4
Nov 10
DIY Robocars via Twitter
Nov 9
DIY Robocars via Twitter
Excellent use of cardboard instead of 3D printing! https://twitter.com/Ingmar_Stapel/status/1324960595318333441
Nov 7
DIY Robocars via Twitter
RT @chr1sa: We've got a record 50 teams competing in this month's @DIYRobocars @donkey_car virtual AI car race. Starting today at 10:00am…
Nov 7
DIY Robocars via Twitter
Nov 6
DIY Robocars via Twitter
RT @a1k0n: Car's view, using a fisheye camera. The ceiling light tracking algorithm gave me some ideas to improve ConeSLAM, and having grou…
Nov 5
More…