Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

Views: 305721

Reply to This

Replies to This Discussion


yes I'll give it a try. It's a pitty that Missionplanner can't display both GPS data yet. I'm courios of what will happen.

Bill, you're right. So my solution is to shield the GPS antenna directly from "low elevation sats" and multipath signals. Remember my yoghurt pot trick.

Thomas, thank you for the ublox config, but..

As a every year discussion I don't agree with enabling the signal correction via SBAS. In my opinion that makes sense for 24/7 applications or those who need high absolute position accuracy. For our copters, who fly around 30min, it could lead to damage due to GPS glitches.

  • Imagine you have a 3D fix+max. satcount and take off, GPS position is a bit "off" (but doesn't matter for 30min bcs it keeps that offset the hole flight).
  • Flying around some minutes and suddenly EGNOS or WAAS data are received.(Sometimes 5min are not enough)
  • The GPS algorithm uses these values and calculates a new "correct" position(but 10m away).
  • AC navigation controller says puh, I have to correct my position...and copter flys away.

So I think we only need "relative position accuracy" where a bit off is accepted. I don't need to drop things on a 20cm target.

Randy told us, the ublox config is being sent to GPS on each boot. Is this still the case? Does this config overide the SBAS settings? Sorry I didn't have had time to investigate whats going on during boot.


Seems to depend on location. If its not turned off, I did not experience any bad habit because of activated SBAS (EGNOS ..3 Channels)@ center of Germany . (Max M8Q with small active patch) I additionally disabled QZSS @ GNSS Config.

@Emin: Peter showed a direct log comparision at drones-discuss between Max M8Q and LEA 6H as well between Max M8Q and NEO M8N, quite impressive.

thanx for posting very clear pictures for connecting NEO-M8N to pixhawk. that would be a great help. i think configuration for the Neo-M8N has to be through a configuration utility (if config is needed). have to get it ASAP.


Hopefully someone can help with a log-download issue. I have been testing 3.2rc on 2 pixhawks without issue; flyes great and logs are downloaded easily through USB.

I then loaded 3.2rc2 on an APM, and it has become impossible to get the logs off the flight controller. I try to download over mavlink, but no matter what I end up with the attached error. I see it start to download, but then it fails:

Any idea what I should be doing differently? do i need to change any telemetry radio settings to make this work?



P.S. I tried to first post on the ardupilot forums but although Stefan tried to help, no solution has yet been found.


I believe that there may be a problem with the capability of the CSG M8Q to handle a Measurement Period of 200ms (5Hz).

I too have seen the data stream glitches, when using U-Center, at a Measurement Frequency of 5Hz.

Switching back to a Measurement Frequency of 1Hz (default) cured the data stream glitching.

Also, the HDOP value appears to be stuck at 1.1 no matter how many sats are presently be acquired.

PS: It appears that U-Center does not decode the number of sats and the HDOP when in the UBX (binary) mode.


TCIII ArduRover2 Developer


     Yes, the config is being sent to the ublox on each boot.  It doesn't send everything though and I had a look in the AP_GPS_UBLOX.cpp file to see what exactly it's sending but even for me that would take a bit of a review.  It also tries to turn off messages that it doesn't recognise.


    Ok, thanks for the report.  The vehicle is disarmed in stabilize mode?

Hi Randy,

Yes sir - disarmed and in stabilize.


Going to have to disagree with you here.

If I let my uBlox LEA-6 run for about 1/2 hour inside the house away from any windows, I can usually acquire around 12 - 14 sats in the afternoon on a good day here in southern Florida.

The HDOP is usually around 1.4 - 1.6 and the vehicle position is rock steady.

Also, if I go outside and run my rover with unobstructed view of the sky, I can usually acquire 12 - 14 sats with an HDOP approaching 1.2 on occasion in the afternoon.


TCIII ArduRover2 Developer


Since I am using U-Center, and not the MP connected to my Pixhawk which at boot up will send configuration parameters to the GPS, the reason for the data stream glitches, according to Craig Elder, is that the GPS is sending back unnecessary messages that are eliminated by the configuration parameters sent by the Pixhawk. The reduced number of required messages reduces the GPS transmission overhead thus eliminating the glitching.
However, that does not explain why you are seeing the glitches in the MP assuming that you have the M8Q/N connected to your Pixhawk and are using the MP to communicate with the Pixhawk over MavLink?
Could it be that the present GPS configuration parameters being sent to the M8 by the Pixhawk firmware are not correct for eliminating superfluous messages?
Tom C ArduRover2 Developer

Thanks Randy,

with the help of that nice USB port I was able to connect and also booting up pixhawk at the same time. In Ucenter I recognized that the port was still set to SPI and also that the small lock was locked. I guess "you" didn't have a chance to change settings for the very first time. I set it to UART1 manually, unlocked the lock and safed settings. (Baudrate still at 9600)

I disconnected every power source, reconnected, booted up pixhawk and tada your values had been sent. Now baudrate is at 38400 as expected. Also rate settings to 5hz.

Could sb confirm this? pls make a backup of the settings so you could repeat that procedure.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service