Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

Views: 305622

Reply to This

Replies to This Discussion

True: The u-blox 7 engine (chip) itself features more, even Galileo, which doesn´t exist yet ;-)

But : According to the pics, this Hobbyking board comes with a 1575MHz (GPS only) patch, same family DJI is using for the NAZA, btw..  

... but you can buy the dual band antenna from Digikey and put it on the HK board and have an enclosure. It's 10 cm larger but it looks like it might fit in.

http://www.digikey.ca/product-detail/en/CGGP.35.3.A.02/931-1153-ND/...

thanx terry, that was something i did not think about before ordering ublox 7 form hobbyking. i will try to upgrade it using sparkfun antenna.

When i use the pixhawk testing 3.2rc2 i found two bug 

1.Running 3.2rc2 without any peripherals, just use usb connect pixhawk.than pixhawk running good and leds hand yellow double flash.But after a period of time,leds stop flash and FMU froze.If i connect full of peripherals(Safe key,GPS,Power module),it just running gread,and never froze again.

2.When the Channel 7 or 8 choose AutoTune, and then use the mission planner do radio calibration pixhawk froze.

sorry my English is not so well, all those use google translation.

Does the sparkfun antenna receive the higher frequency GLONASS?

@terry, i meant the digikey antenna. sparkfun was written inadvertently.

Hi

here is comparison of LEA6(red) and M8N(blue) (behind the house)

LEA6 setting: GPS_TYPE=2(ublox); connected to GPS port; factory settings overided by pixhawk boot

M8N setting: GPS_TYPE2=2(ublox); connected to Serial4/5; didn't check if overided, but elevation set to 10°, SBAS off

Raph I got the same error during log download over mavlink.

Wow there are so many Mavlink Bad Packet (crc fail) messages in debug console... now I know why connecting via mavlink is sow slow since I use a pixhawk. APM has no problems. Fast connection as usual. My SiK firmware is 1.6.

Marco had same issue some weeks ago:

http://youtu.be/ZrihdM0txdw

Somebody said:

"If you untick ECC on both modules that should solve the issue.."

So I'm going to test that tomorrow.. Hopefully this is not caused by serialport or gps settings.

Ravi,

I'm very interested in you results, with stock- and CGGP.35.3.A.02 antenna. That price is unbelievable.

hi,

1. I've only seen pixhawk freezes when GPS or other UART(Rx/Tx) devices were connected in reverse(Tx/Rx). So I can't imagine the reason, perhaps it could hang if an auto detection routine went into time-out if nothing was detected.

2. maybe you reversed RC-in and SBUS input? It would be great if you could upload a picture of your wiring.

So if you like football, 3.2 can do the ball game too, otherwise trimming the hedge :-)

Randy, did you investigate that glitch behaviour happened in your youtube video?

> here is comparison of LEA6(red) and M8N(blue) (behind the house)

wow ... amazing. I am assuming HDOPs also followed that trend.

 

So just to be sure, you used the M8N from csgshop with "stock" GPS+glonass antenna?

I wonder how the M7N will compare to the M8N with upgraded GLONAss antenna, in the US ...

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service