Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

Views: 305593

Reply to This

Replies to This Discussion

Christian,

I will check the THR_MID setting and thank you for the reply.  However, I may not have articulated the issue correctly.  I seem to have sufficient throttle available to me in stabilize.  My issue is when switch from AltHold or Loiter (didn't try other modes yet) to Stabilize; the RPM of the motors drop, quad starts a moderate descent, and I have to adjust the throttle to prevent a hard landing.  After I've recovered, all seems well.  Regards

Hi all, just loaded AC3.2-rc3 but my 433MHz telemetry stopped connecting, really odd, it was connected just before ungrading from 3.1.5 to 3.2-rc3 but now it will no longer connect?

The two radios talk to each other and load their respective settings which are identical, also tried two different PC's, is there something new in 3.2-rc3 that needs to be changed to allow connecting?

Went back to 3.1.5, connects no problem, tried 3.2-rc3 again, nothing...

What is stopping 3.2-rc3 from connecting via mavlink?

The board is the Pixhawk compatible AUAV-X1, maybe some hardware incompatibility or setting?

Thanks for your help Brandon.  I did an accel cal after loading rc3, but somehow overlooked the dreaded compass cal in the red Warning #1.  So as you suggested, i armed connected to mp and sure enough i needed both cals.  All is now well in IRISville.  Appreciate your directions! 

Here are the before THR_MID and TRIM_THROTTLE params.  I adjusted THR_MID to TRIM_THROTTLE and will test. 

Hi people,

I've been flying and updating my 3DR quad since day one, now suddenly I'm having big problems :-(

After the new firmware/software update.......

1: In Mission Planner, my quad now has a 90 degree compass offset.

2: In Mission Planner, although I can connect with the 3DR radio, Mission Planner cannot see the modem in the setup screen.

What am I doing wrong here ?

Oh, the Beta version of Mission Planner does not give Compassmot in the CLI anymore either....

Sorry, APM 2.5

Conanony,

There are also a few other people having these behavior. It started two weeks ago. It was a very intermittent connection, grown to a lost connection. We disabled the ECC box in telemetry settings. That worked well for a week, and today I can't connect to all 3 of my copters. It's independently of the USB device. I tested already two. I updated all devices to SiK version 1.9 but no luck. The RSSI is decreasing exponentially to distance. The connection can only be established within one meter and RSSI is totally lost after 3 meters. Maybe some strange atmospheric disturbances?

Edit: happens with 3.1.5 till 3.2 RC3, APM and Pixhawk

Test report AC3.2-rc3:  I did auto mission with Do_set_roi.  The flight is rather smooth and nice except that when ROI started, there's a brief oscillation in both roll and pitch as shown in line numbers 2731 up to 2957. Please see attached log. Thanks

Attachments:

hi, you never know could be solar particles because of solar flares. they were predicted for this year. christian by the way which connector of pixhawk do u connect the second compass. i guess *- rc3 has provision for three external compasses.

We've just found a mostly innocuous bug in -rc3.  I've added it as Warning #2 in the main discussion above.

The bug is a missing bracket in this line.   This issue is that for PX4/Pixhawk users, their vehicle could have the throttle/radio failsafe triggered even if it's been disabled through the mission planner's Failsafe set-up page.  This throttle failsafe is triggered when the PX4/Pixhawk stops receiving updates from the receiver which can happen when the TX is turned off or the receiver is pulled loose.  Now most users would want a failsafe to trigger in this case so it shouldn't be a problem.

If you generally do *not* set-up your throttle failsafe I would recommend waiting until -rc4 is out which will include the fix.

Could this also have been a PixHawk bug in the V3.1.5? Because it will not "hold" my setting for the Trottle failsafe.

Paul,

    No that issue must be different.  More likely to be a mission planner issue although it's hard to be sure.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service