Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

Views: 305103

Reply to This

Replies to This Discussion

Hello Micha,
Yes, I also tried individually directly with the receiver, but the strange thing is that at the start and after the initialization of the flight controllers ESC start doing Beep, Beep as if there is no signal from the FC.
Emile told me that the problem of calibrating a release 3.2RC3 released for the beep at the start of the ESC should I increase the parameter TRIM Motor.
No I do not use the D4R-II with 27 ms firmware, I installed this firmware ArduCopter-vrubrain-v51-PPM, as it says on the website of VR μBrain.

greetings

Right, i did not change the firmware on the VRbrain. They came with 3.2 RC2. D'ont tell me there is a separate firmware version for SBUS and PPM? That could explain a lot..

About the esc's, have you tried playing around with the endpoints of your trottle channel on your transmitter?

I confirm that rally point no work on PIXHAWK AC3.2.RC3, also when rtl is invoke by failsafe (battery) or manualy, drone start to climb....I switch to manual mode to stop climb.... RTL Alt is set at 15m and  I set rally point to 30m......

sorry Rainer, but that's the batt part. I was talking about the throttle failsafe.

As i performed (without any luck) on http://copter.ardupilot.com/wiki/throttle-failsafe/

:-(( 

Hello Micha,
I solved I changed the ESC and everything is ok, for the calibration I made one at a time with the receiver.

regards Fabio

Good to hear you resolved it. :) Do you like the way it flies? I do ;)
for my part i got in touch with Roberto,sent him the logs and he is looking into it.

Randy, if i can have a moment of your time. Roberto from Virtual Robotics and i are trying to resolve an issue i have with random failsafe triggering on 2 different copters.  I use a D4R-II flashed with the 27ms  firmware and a  Micro VRbrain 5.1 using cppm.
I have seen on youtube that you have a simular RX. Have you flashed it with the 27ms firmware? If so, could you check if you get random failsafes with a Micro VRbrain if you can find the time?
Thank you.

Btw. Pixhawk is not affected by this issue and works just fine.

Hello,
Today I made ​​the first flight with VR Micro Brain 5.1, I was very satisfied with the behavior in flight, very smooth, without bumps and jolts, listening to the sound of their engines was very smooth and progressive accelerations and decelerations, the only strange thing ruotavo when the quad on himself left very, very slowly while turning to the right a bit faster in the other direction either pitch or roll was very responsive and fast.
I do not know where to look in the parameters (if it is a setting), as regards the behavior mentioned above.

greetings

randy, so does that mean the pixhawk would support 2 compasses? is the second I2C port via the small I2C expansion board?

@Ravi,

The pixhawk and px4 support two compasses in total.  So there's one internal compass (i.e. built into the board and cannot be disabled easily) and then one additional external compass (like on the GPS+Compass module) can be attached using the I2C port.

thanx randy for clarification. after loading rc3 on pixhawk the mission planner was asking for 2nd compass calibration. i think rc2  was using only one compass. either internal or external. rc3 uses both compasses. is that right?

To be clear, arducopter/arduplane/ardurover actually we only ever uses one compass at a particular moment.  This is quite different than with the accelerometers where we mix the outputs from as many IMUs as we have on the board.

So AC3.2 (including -rc1, -rc2, -rc3) will fall back to one of the other compasses attached.  So if you've got an external compass it will be used by default but if it fails it will try to use the internal one.  The problem with -rc2 and earlier was that we didn't insist that the internal compass was calibrated meaning if it did fail-over to the internal compass it was unlikely to work well.  This happened to be at the Sparkfun AVC competition and made it blatantly clear to me that we needed to fix the compass failover code.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service