Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

Views: 305678

Reply to This

Replies to This Discussion

I tried the new 3.2 code on my traditional heli last time. Stabilize works, however ..

Is it an intended feature that the tail rotor does not react in acro mode, when i move the yaw stick of my RC?

I only tried it with a unplugged motor. Unfortunately, there are no logs because for some reason the code with enabled logs is to big for my APM2. With AC 2.9 the tail rotor reacted immediately on yaw commands though the code and behavior has changed a lot since.

Here's my original thread about this issue:

http://diydrones.com/forum/topics/newb-pixhawk-doesn-t-seem-to-work...

It has nothing to do with waypoints.

Steve,

     -rc3 should be out next tuesday or so.  The most critical issue is the pixhawk is crashing fairly often when connecting with the AP Planner 2.  It only happens on the ground and we're getting close to a solution.

Hi Randy, thanks for the good news.  tested Ac3.2-rc2 on auto and it seems there's really pulsating throttle when climbing from one waypoint to a higher waypoint. Please see the attached log (CTUN-ThrOut). I hope this is fixed in -rc3.  Regards.

Attachments:

Rich have you got the Pixhawk installed in a frame complete with the 3DR Power Module ?

Or are you bench testing with just USB power ?

It's installed in my FW450, with 3DR Power Module, 3DR ublox GPS, FrSky X8D receiver connected via its Sbus output to the PixHawk RCIN.

I contacted 3DR support, and they confirmed the issue and advised me to use 3.2 RCx until a final 3.2 is released.

Thanks for this good news.

Matthias, AC3.2 rc2 is completely untested on tradheli, so I'm not sure what is going on with your yaw.  I had to do a number of fixes before I try flying it.  I've got a Pull Request in for those fixes but I don't know if they'll make rc3.  

I put a warning out not to fly AC3.2 on Tradheli yet.

Ohh... this is indeed an interesting fact ;-)

Thank you for your reply.

By the way: How do you make changes to an already sent pull request? Creating a new commit in your branch stashing the old commit (or reverting it?) and then just synchronizing, or creating a complete new pull request?

i tried the Neo-7 GPS and compass module from hobbyking. it is giving a position error of 500meters. i really do not know why. although i get satellite count as 9.

I make a simple quad copter by ArduCopter 3.2RC2 on P4FMU only.  The receiver is FrSky TFR4-B.

I set ARMING_CHEK to 0 (zero) to disable pre arming check to escape safety button function.

The armed and disarmed function are working by observation of Mission Planner.

However, the actual out put of CH3 is not activated at all.

I think this is not normal but just give a try to avoid PX4FMU to garbage:-(

Any idea?

Hattori-san,

     We don't officially support the px4-fmu only configuration although we think it should work.  By the way, you can disable the need for the safety switch by setting the BRD_SAFETYENABLE parameter to 0.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service