Hi everyone, Ive got a F550 converted to 680 with DYS 65oKV motors and APM 2.6.

Had 3.1.5 installed initially but upgraded to 3.2.  Since then I get about a max 1-2 mins flight time on 4S 8500mah battery and no motors spinning on arming.  This is completely weird behaviour and since 3.2 cannot even look at the logs properly and no terminal to do reset....

What is wrong with this and how can I either erase the amp and reinstall 3.1.5 or at least fix the issues I am having.

Any advice please grateful accepted.


Views: 501


Reply to This

Replies to This Discussion

Looks like MOT_SPIN_ARM is set to 70, have you tried increasing it slightly? I don't use spin on arm, but do you motors spin up as soon as you lift the throttle? Wondering if there is a dead band at the bottom.

Your bin log is longer than 1 or 2 minutes, looks to be 10 minutes to me.

3.2 does allow log review, but not using CLI anymore....use review data flash logs in flight data if using Mission planner. EDIT, I just also tried using Log Browse on the CLI page and it loaded your BIN file fine too. So not sure what you mean.

Looks like you had a battery voltage fail safe at 13.2 Volts after about 10 minutes which is as you have it set (3.3V per cell so fine), and used about 4000mAh from the battery assuming you power module is correctly calibrated. 


I appreciate your input Stu. Thanks I'll take another look and see what's going on.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service