I just built my Arducopter however, when i connect my battery to the set up the escs start beeping indicating there is a problem with the voltage. When i connect the battery to a lipo battery charger i get and error saying the second cell is below voltage (about 1.3v). 

I thought it was a faulty battery however i got a second battery (of a different brand) and the same thing happened to the same second cell so I'm wondering if it is possible for the arducopter set up to cause a battery to loose all the voltage in a cell.

What sort of issue could cause this kind of reaction from lipo batteries?

If it helps I got the jdrones kit. Info of my hardware is below

- APM2.5

- 4 x Servo motors (850Kv)
- 4 x ESCs (20Amp)

- Zippy 4000mah 40C 3S battery

- AR8000 spektrum RX (connected to the TM1000 telemetry module)


Many Thanks in advance

Views: 626


Reply to This

Replies to This Discussion

Not pointing a finger on this one.  When I was looking for batteries I had read that the Zippy Batteries had that problem.  Hooking up to the Quadcopter isn't going to take out one cell unless it already had a problem.  My suggestion would be is to get one of the Turnigy Nano Tech batteries and try it.  They are cheaper but they have worked in everything that I have.  Its really hard to blame the quad for the problem.  Because when you plug it in, it doesn't choose a cell.  All the cells are in series. I would really look into a different type of battery.

Maybe a problem with your charger... try to measure each cell with a voltmeter after a complete charge (on the balance plug).

I use Zippy for years and never had this kind of problem. I don't think the quad is to blame...

Good luck

As long as you have nothing connected to the balance port on your battery in Arducopter, I really cannot see anything that could feasibly cause this problem except a bad battery. When you connect something to the main power leads of your Lipo, it cannot decide which cell it's drawing current from as it's wired in series. In a normal battery all cells will discharge equally (or very nearly). 

I know you've tried a second, but the only other feasible explanation is a bad charger as olivier said.

I forgot to mention, my first battery was a Turnigy 4000mah 30C 3S. This Zippy battery is my second battery that developed this problem after being connected. Perhaps its just a coincidence?

Sounds like a faulty balancing circuit on the charger (or external balancer). Either that or the balancer wasn't hooked up properly.

Hmmm perhaps. In that case, why would the ESCs beep the tone for odd voltage? 

Just as an added note, it only seems to beep the voltage problem when i connect the APM 2 to the PCB. When I power the APM2 separately (i take off the jumper) the ESCs don't beep about voltage.

Not sure about the ESC beeping. There are lots of reasons why the ESC would beep that are not related to the cell voltage. That might be unrelated to the battery issues. How are you hooking everything up like the ESC and the APM? If everything is hooked up properly and there are still issues the charger is likely the culprit.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service