I wanted to start a conversation around the roll and pitch of Arducopter drifting as you fly.

 

The reason is I just assembled new hardware and problems that weren't there before have now shown up in a bad way. Flying indoors in a 5ft space I was able to get up to 30° error in roll and around 10-15° in pitch. I was able to control it and it flew perfectly level the whole time, I just had to hold the stick into the corner of the radio. Lading and waiting corrects the issue.

 

What could cause this. I had been flying an older version of the IMU this whole time. This version has an analogue filter for the gyros where the new hardware has it as an option. You must solder the pads around the gyros to enable them. I was also flying with two slightly tweaked motors giving off a lot of vibration. This could affect the accels. 

 

My question is: If you have a problem like this, what is the vibration level on your copter, and do you have the filter pads soldered? 

 

And notice I didn't say "loss of control" or "it didn't fly stable". I had control, and it flew perfectly. It just lost it's reference to the ground and I had to compensate with the stick. Had it been worse than 45° I would have lost control. 

There are three pairs of pads, each with a white outline. (look for GYRO-XY near the relay).

Jani Solders his to enable the filter. I have never flown this board until now. I will solder them to test the filters this week.

 

Views: 5233

Replies are closed for this discussion.

Replies to This Discussion

On page 14 in the manual for the Z-Gyro I found this clause


"If the AutoZero function is not used, the AZ pin ( pin 24) should be connected to ground."


It looks like the AZ pin unconnected on the Eagle files I have. What effect will it have to this pin floating on the performanze of the Gyro?

I have first version of sensors/oilpan. There are no filter pads there. Wht can I do?
Guntars, I seem to recall that the first version of the board had them on by default. We added the solder jumpers and made the filters optional because the airplane guys found it worked better for them without them.
Thank You, Chris!

any more info on this?

 

Same here...

 

Did you try to connect it to the ground ? Any effect ?

jason claims to have this totally solved.

ask jason.

really! is there a thread? 

 

There is no access to the solderpad.
Solved what? AutoZero Pin? What is that?

look at the title:  "Arducopter Drift issues"

 

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service