After verifying that Altitude hold and loiter was working properly (without any toilet bowls) I tried the Auto mode with horrible results. 

Checking the logs it seemed like the copter thought it was about half a kilometer away when it got out of control. 

I also checked the HDOP of our location and it was under 2 at the time we were flying (HDOP is always under 3)

I have attached logs from two of our flights in auto mode. 

Thank you for helping. 

edit 3/3/15:

This problem is mostly fixed:

What I did:

1. I used a new GPS module (same model) and mounted it on one of the arms that are farther away from the receiver (south west arm in the picture, if up is North)

2. I used autotune mode to tune the stabilize gains (http://copter.ardupilot.com/wiki/autotune/)

3. I set the throttle to the mid position (http://copter.ardupilot.com/wiki/ac_throttlemid/)

Attached is a flight log with these changes. I do not get GPS glitches now but RTL brings the copter back to about 5 meters west of where it starts. Any help would be greatly appreciated. 

Below is the flight path:

Views: 842

Attachments:

Reply to This

Replies to This Discussion

This problem is mostly fixed:

What I did:

1. I used a new GPS module (same model) and mounted it on one of the arms that are farther away from the receiver (south west arm in the picture, if up is North)

2. I used autotune mode to tune the stabilize gains (http://copter.ardupilot.com/wiki/autotune/)

3. I set the throttle to the mid position (http://copter.ardupilot.com/wiki/ac_throttlemid/)

Attached is a flight log with these changes. I do not get GPS glitches now but RTL brings the copter back to about 5 meters west of where it starts. Any help would be greatly appreciated. 

Below is the flight path:

Attachments:

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service