ArduCopter V2.9.1b APM2.5 - Alt Hold / Yaw Tuning (Heavy Aluminum Quad)

Hey Everyone:

I have a heavy home built quadcopter and am having some issues getting it properly tuned. I've tried to give as much detail as possible. Hopefully this will help! Thank you so much for your help, input, and suggestions!


  1. Slow Yaw after takeoff
    The copter slowly yaws counter clockwise for at least a minute. Eventually it looks like stops. I've checked the mounts, and they appear to be level and rotated straight  (I checked what I could with a level). I've also moved all ESC and power cables as far away as I could. I've done the manual compass calibration dance and set my declination. I'm not sure what PID to get this to lock in.
  2. Jumpy Alt Hold
    When I engage the Alt Hold, the copter appears to be very jumpy. It will surge up and then down, sometimes even landing! I've checked my raw z-accel and it looks to be within range. (See below) I've also set my THR_MID to my average throttle (700), which I know is high, but this is a heavy copter. See spec below. Maybe I need to try larger props?


  • Homemade Aluminum Frame
  • Heavy! Approximately 5lbs (2.27kg) fully loaded (Battery, Camera, FPV hardware)
  • 4x eRC BL450S Motors (950KV)
  • 10 x 4.5 Propellers (I also have 11 x 4.7 I can try)
  • Turnigy Plush 30A ESCs

I've tuned it using the great tuning guide on this forum. I wish this was available for all the PID's! It flys great in stabilize mode (other then the initial yawing). Also, V2.8.1 was much better for me using ALT HOLD. I'm sure once I get this tuned up, it will be better then ever.


Raw Accel (XYZ)

Mag Field vs Throttle

Raw Mag vs Throttle

Throttle IN (CH3) vs Throttle Out

Throttle Vs Heading

Raw Pressure vs Abs Scaled Pressure

VCC Power


Views: 1871


Reply to This

Replies to This Discussion

Your zAccel looks marginal. You need to work on your vibration. I would try larger props, 70% to hover does not leave you much room. Your Vcc looks messed up as well. Are you using 3DR power module?

Indeed, I noticed the same spikes Vcc, but this is what I have had also in 2.9.1b.

Then someone did point me (I believe from Git) and when I did install another 2.9.1b (with fix), Vcc looks "linear".

In 3.0rc2 Vcc looks to be fixed.

Thanks Richard! I will try larger props this weekend and address my vibration again. The zAccel normal looks a little better, but I wasn't hovering perfectly.

I am using the 3DR power module. I'm not using the updated GIT version, just the version that is downloaded from Mission Planner. I may tackle that this weekend too. Before criro1999 mentioned it, I didn't think there were other versions. 

I just added a screen shot of my PIDs at the bottom.

Hi Criro1999,

Do you remember where on Git you found the 2.9.1b (with fix) firmware?  I tried to find it this weekend, but did not have any luck.  Thanks!

As I already did reply on another post for the same question, I did take it from link below, but now this is replaced by 3.0-rc2. Why you dont try 3.0-rc2? I know this is not official released, but it contains that fix.

Or you can go back in time on next link below and look for that version. Look inside "git-version.txt" file where youy find latest 2.9.1b

I spent the last couple of days rebuilding the APM Isolation.I used an old PCB cut and drilled with silicone anti-vibration fan mounts and moongel. Similar to this. The ALT HOLD no longer jumps around! I also upgraded to large props (11 x 4.7) and was able to get hover to be an average of 65%, which is much better. Finally, I put the last dev version of 2.9.1b i could find on GIT, that seemed to fix the VCC graph issue.

As always, thanks for you help!


  • Quadcopter still tends to slowly rotate. It seems like this is not a problem in LOITER? Ill have to look into this more.
  • Quadcopter looses some altitude in ALTHOLD when manuvering quickly, but then slowly regains altitude again.


Accel Graph

VCC Graph

I'm still dealing with some of the above issues.

I've decided to remove ArduCopter V2.9.1b-dev and go back to a non-dev version.  I was testing RTL and it fell from the sky and I was unable to recover. I may go back to 2.8.1 until AC3 is released, as I had less problems.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service