I am having a weird problem uploading (via USB) using Arduino .23 to a "2560" series board. I should mention that I have two "2560" boards and Arduino works with one of them correctly. Both com ports have been set up exactly the same...Com Port speed is 115,200, "set RTS on close" is checked for both. The FTDI driver is the same being used for both boards.

The first board works correctly, Arduino compiles and the sketch size is displayed, a moment later the red and green "flight mode" lights disappear and the receive and transmit lights crank until the code is uploaded. After the code is uploaded there is a slight delay and the board reboots and goes back to flashing red and green. All is good.
On the second board: Arduino compiles and the sketch size is displayed and the announcement is made that it is uploading...Arduino then sticks in that mode displaying no errors at all and never completes the upload. BUT, what happens on the APM board side is that after the sketch size is displayed the red and green light go out momentarily while the amber receive light blinks for about 2 seconds... the transmit light does not handshake blink with the receive light. After this 2 second time period the red and green light start to blink again as if nothing ever happened. 
Has anyone seen this before? I have searched exhaustively for an answer but the fact that this works for one board and not the other has me puzzled. Thanks for any input...

Views: 302

Reply to This

Replies to This Discussion

i've seen some other threads on diyd with some problems but haven't seen a solution yet. it might be the same problem or might not :)

Some questions

has the board with the problem ever worked?

which usb driver do you have installed?

have your tried resetting usb by powering your computer down?

what happens if you press the reset on the board about the same time (or just after) that arduino reports the program size?

do you have a programmer?

-the "bad" board has never been able to upload via Arduino. BUT it is able to get USB updates via Mission Planner.

-I'll have to check on the USB driver version but I checked it a month or so ago. This USB driver works for the other "2560" board.

-I have tried to do a "hard" reset by shutting down completely and then powering back on.

-I was going to try the reset button trick next. I saw this in another thread.

-no, I do not have a programmer.


have your checked rts on close when the board that isn't working is plugged in? i don't recall if it is a board/port specific or general usb setting.

as you say you should expect the same functionality from both boards and it appears to be working because the mission planner can upload a hex. have you checked rts on close with the board that fails plugged in instead of the board that works?

if all else fails you can replace the .hex file the mission uses with the one your arduino produces. you should see the location of the hex in arduino if you hold down the shift key when you click compile

Yes- I did check the "rts on close" on the non working board.

replacing the hex sounds interesting. I didn't know I could do that. Thanks for the tip (although, I would still like to get this to work and don't understand why it won't).

thanks again.

Would the file that I am replacing be the "firmware.hex" in the Mission Planner directory?

there should be a firmware for each type of craft. quad, octo, plane etc.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service