Hi, I have an EasyStar with the original ArduPilot.
I have done a lot of test's and it flew great in all modes except the auto mode.

In the auto mode it hits every waypoint like it should, but before doing so it circles around and around.
So instead of flying straight towards the waypoint, it turns and circles and then hits the waypoint. And this I repeated for every waypint as well.

Here is my route.

And here is a video of ArduPilot flying it so you can see for yourself.

Do anybody know what has gone wrong here?
I suspect it being in the code, but there are so many numbers I don't dare too changing



Views: 540

Reply to This

Replies to This Discussion


Your video is set to Private so we can not watch it.


My guess is that the Radius setting has been set too tight.


In the code it could be this:

The setting is inside the NAVIGATION: PARAMETERS section of the AP_Config.h tab of the 2.7 code.

LOITER_RADIUS 40 // meters : radius in meters of a Loiter


Or when using the ArduPilot Config Tool

The Radius Limit setting: (Default I believe is 60 meters.


These settings (I believe) are used to determine if a WP is Hit versus a Miss.  If your plane flies within the radius limit of the WP then it moves onto the next WP, otherwise it banks and comes around for another attempt.


Did  you make any changes to these settings?

Thanks you for your replay.


(I apologize, the YouTube video is now fixed.)


The LOITER_RADIUS is set to 40 meters, and the The Radius Limit setting is the default 60 meter.

I don't think those setting are the problem, the plane seems to be only 10-15 meter from the WP, and then it starts to circle.

I doesn't help to "nudge" the plane to the waypoint either.


But still, like you wrote, it seems like it misses the waypoint and has to get another attempt.

What could cause something like that when the radius setting are the defaults?

Hi Peter-Hans,


Which code are you using?  I have the same problem with Ardupilot v21 with the green board.  As for v2.7, it's for the red board, which I also tried with ArduIMU but also have the same problem.  Please share your finding, I have 5 green boards, and 3 red boards lying around that I want to give them all a try again.


My setup for the older Ardupilots:

1. Ardupilot 168 + shield board with airspeed sensor + EM406

2. Ardupilot 328 + ArduIMU + Ublox


I'll put them in my plane and give it a try this week.


Best wishes,



The board I fly is the red with thermopiles. I use the 40 meters in the code and the mission planning tool for radius limits. On windy days I expect to miss and go around for a second hit on some of the WP I fly (star pattern). Some fly into the wind and do well on first attempt, the ones running across the wind sometimes have to get a second try.

I have an older board but have not flown it. Does it work ok? I'd like to use it for FBW but everyone is moving so fast with all the newer boards... Sounds like the green ones work ok on 2.1. Do you fly any flying wings?
I just watched the video.  Nice country... Reminds me of home (Montana).  I noticed that when I save my missions as files and reload them the elevation does not get updated if I've adjusted it from what it was before.  You're right at the tree height of that big tree, when I finally figured out what was happening and why my elevation was so low I almost had to climb a big oak tree for my plane.  My video revealed that I missed it by a good 30 yards, but from where I was standing I thought for sure it was going to hit the tree.  Now I only save the missions to keep the pattern in my thoughts then I program it live w/out loading the saved file.  Takes longer but I know the initial elevation will be correct.

Hi, I am using:


- ArduPilot ATMega328 (red board) with the ArduPilot 2.7.1 code.

- ArduIMU+ V2 (blue one with ArduIMU 1.8.2 code).

- ArduPilot Shield V2.

- U-Blox5 GPS modul.


I also get an "Something is wrong!!!" message when I upload the route from the Config Tool.


And also, about the altitude. My plane doesn't seem to follow the assigned altitude at all. This video wasn't too bad, on previously flights I've had to interfere and pull the plane up again before continuing the run. It flew only 5-6 meter above ground.


(About the country, its western Noway. I believe its indeed quit similar to the north of America (Montana) and Canada.)

You need to use a bigger hit radius for starters, and probably tune your PIDs. All UAVs need to be tuned to perform well.
I'm sure this has been asked before, but I can't recall.  What radius do you use for your EZ?  What's typical?  I've left mine at 40m which on a calm day is pretty easy to hit.  Windy days I'll go back for another go at it.  I assumed that 40 was what everyone used.

Yes, I wounder about that too.


I got a "stock" EasyStar (only upgraded the motor) and mine even circles on windless days.

Is your problem fixed peter? I mean circling before hitting a waypoint. I have the same problem. Please tell us what you have done.

No, sadly I haven't fixed it. I tried editing the code/settings etc. when this happened.

I don't usually give up that easily. But after trying and trying a couple of months now, I got feed up an bought the ArduPilot Mega.

Actually, I got that today, so I haven't wired it up yet. But I am hopping the Mega will fly a bit better.


I wish you god luck on finding the problem, and hope you will post a solution here if you fiend any.

I of course haven't thrown away the old ArduPilot, so it would be fun with a solution so we can be able to use that one too.


Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service